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1 Welcome

This  manual  provides  a  basic  overview  of  installing  and  using  20-sim.  It  is  not  a
reference manual but intended as a guided tour to show you how to use 20-sim and how
to create and simulate your own models.

If  you  need  detailed  information  on  20-sim  please  have  a  look  at  the  the  Reference
Manual.

 
If you are a first time user you are advised to  read  this  manual  carefully  and  run  the
various examples to get hands on experience with the package.

Installation:  This  chapter  describes  the  various  versions  of  20-sim  and  how  to
install  20-sim  on  your  computer.  It  is  useful  for  system  managers  and  if  you
experience problems installing the package.  You  may  skip  this  chapter  if  20-sim  is
properly working on your computer.

Introduction:  This  chapter  describes  the  basic  parts  of  the  20-sim  package,  the
modeling  representations  that  are  supported  and  the  various  toolboxes.  It  gives  a
good  overview  of  the  package.  Users  who  want  to  learn  the  package  by  trial  and
error.

Equation Models: No one should skip this chapter! It describes the basic modeling
representation  of  20-sim:  (differential)  equations.  You  should  run  the  examples  of
this chapter to get a good understanding of entering equations in 20-sim.

Block  Diagram  Models:  Extremely  recommended  once  you  have  finished  the
equations.  Everyone  will  now  and  then  use  block  diagram  elements  and  in  this
chapter you can learn all about this modeling representation.

Iconic  Diagrams: Iconic diagrams or physical components are  the  building  blocks
of models of physical systems. This chapter is absolutely  worth reading for everyone
who is involved in modeling physical systems.

Bond Graphs: Bond graphs are a mathematical notation of physical systems. 20-sim
has  a  large  library  of  bond  graph  elements.  This  chapter  does  not  explain  bond
graphs but how to use 20-sim to enter bond graph models.

3D Mechanics Toolbox: The 20-sim 3D Mechanics  Toolbox  provides  you  with  the
tool that makes 3D dynamic modeling easier, the 3D Mechanics Editor.

Animation Toolbox: The Animation Toolbox offers you an easy  way  to  create  3D
Animations and view graph animations.

Control toolbox: The Control Toolbox of 20-sim contains several tools that can aid
you  in  developing  controllers  for  your  modeled  machines,  the  Controller  Design
Editor, the Filter Editor and the Neural Network Editors.

Frequency  Domain Toolbox:  The  20-sim  Frequency  Domain  Toolbox  consists  of
the Linear System Editor, FFT Analysis and Model Linearization functionality.
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Mechatronics  Toolbox:  The  Mechatronics  Toolbox  includes  the  Motion  Profile
Wizard, the CAM Wizard and the Servo Motor Editor.

Real Time Toolbox: The Real Time Toolbox  provides  you  with  C-code  generation
tools and templates for all kinds of different targets and platforms.

Time Domain Toolbox: During simulation, the time domain behavior of a model is
calculated. Based on this time-domain behavior, the model can be analyzed. A set of
powerful methods for time domain analysis is available in 20-sim.

Scripting Toolbox: This chapter contains a description of the scripting functionality
that allows you to automate tasks with 20-sim using Octave, Matlab or Python.

20-sim Unity Toolbox: This chapter contains a description of the new 20-sim Unity
Toolbox functionality  that  allows  you  to  use  Unity  3D  animations  together  with  20-
sim.
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2 Notation

In the 20-sim manual the following typographic notations are used:

User instructions are numbered:

1. Open the Simulator and start a simulation run.

Specific 20-sim menus and menu commands are in bold:

The  simulator  can  always  be  started  by  the  Start  Simulator  command  from  the
Model menu.

Files and directories are written in italic type:

The file  ScaraRobot.emx  is  located in C:\Program Files\20-sim  5.0\Models\Examples
\2D  Mechanics  (or  on  64-bit  systems:  C:\Program  Files  (x86)\20-sim  5.0\Models
\Examples\2D Mechanics).

20-sim  commands,  windows  and  window  parts  are  started  with  an  uppercase
character and written in italic type:

Drag and drop the model from the Library Browser to the Graphical Editor.

Parameters, variables and other specific 20-sim elements are written in italic type:

In the equation model the function abs is used to make the signal output equal to the
absolute value of sum of variable offset and the signal input.
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3 Installation

3.1 Versions
20-sim is available in two versions: Viewer and Professional.

Viewer/Demonstration version: This is a freeware version that allows you to load
and run models and evaluate the package. Saving of  models  is  not  possible  in  this
version.

Personal: This version is for use at home, for students and personal education. Not
for commercial,  government,  academic  or  other  organizational  use.  This  is  the  full
version of 20-sim with standard toolboxes. 

Professional: This is the full version of 20-sim with standard toolboxes.

Next to the standard toolboxes that come built-in with 20-sim, additional  toolboxes  can
be purchased. The table below shows in detail the options that are available:

 20-sim  with  standard
toolboxes

Viewer Personal Professional

Library Models v* v v

Number of Variables unlimited < 200 unlimited

Number of Equations unlimited < 200 unlimited

3D Mechanics Toolbox v* v v

Animation Toolbox v* v v

Control Toolbox v* v v

Frequency Domain Toolbox v* v v

Scenario Manager x v v

Mechatronics Toolbox v* v v

Real Time Toolbox v* v v

Time Domain Toolbox v* v v

Scripting Toolbox x v v

Additional toolboxes

20-sim Unity Toolbox x x p

 
v = included
p = has to be purchased separately
v* = included but no saving possible
x = not available
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20-sim is installed, using an Installation Manager that will lock  20-sim to your computer.
There are three types of licenses available:

Free  :  The  demonstration  version  comes  with  a  license  that  is  not  locked  to  your
computer.  No actions have to be taken after installation of the program.

Single  License:  A  single  license  locks  20-sim  to  a  specific  computer.  After
installation you have to register to get a valid license.

Floating License: A floating license allows multiple users to work with 20-sim at the
same time. After installation you have to register to get a valid license.

3.2 Requirements
20-sim is guaranteed to work on computers that will meet the following requirements:

Operating System: Windows 7, 8, 8.1, 10, 11.

Processor requirements: 20-sim requires a CPU with SSE2 support. Supported: Intel
Pentium 4 and above, AMD Athlon x64 and above.

Available Disk Space: 690 MB.

3.3 Installing 20-sim
20-sim can be downloaded from the website  www.20sim.com. This is an installation file
that  will  install  20-sim  on  your  computer.  The  first  4  steps  are  equal  for  all  users.
Depending on the type of license (single, floating) you have to continue differently.

1. Install 20-sim and start the program.

2. During Installation you will be asked to install the (optional) Python 3.7 package.
We advise to keep the default setting: Yes.

3. Start 20-sim (from the Windows Start Menu choose 20-sim 5.0).

If a valid license of 20-sim 5.0 was activated before, the program will start automatically
and you can skip the rest of this  section.  If  you  have  not  installed  20-sim  before,  the
License Activation dialog will open.  You  can  also  manually  open  the  License  Activation
dialog:

4. From the Help menu select License Activation.

http://www.20sim.com
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Use the Registration/Update window to request for a license.

5. If you have a valid license key or license file, press the Activation button to enter
your license key or browse for the license file.

If you do not yet have a valid license, press the Trial License  button request  an  trial
license or press the Buy button to purchase a license. If you want to continue in Viewer
mode (no save functionality), just close the dialog without activating 20-sim.

6. Select which kind of license you have and who should use the license.

License installation dialog.

Single License

If you are using a single license, you have to enter a license key or license file.

7. On the next dialog, select I received a license key by e-mail and enter the key
in the next dialog. When you received a license file, you have to enter the
location of the license file.
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Single License dialog.

You will be asked for confirmation (click  Activate  Now)  and  activation  will  be  carried
out. After a  successful  activation  process  the  License  Information  dialog  will  show  the
new license.

Web Activation dialog.

Floating License

Installing a floating license (Administrator)

If you are using a license that is shared by more users (floating license, also known as
concurrent  license  or  server  license),  you  have  enter  the  received  license  key  and  a
location on the server (a normal Windows shared folder) first. This location on the server
should be accessible to all users and have read/write permission. The floating license will
be stored at the selected location.

6. On the next dialog, select First Installation and then enter the license key and
the location on the server (Windows share).

On the location that you have given, a license file  20sim.lic  will be installed. Remember
the location of this file  because every  new user of 20-sim will need to enter it. You will
be asked for confirmation (click  Activate  Now) and activation will be carried out. After
a successful activation process the License Information dialog will show the new license.

Using a floating license (Other users, Administrator)

If  you  are  using  a  floating  license  that  was  already  installed  you  have  to  enter  the
location of the license file.

7. On the next dialog, select Administrator already installed server license and
then enter the license location (i.e. location of the file 20sim.lic).

After a successful entry  of the location of  the  license  location,  the  License  Information
dialog will show the new license.
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3.4 Uninstalling
You can uninstall 20-sim by clicking the Uninstall command from the 20-sim start menu.
Uninstalling of 20-sim will  not  deactivate  your  license.  If  you  want  to  move  20-sim  to
another computer, you have to deactivate your license first before uninstalling.

3.5 Deactivation
If you want to move 20-sim to another computer, you have  to  deactivate  your  license
before uninstalling the program. On the new computer you can then install the program
and activate the license. To deactivate your license:

1. From the Windows Start menu open 20-sim.

2. From the Help menu choose License Activation.

3. Press the Activation button.

4. Choose Deactivate the License and click Finish

You  will  be  asked  for  confirmation  and  deactivation  will  start.  After  a  successful
deactivation, you version of 20-sim has turned into the demonstration version. You can
now uninstall the software and reinstall it.
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4 Introduction

4.1 What is 20-sim
20-sim is a modeling and simulation program that  runs  under  Microsoft  Windows.  With
20-sim  you  can  simulate  the  behavior  of  dynamic  systems,  such  as  electrical,
mechanical and hydraulic systems or any combination of these.

20-sim  fully  supports  graphical  modeling,  allowing  to  design  and  analyze  dynamic
systems  in  a  intuitive  and  user  friendly  way,  without  compromising  power.  20-sim
supports the use of components. This allows you to enter models  as  in  an  engineering
sketch: by choosing components from the library and connecting them, your engineering
scheme is actually rebuilt, without entering a single line of math!

From the engineering sketch,

directly to a model, one on one!
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4.2 20-sim: a quick tour
The best way to experience the capabilities  of  20-sim  is  to  open  example  models  and
run  simulations.  In  this  quick  tour  we  will  show  you  how  to  load  models  from  the
Examples library and run simulations.

1. Start 20-sim.

20-sim consists of two main windows (Editor and Simulator) and a lot of tools. The Editor
opens when you start 20-sim. In the Editor you can create your models.

The 20-sim Editor.

The Editor consists of four parts:

Model tab / Library  tab: This is the part at the middle  left. The Model tab shows the
model hierarchy, i.e. the hierarchical composition (all the elements) of the model that
is created in the Editor. The Library tab shows the 20-sim library.

Graphical Editor / Equation Editor: This is the big white  space at the middle  right. In
this editor you can create graphical models and enter equations.

Output tab / Process tab / Find tab: This is the part at the bottom right. The  Output
tab shows the files that are opened and stored. The Process  tab shows the compiler
messages. The Find tab shows the search results.

Interface tab / Icon tab: This is the part at the bottom left. The Interface tab shows
the interface  of  a  selected  model.  Double  clicking  it  will  open  the  Interface  Editor.
The Icon tab shows the icon of a selected model. Double clicking it will open the Icon
Editor.

We  will  open  the  model  DiscreteController.em  from  the  Examples\Control\Standard

Control folder.

2. Select the Library tab to open the Library Browser (shows the 20-sim library).
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3. In the Library Browser select Examples - Control - Standard Control - Discrete
Controller. Your Editor should now look like:

The 20-sim Editor with the model library selected.

Note: All models in 20-sim are  stored  on  file  with  the  extension  .emx.  Library  models
can  be  found  where  20-sim  was  installed,  e.g.  C:\Program  Files  (x86)\20-sim  5.0
\Models. The  model  DiscreteController  is  stored  in:  C:\Program  Files\20-sim  5.0  (x86)
\Models\Examples\Control\Standard Control\DiscreteController.emx

4. Drag and drop the Discrete Controller model to the graphical editor (large white
area). Now the model is opened.  Your Editor should look like:

The 20-sim Editor with the model DiscreteController.emx loaded.

You can inspect the model by enlarging the Editor  window or using the zoom button. We
will continue the quick tour running a simulation.
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5. In the Model menu select Start Simulator. Now the Simulator will be opened.

The 20-sim Simulator with the model DiscreteController.emx loaded.

In the Simulator you can run a simulation and show the results in plots and animations.
The Simulator contains various tools to analyze the simulation results.

6. In the Simulation menu select Run. Now a simulation run will be performed. Your
Simulator should look like:

The 20-sim Simulator with the simulation results.

You have just learned how to open and run an example model. Try to load and run other
models from the Examples  library  to find out more about the capabilities of the  20-sim
package.
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4.3 Library
In  20-sim,  creating  models  only  takes  you  just  a  few  mouse  clicks.  By  dragging  an
element from the library  and dropping it in the graphical editor, your  model  is  actually
built the same way as you would draw an engineering scheme. 20-sim supports various
model  representations,  such  as  block  diagrams  and  iconic  diagrams.  These
representations may be combined in one model.

Library Browser

All models in 20-sim are stored on files with the extension .emx. The standard libraries
can be found in the 20-sim folder:
 

C:\Program Files\20-sim 5.0\Models

or on 64-bit systems:

C:\Program Files (x86)\20-sim 5.0\Models
 
This folder contains all the models that are visible in the Library  Browser  on the left part
of the Editor. 

You can find the library at the left of the Editor.

The library contains 3 sections with building blocks:

Bond Graph: bond graph elements

Iconic Diagrams: Physical components

Signal: Block diagram elements

The library also contains 2 sections to help you getting used to 20-sim:

Examples: example models that show you how to perform various tasks in 20-sim

Getting Started Manual: all  the  models  that  you  need  in  the  lessons  of  the  Getting
Started manual.

Open Models

All  library  models  are  open  source.  You  can  inspect  the  content  of  any  model  in  the
Editor. If the  model  contains  a  hierarchy,  you  can  use  the  Go  Down  command  of  the
Model menu to descend in the hierarchy. If a model opens a specific editor, you can still
inspect the underlying code by keeping the shift key  pressed while  clicking the Go Down
command.
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Custom Libraries

You can create your own model libraries in 20-sim:

1.  From the Tools menu click Options - Folders - Library Folders.

2. Add your folder.

3. Give it a useful name by clicking Edit Label.

4. Click OK to close the dialog.

Then you can add your own library models to the library:

5. Select the submodel that you want to store in your library.

6. From the File menu select Save Submodel.

7. Store the submodel in your library folder.

The next time you start up 20-sim, the library will show the new submodel.

4.4 Block Diagrams
Block  diagrams  allow  you  to  graphically  represent  the  mathematical  relationships
between signals in a system. They are especially suited to model control systems. In 20-
sim a large library of block diagram elements is available. The elements are displayed in
the Editor by icons.  You can create block diagram models by dragging the elements to
the Graphical Editor and making the proper connections between the elements.

Library

20-sim has a large library of block diagram elements such as linear, non-linear, discrete
and source elements. In 20-sim you can create  custom  made  block  diagram  elements
and add them to the existing libraries or combine them in newly defined libraries.

From the Library Browser (left) you can drag and drop elements into the Graphical Editor (right).
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Signals

The foundation of block diagram elements is the use of input and output signals. 20-sim
allows you to create user defined block diagram elements with  an  arbitrary  number  of
input and output signals. Signal sizes can be 1 (default) or larger.

Custom Made Models

In 20-sim you can create your own block diagram elements and save them in your own
model library. Models can have an arbitrary number of ports, input and output signals. A
specialized drawing editor can be used to give the models any kind of representation.

4.5 Iconic Diagrams
Iconic diagrams or components are the building blocks of physical systems. They allow
you to enter models of physical systems graphically, similar to drawing  an  engineering
scheme. In 20-sim a large library of iconic diagram elements is available. The elements
are displayed in the Editor  by  icons which look like the corresponding parts of the ideal
physical model. You can create models by dragging the elements to the  Graphical editor
and making the proper connections between the elements.

Library

20-sim  has  a  large  library  of  iconic  diagram  elements  such  as  electrical,  hydraulic,
mechanic and thermal models. In 20-sim you  can  create  custom  made  iconic  diagram
elements  and  add  them  to  the  existing  libraries  or  combine  them  in  newly  defined
libraries.

From the Library Browser (left) you can drag and drop elements into the Graphical Editor (right).

Ports and Multiports

The foundation of iconic diagram elements is the use of power ports. Power ports enable
the connection between elements by describing the power flow between the elements. A
power port consists of two signals  which  are  called  across  and  through.  20-sim  allows
you to create user defined iconic diagram elements with an arbitrary  number  of  power
ports. Port sizes can be 1 (default) or larger (multiports).
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Algebraic Loops and Differential Causality

Algebraic loops and differential causalities are traced automatically.  If  possible,  20-sim
will  rewrite  the  equations  symbolically  to  remove  algebraic  loops  and  differential
causalities.

Custom Made Models

In 20-sim you can create your own iconic diagram elements and save them in your own
model library. Models can have an arbitrary number of ports, input and output signals. A
specialized drawing editor can be used to give the models any kind of representation.

4.6 Bond Graphs
20-sim  was  the  first  commercially  released  software  package  to  support  bond  graph
modeling. The first version of 20-sim with  a  bond  graph  library  was  released  in  1995.
Since then a continuous  effort  to  improve  bond  graph  modeling  has  made  20-sim  the
standard in bond graph modeling.

Bond Graphs

Bond graphs are a network-like description of physical systems in terms of ideal physical
processes. With the bond graph method, the system characteristics are split-up into  an
(imaginary)  set  of  separate  elements.  Each  element  describes  an  idealized  physical
process.  To  facilitate  drawing  of  bond  graphs,  the  common  elements  are  denoted  by
special symbols.

Library

20-sim has a large library containing all standard bond graph elements. Next to standard
elements, 20-sim supports custom user made bond graph models.

From the Library Browser (left) you can drag and drop elements into the Graphical Editor (right).
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Ports and Multiports

The foundation of bond graph modeling is the use of power ports. Power ports form the
connections with other bond graph elements and consist of two signals which are called
effort and flow and multiply  to power. 20-sim allows you to create user defined models
with an arbitrary  number of power ports and signals. Ports  sizes  can  be  1  (default)  or
larger  (multiports).  For  every  port  you  can  specify  the  causality  as  fixed  preferred,
indifferent or depending on the causality of other ports.

Causality

Causal strokes indicate the direction of the efforts and flows in a bond graph model. In
20-sim  you  have  to  enter  the  equations  in  one  of  the  possible  causal  forms  only.  If
causality  is  changed,  the  equations  are  rewritten  automatically.  20-sim  shows  causal
strokes in black color for preferred causality  and  in  causal  strokes  in  orange  color  for
non-preferred causality. The Causality of a complete model is derived automatically  but
can be changed manually.

20-sim will assign causality automatically to your bond graph model.

Algebraic Loops and Differential Causality

Algebraic loops and differential causalities are traced automatically.  If  possible,  20-sim
will  rewrite  the  equations  symbolically  to  remove  algebraic  loops  and  differential
causalities.
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Custom Made Models

In 20-sim you can create your own bond graph models and save them in a custom made
model library. Models can have an arbitrary number of ports, input and output signals. A
specialized drawing editor can be used to give the models any kind of representation.

Create custom made bond graph elements.

4.7 Editor
Models are entered and compiled in the 20-sim Editor. The Editor  is  a versatile  tool that
helps you to enter models  supporting  a  wide  variety  of  systems  including  linear,  non-
linear, discrete-time, continuous-time and hybrid systems, without restricting the user to
a certain model representation. After entering and debugging, the model can be checked
and  compiled.  This  is  performed  automatically  in  the  background,  when  opening  the
Simulator.

Model Representations

Systems  can  be  modeled  in  20-sim,  using  equations,  state  space  descriptions,  bond
graphs, block diagrams, and components or iconic diagrams. These descriptions can be
fully coupled to create mixed models.
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Open Source

20-sim models are stored in files. A Library Browser is part of the program, but you can
also use the Windows Explorer for library management. All 20-sim models are open! You
can drag and drop them from the library  browser into the graphical editor to build new
models. You are allowed to store the original and changed models in separate folders to
create your own library of models.

You can drag and drop models from the library browser to the graphical editor.

Debug Mode and Fast Mode

20-sim can operate in two modes: Debug Mode   and Fast Mode . This is indicated
by the Mode button at the complete right of the toolbar. You can quickly  change between
these modes by clicking on the Mode button. In Debug Mode  all possible  checks will be
performed  and  warnings  will  be  generated  for  possible  model  errors.  Always  start
modeling in Debug Mode!

Graphical Models

You can construct graphical models (block diagrams, iconic diagrams, bond  graphs)  by
dragging and dropping models  from  the  Model  Library  to  the  Graphical  Editor.  Default

the Editor is in Selection Mode . If you want to make connections between the models,

you have to change to the Connection Mode . 

Drawing

The  icon  of  every  standard  library  model  in  20-sim  has  been  created  using  a  special
drawing  editor:  the  Icon  Editor.  You  can  use  the  Icon  Editor  to  change  the  standard
library  models or create your own  library  models.  You  can  enter  text  and  add  bitmap
pictures in every level of your model. With lines, arrows and other drawing objects you
can enhance the understanding of your model.
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Hierarchical modeling

20-sim supports unlimited hierarchical modeling. The highest levels consist of  graphical
models  (state  space  models,  block  diagrams,  bond-graphs  or  components)  and  the
lowest level is formed by equations models.

Equations

The lowest level in a 20-sim model is formed by  equations.  Equations  in  20-sim  follow
the standard mathematical notation and can be changed by the user. A  large collection
of linear, non-linear, scalar and matrix functions are available for the use in equations.

4.8 Variables, Parameters and Initial Values
Equations are the foundation for all models in 20-sim. At the lowest level of a model you
will always find equations. Equations can be  entered  in  the  20-sim  Editor.  An  example
equation model is shown below:

parameters
real m = 1.0 {kg}; // mass
real g = 9.8 {m/s2}; // gravity
real K = 2.0 {N/m}; // spring constant
real f = 1.0 {N.s/m}; // friction parameter

variables
real v {m/s}; // velocity
real interesting x {m}; // position
real Fm {N}; // net-force applied to the mass
real Fs {N}; // spring force
real Fd {N}; // damper force

equations
Fm = -m * g - Fs - Fd;
v = ( 1/m ) * int( Fm , 0 );
x = int( v , 0 );
Fs = K * x;
Fd = f * v;

A 20-sim equation model starts with the declaration of parameters and variables. In the
Equation section, the equations are entered. An equation is simply  a variable  on the left
part of the equal sign and variables or functions at the right  side.  During  a  simulation,
the equations are calculated over and over again, many time steps, while  the  resulting
variable values are be shown in plots.

You can inspect equations by opening an example model, select one of the blocks  with
you mouse pointer and select "Go Down "from the right mouse menu. If you repeat this
you will always see an equation model at the lowest level.

Variables

Variables can change value during a simulation. You can inspect the current value of  a
variables in the Variables Chooser (Simulator - View - Variables).

Parameters

Parameters  have  a  fixed  value  that  you  can  change  before  a  simulation  in  the
Parameters/Initial Values Editor (Simulator - Properties - Parameters).
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Initial Values

Some functions like an integral or a hold have an initial value. These initial values can be
entered in the equation model (see int-function with a zero initial value in  the  example
above: v = (1/m)*int(Fm , 0)) or be changed before a simulation in the the Parameters/
Initial Values Editor (Simulator - Properties - Parameters).

4.9 Simulator
After  entering  a  model  in  the  Editor  you  can  check  and  compile  it.  This  is  performed
automatically in the background, when opening the Simulator. The Simulator  is  used for
model simulation and analysis.

Plot Windows

Simulation results can be shown in plots and animations. These plots and animations can
be part of the main Simulator window or additional windows. Plots are fully  configurable.
Logarithmic  views,  true-type  fonts,  line  styles,  marker  styles  and  backgrounds  are
supported.  Plots  and  animations  can  be  made  ready  for  publication  easily  (copy  to
clipboard and paste in any document).

  

Show simulation results in plots and animations simultaneously.

Debug Mode and Fast Mode

20-sim can operate in two modes: Debug Mode  and fast Mode  This is indicated by
the Mode  button in the toolbar. In Fast mode a built-in  runtime  compiler  is  used  which
compiles the simulation model into platform specific 32-bit machine code. The result is a
dramatic  increase  of  simulation  speed.  20-sim  machine  code  runs  faster  than  the
equivalent  compiled  C-code!  Compiling  the  machine  code,  even  with  large  models,  is
done while  you  start  up  the  Simulator.  The  compiler  is  an  internal  part  of  the  20-sim
software. No external compiler or program is required!

Simulation Algorithms

20-sim contains powerful simulation algorithms for solving ordinary differential equations
(ODE)  and  differential  algebraic  equations  (DAE).  It  has  a  variety  of  numerical
integration methods: one-step, multi-step and multi-order.
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Discrete-time models

20-sim  will  automatically  detect  discrete-time  loops  in  a  model  and  assign  each
independent  loop  a  separate  sample  rate.  Discrete  signals  are  shown  in  the  Editor  in
green. Discrete-time parts are activated by time events so  that  mixed  continuous-time
and discrete-time models are handled correctly.

Events

20-sim can also handle state events based on zero-crossing algorithms. This results in a
fast and accurate event detection and localization.

4.10 Toolboxes
20-sim  contains  a  number  of  Toolboxes.  The  following  toolboxes  can  be  found  in  the
Editor:

1. Control toolbox: This toolbox consists of the Controller Design Editor, the MLP
Network Editor, the B-Spline Editor and the Filter Editor.

2. Mechatronics Toolbox: This toolbox consists of the Cam Wizard, the Motion Profile
Wizard and the Servo Motor Wizard.

3. 3D Mechanics Toolbox: This toolbox consists of the 3D Mechanics Editor.

4. Frequency Domain Toolbox: This toolbox allows you to look at model properties in
the frequency domain.

5. Scenario Manager: With this tool you can automate tasks like testing models.

The following toolboxes can be found in the Simulator:

6. Time Domain Toolbox: This toolbox contains powerful tools to inspect the behaviour
of your model using time domain simulation: Parameter sweeps, Optimization,
Curve Fitting, Tolerance analysis, Sensitivity analysis, Monte Carlo analysis and
Variation analysis. You can also use External DLL's to run your time domain
simulations.

7. Frequency Domain Toolbox: This toolbox allows you to look at model properties in
the frequency domain.

8. Real Time Toolbox: This toolbox allows you to create C-code out of any 20-sim
model for the use in real-time applications.

9. Animation Toolbox: This toolbox consists of the 3D Animation and Graph Animation
tools.

Two toolboxes run externally from 20-sim:
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10. Scripting Toolbox: 20-sim scripting allows you to run tasks in 20-sim automatically
using scripts running in Python or other scripting tools. With these scripts you can
open models, run simulations, change parameters, store results and much more.

11. 20-sim - Unity Toolbox: This toolbox couples 20-sim with the Unity game engine.
Unity allows you to make 3D animations with high quality rendering and display on
screen and VR headsets. The Unity toolbox does not come standard with 20-sim, but
has to be purchased separately.
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5 Equation Models

5.1 Introduction
Equations are the foundation for all models in 20-sim. At the lowest level of a model you
will always find equations. Equations can be entered in the 20-sim Editor.

1. Open 20-sim and select File, New and Graphical Model.

The right part of the Editor will now allow you to graphical models. That is why we have
named this part of the Editor  the Graphical Editor. The Graphical Editor  will change into
an Equation Editor if we go to the deepest level of any model.

2. Go to the left of the Editor and click the Library tab

Now the Library Browser will appear.

2. Click on Examples and System Dynamics.

3. Drag the model LorenzAttractor to the white space at the right (Graphical Editor).

Equation model of the Lorenz Attractor.

As you will see the Graphical Editor changes into an Equation Editor and equation model
is opened. This model is called an equation mainmodel, because it has no input signals,
output  signals  or  ports.  This  can  be  verified  in  the  lower  left  part  of  the  Editor  which
shows  the  Interface  of  the  model  (empty).  A  mainmodel  is  a  model  that  cannot  be
connected with other models.

4. Open 20-sim and select File, New and Graphical Model.

5. Go to the left of the Editor and click the Library tab.

Now the Library Browser will appear.

6. Click on Examples and Block Diagrams.
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7. Drag the model Oscillator to the white space at the right (Graphical Editor).

As you will see a block diagram model is opened. We will inspect the integrate element
of this model.

Block diagram model of an oscillator.

8. Go to the left of the Editor and click the Model tab.

Now  the  Model  Browser  will  appear.  The  Model  Browser  shows  the  relevant  block
diagram elements of this model.

9. Select the Integrate1 element.

Equation implementation of an integration element.
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As  you  can  see  an  equation  model  is  shown.  This  is  called  an  equation  submodel,
because it has equations which relate an output signal to an input signal. The signals are
defined in the lower left part of  the  Editor  (the  Interface).  A  submodel  is  in  general  a
model that can be connected to other submodels using signals or power ports.

In the next sections we will show  how  to  create  equation  mainmodels  and  submodels.
We  will  start  with  a  simple  mechanical  system  and  show  how  it  can  be  described  by
differential equations. We will enter these equations in 20-sim in the form of an equation
mainmodel.  In  next  section  we  will  show  how  to  model  a  pendulum  with  differential
equations incorporated in an equation submodel.

5.2 Equation Mainmodel

Differential Equations

We consider the mechanical system of the figure below.

A mass with spring and damper.

We  will  first  derive  the  necessary  equations  for  this  system  and  then  enter  these
equations  in  20-sim  and  do  a  simulation.  For  the  mass  we  can  write  the  following
equation:

 
where  Fm  is  the  force  on  the  mass  m  due  to  its  inertia,  v  the  velocity  and  a  the
acceleration.  In  block  diagram  models  integration  is  to  be  preferred  above
differentiation, so we rewrite the equation for Fm:
 

 
For the spring we can write:
 

where Fs is the force on the spring and K  is  the spring constant. For the damper we can
write:
 



5. Equation Models

27Getting Started with 20-sim 5.0

 
where  Fd  is  the  force  due  to  viscous  friction  and  f  is  the  friction  parameter.  For  the
gravity force we can write:
 

 
where Fg is the force due to gravity  and g is  the acceleration of gravity. Combining the
forces leads to the following set of differential equations:
 

Equation Model

These equations can be entered in 20-sim directly as equations. We will use an equation
mainmodel.  A  main  model  means  that  the  model  has  no  input  or  output  signals  to
connect it with the outside world.

1. Open 20-sim and select File, New and Equation Model.

Make sure that 20-sim is in Debug Mode. The right part of the Editor  will now allow you
to  create  graphical  models.  That  is  why  we  have  named  this  part  of  the  Editor  the
Graphical Editor. Equations in 20-sim written in a special language called SIDOPS+. This
language is similar to mathematical equations and is easy to learn.

The taskbar of the Equation Editor.

Look at the taskbar  at the  top  of  the  Equation  Editor.  The  taskbar  contains  buttons  to
insert functions, statements and other language constructs of SIDOPS+.

2. From the task bar select the add button. Choose Equation Examples and Simple.
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Now you will see a simple example of an equation model. Your Editor should look like:

Using the add button you can insert the template of a simple set of equations.

An equation model starts with the declaration of parameters  and variables, followed by
the actual equations. You can easily  get help by putting  the  mouse  pointer  on  top  and
pressing the F1 key.

3. Put the mouse pointer on top of the word sin, click once with the left mouse button
and press the F1 key.

Now the 20-sim Help file should open with the topic on the sine function opened.

4. Close the Help File.

We will enter the differential equations from the previous topic.

5. Clear all equations from the Editor (select them and press delete).
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6. Enter the following equations (you can copy and paste them):

parameters
real m = 1.0 {kg}; // mass
real g = 9.8 {m/s2}; // gravity
real K = 2.0 {N/m}; // spring constant
real f = 1.0 {N.s/m}; // friction parameter

variables
real v {m/s}; // velocity
real interesting x {m}; // position
real Fm {N}; // net-force applied to the mass
real Fs {N}; // spring force
real Fd {N}; // damper force

equations
Fm = -m * g - Fs - Fd;
v = ( 1/m ) * int( Fm , 0 );
x = int( v , 0 );
Fs = K * x;
Fd = f * v;

7. Delete empty lines and use the tab-key to get a better layout.

Your Editor should now look like:

The equations of the spring-damper-mass model entered.

8. From the Model menu select the Check Complete Model command.
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Now the complete model will be checked. If  the  model  is  correct  at  the  bottom  of  the
Editor the Process tab should show a message indicating 0 errors and 0 warnings:

The results of model compilation are shown in the Process tab.

If any errors are found, a message window pops up,  showing  the  errors  which  20-sim
has found. The figure below shows the errors that are generated when a multiplication is
missing (m g should be m*g). You can click  on the error in the Process tab to highlight
the corresponding equation.

If errors occur, messages will be generated in the Process tab.

9. If any errors occur, try to solve them.

10. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name EquationModel.emx.

If  you  have  problems  entering  the  equations  or  checking  the  model,  load  the  model
Equation Mainmodel from the Getting Started\Equation Models section of the library.

Simulation

Now we have entered the equation model, we will proceed and show how you can run a
simulation.

11. In the Editor toolbar from the Model menu select the Start Simulator command.
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This opens the Simulator window. We will proceed with this window.

The Simulator will open with an empty plot.

12. In the Simulator toolbar from the Properties menu select the Parameters
command.

The  Parameters  Editor  shows  all  the  parameters  of  your  model.  It  is  a  useful  tool  to
quickly  change  the  value  of  a  parameter.  Check  that  the  parameter  values  of  your
model are equal to the values in the picture below.

The Parameters Editor allows you to make quick changes to the parameters in a model.

13. From the Properties menu select the Run command.
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14. The Run Properties Editor shows the simulation settings. Change the Finish Time to
15 s and the Integration Method to Euler.

The Run Properties Editor allows you change the simulation settings.

15. Specific settings for the Euler method can be selected by clicking the Set
Properties button. Set the step size equal to 0.2 s.

The second tab shows the specific settings of the chosen Integration Method.
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16. From the Properties menu select the Plot command.

In the Plot Properties Editor you can define the settings of a plot.

17.  In the Y-axis tab click Choose.

This opens the Variable  Chooser  which helps you  to  select  the  variable  that  should  be
plotted. It should look like:

The Variable Chooser shows the model variables and their current values.

18. Select the variable x and click OK.
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19. Select the Plot Properties tab and change the Title to Equation Mainmodel.

You can give a plot any desired look and feel.

20. Click OK to close the Plot Properties Editor.

21. From the Simulation menu select the Run command to start the simulation. The
result should look like the figure below.

The simulation results of our equation mainmodel.

22. From the File menu click Save.

If you had problems running a simulation, load the model Equation Mainmodel from the
Getting Started\Equation Models section of the library.
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23. Now go back to the Editor.

24. Click on the small triangle of the Variables pane at the right of the Editor or drag
the pane to the left:

This will show the Variables pane showing you all the parameter and variable values.
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5.3 Equation Submodel

Differential Equations

In the second part of this lesson you will learn how to enter the equations of motion of a
simple pendulum in an equation submodel. If we transfer all equations to the hingepoint
with angle theta, the equations of motion of a simple pendulum can be described as:
 

m·l²·s²·theta = T - c·s·theta - m·g·l·sin(theta)
 
or
 
s²·theta = (T - c·s·theta)/(m·l²) - g/l·sin(theta)
 
with:
 

theta pendulum angle (rad)

T applied torque on the pendulum (Nm)

l pendulum length (4 m)

m pendulum mass (0.25 kg)

c friction at the pendulum hinge (0.1 Nms/rad)

g gravity constant (9.8 m/s²)

 

 
Written as first order differential equations:

theta_dot_dot = (torque - c·theta_dot)/(m*l2) - (g/l)·sin(theta);
theta_dot = int(theta_dot_dot);
theta = int(theta_dot);

 
The input variable  is the applied torque and the output  variable  is  the  pendulum  angle
theta. This equation submodel will be used in a block diagram model as shown below. A
square  wave  generator  will  act  as  torque  and  the  signal  monitor  block  will  catch  the
output angle theta.

A pendulum submodel implemented by equations.

Entering Equations

These equations can be entered in 20-sim directly as equations. We will use an equation
submodel. A  submodel means that the model  has  input  or  output  signals  to  connect  it
with the outside world.

1. Open 20-sim.

Make sure that 20-sim is in Debug Mode.
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2. Select File, New and Graphical Model.

The right part of the Editor will now allow you to graphical models. That is why we have
named this part of the Editor  the Graphical Editor. The Graphical Editor  will change into
an Equation Editor if we go to the deepest level of any model.

3. Go to the left of the Editor and click the Library tab.

4. Drag the following library models to the Graphical Editor:

 model library model

 Library\Signal\Sources
Library\Signal\Block Diagram

WaveGenerator-Square
SignalMonitor

5. Select the SignalMonitor submodel.

6. From the right mouse menu or from the Model menu select the Properties
command.

7. Change the name of the model to Angle and click OK.

8. Rename the other submodel to Torque.

The Editor now should look like:

Drag and drop models from the library to the Graphical Editor.

If the submodel names are not shown,  select  a  submodel  and  from  the  right  mouse
menu choose Show Name and Bottom.

9. Put the mouse pointer in between the two submodels. From the right mouse menu or
from the Insert menu select Empty Submodel.

This adds an empty submodel.

10. Rename the new Submodel to PendulumSubmodel (right mouse menu - Properties).
Use the right mouse menu to show the name at the bottom.
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The Editor now should look like:

Drag and drop models from the library to the Graphical Editor.

11. Make sure that the PendulumSubmodel is selected.

12. From the right mouse select Edit Interface.

This will open the Interface Editor.

The Interface Editor is used to define input and output signals.

In the Interface Editor, you can define the model interface. We are going to define two
signals: one input signal (Torque) and one output signal (Angle).

13. Change the Name to PendulumSubmodel.

14. From the Edit menu select Add Port.
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15. Choose the following settings:

 Items Values

 Name
Type
Orientation
Quantity

torque
Signal
Input
torque

 
Your Interface Editor should now look like:

The input signal represents a torque.

16. From the Edit menu select Add Port.

17. Now choose the following options:

 Items Values

 Name
Type
Orientation
Quantity

theta
Signal
Output
angle
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Your Interface Editor should now look like:

The output signal represents an angle.

18. Close the Interface Editor by clicking the OK button.

Now we have defined the Interface  of our equations submodel. Next we will  change  its
appearance.

13. Make sure that the PendulumSubmodel is selected.

14. From the right mouse select Edit Icon.

Now the Icon Editor will be opened:

The Icon Editor is used to create custom made model icons.

In the Icon Editor, you can change the icon of the model. As you can see, a default icon
has  been  generated.  The  terminals  (dots  in  the  center,  indicating  where  the  signals
connections  should  be)  are  already  available.  We  are  only  going  to  enlarge  the  gray
square.
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21. In the toolbar of the Icon Editor, click the left arrow  to change to selection
mode.

22. Select the gray box.

Four orange squares, indicating the corners of the box, will now be visible.

23. While the square is still selected, go to the colorbar at the bottom of the Icon Editor.

24. Point the mouse on the color yellow and click the right mouse button.

Now  the  square  should  have  a  yellow  background  and  a  black  border  (with  the  left
mouse button the border color can be selected).

25. Select the text (name) in the middle of the square.

26. From the right mouse menu, click Properties.

A text editor pops up.

27. Change the default text to Pendulum Submodel and click OK.

28. Select the square and drag the corners until it is large enough to contain the text.

29. Select the text Pendulum Submodel.

30. Click the keyboard arrows to move the text to the center of the square (press the 
Shift button while dragging for fine movements).

31. Click on the small squares in the middle, representing the input signal (torque) and
the output signal (theta) and drag them to the borders of the square.

Now the icon should look like:

The black squares indicate the connections for the input and output signal.

32. From the File menu select Exit. A pop-up window will ask you to update the graph
first. Choose Yes.
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You Editor will now show the yellow icon. So far we have given the model an icon and an
interface. Now we are going to enter its implementation in the form of equations. Look at
the  taskbar  at  the  top  of  the  Graphical  Editor.  The  taskbar  contains  buttons  create
connections, draw lines and more.

The taskbar of the Equation Editor with the selection mode selected.

33. In the taskbar, choose the left button . This is the Selection mode button.

34. Select the PendulumSubmodel.

35. From the Model menu select the Go Down command.

The submodel has no implementation. A window will therefore pop-up, asking you what
kind of implementation you would like.

36. Select equation submodel.

Now an empty Equation Editor will be shown:

The submodel has an empty implementation.

We will enter the differential equations that where at the start of the topic.
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37. Copy the following equations to the Equation Editor.

parameters
real l = 4.0 {m};
real c = 0.1 {N.m.s/rad};
real g = 9.8 {m/s2};
real m = 0.25 {kg};

variables
real theta_dot_dot {rad/s2};
real theta_dot {rad/s};

equations
theta_dot_dot = (torque - c * theta_dot)/(m*l^2) - ( g / l ) * sin( theta );
theta_dot = int ( theta_dot_dot , 0 );
theta = int ( theta_dot , 0);

 
You model should now look like:

The submodel is implemented by equations.

38. From the Model menu select the Check Submodel command. Now the submodel
will be checked. If any errors are found, a message window pops up.

39. Return to the main model level of the hierarchy: From the Model menu select the
Go Up command.

Now we have completed our equation submodel. The only  thing that is left is to connect
it to the other models.

40. In the taskbar, choose the second left button . This is the Connection mode
button.

41. Select the submodel Torque and then the submodel PendulumSubmodel.

Now a signal should be visible pointing from Torque to PendulumSubmodel.
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42. Connect the submodels PendulumSubmodel and Angle.

Now your model should look like:

The equation submodel connected to the other models.

43. From the Model menu select the Check Complete Model command.

Now the complete model will be checked. If  the  model  is  correct  at  the  bottom  of  the
Editor the Process tab should show a message indicating 0 errors and 0 warnings:
 

The results of a model check are shown in the Output tab.

If any errors are found, a message window pops up,  showing  the  errors  which  20-sim
has found.  You can click  on the error in the Process tab to highlight the corresponding
equation.

44. If any errors occur, try to solve them.

45. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name EquationSubmodel.emx.

If you had problems running a simulation, load the model Equation Submodel  from  the
Getting Started\Equation Models section of the library.

Simulation

We have entered the model and proceed with the simulation.
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46. In the Editor toolbar from the Model menu select the Start Simulator command.

This opens the Simulator window. We will proceed with this window.

47. In the Simulator toolbar from the Properties menu select the Parameters
command and change the default parameter values to:

 Torque\Amplitude
Torque\omega
PendulumSubmodel\l
PendulumSubmodel\c
PendulumSubmodel\g
PendulumSubmodel\m

4
0.1
4
0.1
9.8
0.25

 
Note that 20-sim will sometimes use prefixes like m  (= 0.001), when working with units.
The value of PendulumSubmodel\c may therefore be indicated as 100 m N.m.s./rad.

48. From the Properties menu select the Run command and change the default values
to:

 
 

Start
Finish
Method
Step Size

0
100
Runge-Kutta 4
0.1

49. From the Properties menu select the Plot command.

50. Select the Plot Properties tab and change the Plot Title to Equation Submodel.

51. Select the Y-axis tab.

The variable Angle\plot is automatically selected.

52. Change the label to Angle.

53. Click the Add Curve button.

This opens the Variable  Chooser  which helps you to select another variable  that should
be plotted.

54. Select the variable Torque\output from the list and click the OK button.

55. Change the label to Torque.

56. De-select the Shared Y-Axes option.

57. Close the Plot Properties Editor by clicking the OK button.
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58. From the Simulation menu select the Run command to start the simulation. The
result should look like the figure below.

The simulation results of the equation submodel.

59. From the File menu click Save.

60. In the Simulator, click on the Distribute Curves button (see below).

With this button, you can separate the curves each into one plot with a shared x-axis. If
you click  on the Distribute Curves  button again, you will see the two curves in  a  single
plot with a shared y-axis. If you click on the Distribute Curves  button again, you will see
the original plot.

If you had problems running a simulation, load the model Equation Submodel  from  the
GettingStarted\Equation Models section of the library.
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6 Block Diagrams

6.1 Block Diagram Mainmodel

Differential Equations

We consider the mechanical system that was also use for the equation main  model.  In
this lesson on you will learn how to describe this system with a block diagram.

A mass with spring and damper.

The mechanical system can be described by the following set of differential equations:

Block Diagram Model

Drag and Drop

These equations can be entered in 20-sim using a block diagram. We want to obtain the
following block diagram.

Block Diagram model of the mechanical system.

1. Open 20-sim and select File, New and Graphical Model and make sure that 20-

sim is in Debug Mode .
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The right part of the Editor will now allow you to enter graphical models. That is why we
have named this part of the Editor the Graphical Editor.

2. Go to the left of the Editor and click the Library tab.

3. Drag the following library models to the Graphical Editor:

 model library model

 Library\Signal\Sources
Library\Signal\Block Diagram
Library\Signal\Block Diagram
Library\Signal\Block Diagram

Constant
Attenuate
Integrate (2×)
Gain (2×)

4. Select the Constant model. From the Model menu select the Properties command.
This will open the Model Properties Editor.

5. Rename the model to Fg.

6. Do so with all the models until your Editor looks like:

You can give block diagram elements useful names.

Connections

7. In the taskbar, choose the second left button (the mouse pointer with line). This

is the connection mode button .

8. Select the model Fg (left mouse click on top of the Fg model) and then the model m
(left mouse click on top of the m model).

Now a signal should be visible pointing from Fg to m.
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9. Enter the other connections until your Editor looks like the figure below. You can
make intermediate points (the corners of a connection) by quickly clicking the left or
right mouse button, while dragging.

If you have problems making connections please note that there are two way to make a
connection: tapping  mode and pressing  mode. With the tapping  mode you  click  the
left mouse button at the first model (do not keep it pressed but quickly  "tap" the button)
and keep tapping until the second model is reached. With the pressing  mode you press
left  mouse  button  on  the  first  model  and  keep  it  pressed  until  the  second  model  is
reached.  Intermediate  points  in  pressing  mode  are  made  by  clicking  the  right  mouse
button.

Using the connection model button, you can create connections between elements.

If you want to change there position of the models or connections, you have to switch to

the selection mode  button. You can switch to selection mode by clicking left button

(the mouse pointer) of the taskbar. Make sure to switch back to connection mode   to
make the other connections.

Splitters

10. Click on the middle of the signal pointing from the submodel v to x.

A splitter will be inserted.

11. Make a connection from the splitter to the model f.
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Your model should look like:

Click on a signal to insert splitters.

Plus Minus

12. Click on the K model to start a connection and then click on the middle of the signal
pointing from the submodel Fg to m.

13. 20-sim will open a dialog asking you to insert a multiplication or addition. Select the 
PlusMinus option and select the minus sign.
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14. Repeat this action by making a connection from the f model to make your Editor
look like:

if you end a connection on another connection 20-sim will insert a multiplication or addition.

Compiling

15. From the Model menu select the Check Complete Model command.

Now the complete model will be checked. If  the  model  is  correct  at  the  bottom  of  the
Editor the Process tab should show a message indicating 0 errors and 0 warnings. If any
errors  are  found,  a  message  window  pops  up,  showing  the  errors  which  20-sim  has
found.   You  can  click  on  the  error  in  the  Process  tab  to  highlight  the  corresponding
equation.

16. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name Block Diagram Mainmodel.emx.

If you have problems creating the model, load the model Block Diagram Mainmodel from
the Getting Started\Block Diagrams section of the library.
 

Simulation

17. In the Editor toolbar from the Model menu select the Start Simulator command.

This opens the Simulator window. We will proceed with this window.

18. In the Simulator toolbar from the Properties menu select the Parameters
command and change the default parameter values to:

 Fg\C
m\K
f\K
K\K

-9.8
1
1
2
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19. From the Properties menu select the Run command and change the default values
to:

 
 

Start
Finish
Method
Step Size

0
15
Euler
0.2

20. From the Properties menu select the Plot command.

21. Select the Plot Properties tab and change the Plot Title to Block Diagram
Mainmodel.

22. Select the Y-axis tab and click Choose to open the Variable Chooser.

22. Select the variable x\output from the list and click OK.

23. Set the following values:

 Tick Style Properties  

 Tick Style
Min. Distance (pixels)
Color

Diamond Closed
2
Red

 Scaling  

 Scaling
From
To

Manual
-10
10

25. Close the Plot Properties Editor by clicking the OK button.

26. From the Simulation menu select the Run command to start the simulation. The
result should look like the figure below.

The simulation result.
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27. From the File menu click Save.

If  you  had  problems  running  a  simulation,  load  the  model  Block  Diagram  Mainmodel
from the Getting Started\Block Diagrams section of the library.

6.2 Block Diagram Submodel

Pendulum

In the topic Equation Submodel, we have found that a pendulum can be described by the
differential equations:
 

theta_dot_dot = (torque - c·theta_dot)/(m*l2) - (g/l)·sin(theta);
 
theta_dot = int(theta_dot_dot);
 
theta = int(theta_dot);

We can also  describe  these  equations  with  a  block  diagram.  The  input  variable  is  the
applied torque and the output variable  is the pendulum angle  theta.  The  corresponding
block diagram is shown below:

Block diagram model of a pendulum.

In the block  diagram  a  square  wave  generator  acts  as  torque  and  the  signal  monitor
block catches the output angle theta. Block diagrams tend to grow complex easily  when
more elements are involved. To keep a good overview, hierarchy must be used. In this
model the elements of the pendulum part (inside the green square) will be hidden  in  a
submodel as shown below.  Still  the  square  wave  generator  will  act  as  torque  and  the
signal monitor block will catch the output angle theta.

Pendulum as a block diagram submodel.

1. Open 20-sim.

2. Make sure that 20-sim is in Debug Mode.
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3. Try to create the block diagram at the top of this topic yourself or load the model 
Block Diagram from the Getting Started\Block Diagrams section of the library.

To make a submodel out of all the elements in the green square we first have to select
all these elements. A multiple selection (i.e. more than one element selected) is easy in
20-sim. Two methods can be used:

Keep the Shift key pressed while you click your mouse pointer on various elements.

Press your left mouse button and keep it pressed while  you drag the mouse pointer
diagonal down (you are creating a square). As you move the mouse, you will see a
square and every  element in the square will  be  selected.  Now  you  can  release  the
left mouse button.

4. In the Editor select all elements that are in the green square.

Your Editor should now look like (only the models Torque and Angle not selected):

Drag a rectangle over an area to select multiple element.

5. From the Edit menu select Implode.



6. Block Diagrams

55Getting Started with 20-sim 5.0

This will make all selected elements, part of  a  new  submodel.  Your  model  should  now
look like:

Use the Implode command to combine the selected elements into one submodel.

6. Select the new submodel and click Go Down (Model menu).

This command will show us the inside of the submodel. It should look like:
 

The implementation of the submodel is a block diagram.

As you can see, 20-sim has added ports (plus and output) automatically that connect the
submodel to the outside world.

7. Click Go Up (Model menu) to go to the highest model level.

8. Select the new Submodel and change its name to PendulumSubmodel (select
Properties from the right mouse menu).
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9. Select the new Submodel and open the Icon Editor (select Edit Icon from the
right mouse menu).

In  the  previous  topic  is  explained  how  you  can  use  the  Icon  Editor  to  change  the
appearance of a submodel.

10. Change the icon until it looks like:

With the Icon Editor you can create custom made model icons.

11. From the Model menu select the Check Complete Model command.

Now the complete model will be checked. If  the  model  is  correct  at  the  bottom  of  the
Editor the Process tab should show a message indicating 0 errors and 0 warnings. If any
errors  are  found,  a  message  window  pops  up,  showing  the  errors  which  20-sim  has
found.   You  can  click  on  the  error  in  the  Process  tab  to  highlight  the  corresponding
equation.

12. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name Block Diagram Submodel.emx.

If you had problems running a simulation, load the model Block  Diagram Submodel from
the Getting Started\Block Diagrams section of the library.

Simulation

We have entered the model and proceed with the simulation.

13. In the Editor toolbar from the Model menu select the Start Simulator command.

This opens the Simulator window. We will proceed with this window.



6. Block Diagrams

57Getting Started with 20-sim 5.0

14. In the Simulator toolbar from the Properties menu select the Parameters
command and change the default parameter values to:

 PendulumSubmodel\c\K
PendulumSubmodel\g\K
PendulumSubmodel\l\C
PendulumSubmodel\m\C
Torque\amplitude
Torque\omega

0.1
9.8
4
0.25
4
0.1

15. From the Properties menu select the Run command and change the default values
to:

 
 

Start
Finish
Method
Step Size

0
100
Runge-Kutta 4
0.1

16. At the left of the Simulator, in the tree select plot under Windows1 and change its
name to First Plot (right mouse menu - Rename).

Now your Simulator should look like:

The Simulator with one plot and one curve entered.

17. In the tree at the left click on Window 1 to select it.

18. From the right mouse menu select Add Plot - Plot and change its name to Second
Plot (right mouse menu - Rename).
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Now a second plot will be visible.

The Simulator with the second plot entered.

19. In the tree, select the second plot. From the right mouse menu, select Plot
Properties.

20. Click on the Choose button to select the variable Torque\output and change the
Label to Torque.

21. Give the plot a green color.

Now the Plot Properties should look like:

Entering a plot title and hiding it for display.

22. Close the Plot Properties by clicking OK.
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23. In the tree at the left click on Window1 to select it.

24. From the right mouse menu select Tile Plots - Tile Vertical.

25. Run a simulation

Now the Simulator should look like:

The simulation results of the block diagram submodel.

30. From the File menu click Save.

If you had problems running a simulation, load the model Block  Diagram Submodel from
the Getting Started\Block Diagrams section of the library.
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7 Iconic Diagrams

7.1 Iconic Diagram (Electric)
In the previous lessons you have learned the basics of 20-sim and how to enter equation
models  and  block  diagram  models.  In  this  lesson  you  will  learn  how  to  enter  iconic
diagram models. In the first part an electric network will be entered and simulated. With
help of this model, the importance of the View menu for iconic diagram models will be
explained. After that a mechanical system will be entered and simulated.

1. Open 20-sim and select File, New and Graphical Model and make sure that 20-

sim is in Debug Mode .

The right part of the Editor will now allow you to enter graphical models. That is why we
have named this part of the Editor the Graphical Editor.

2. Go to the left of the Editor and click the Library tab.

3. Drag the following library model to the Graphical Editor:

 model library model

 Library\Iconic Diagrams\Electric\Sources VoltageSource
(DC)

The VoltageSource model has multiple implementations: DC and AC. When you drag and
drop the model to the Graphical editor, you are asked which implementation should  be
used.

4. Choose the implementation DC.

You can always change the implementation by using the right  mouse  menu:  select  the
model, right mouse menu, choose implementation.

5. Drag the following library model to the Graphical Editor:

 model library model

 Library\Iconic Diagrams\Electric\Sources
Library\Iconic Diagrams\Electric\Components
Library\Iconic Diagrams\Electric\Components
Library\Iconic Diagrams\Electric\Components
Library\Iconic Diagrams\Electric\Components

VoltageSource
Inductor
Resistor
Capacitor
Ground

6. Select the VoltageSource model. From the Settings menu select the Submodel
command.

This will open the Model Properties Editor.

7. Rename the model to Voltage.
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8. Do so with all the models until your Editor looks like:

Drag and drop models from the library.

As  in  the  figure  above,  leave  a  lot  of  space  between  the  models.  Otherwise  some
effects, explained later in this topic, might be hard to spot. Every  iconic diagram model
has one or more terminals to allow connections with other models.

9. To show these terminals, from the View menu click Show Terminals.

The terminals will be visible as open and closed rectangles:

Use the View menu to show the terminals of the models.

10. In the taskbar, choose the second left button  (the mouse pointer with line).

This is the connection mode  button.

11. Select the model Voltage and then the model Inductor.

Now a connection will be created between the two submodels.
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12. Enter the other connections until your Editor looks like the figure below. You can
make intermediate points (the corners of a connection) by clicking the right mouse
button, while dragging.

 

The complete model.

13. From the Model menu select the Check Complete Model command.

Now the complete model will be checked. If  the  model  is  correct  at  the  bottom  of  the
Editor the Process tab should show a message indicating 0 errors and 0 warnings. If any
errors  are  found,  a  message  window  pops  up,  showing  the  errors  which  20-sim  has
found.   You  can  click  on  the  error  in  the  Process  tab  to  highlight  the  corresponding
equation.

14. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name IconicDiagramModelElectric.emx.

If you have problems creating the model, load the model  Iconic  Diagram  Electric  from
the Getting Started\Iconic Diagrams section of the library.

Simulation

15. Select the Start Simulator command from the Model menu in the Editor window.

This opens the Simulator window. We will proceed with this window.

16. In the Simulator window, select from the Properties menu the Parameters
command and change the default parameter values to:

 Voltage\U
CapacitorC
Resistor\R
Inductor|L

1V
1u
10
1m

17. From the Properties menu select the Run command and change the default values
to:

 
 

Start
Finish
Method

0
1e-3
Backward Differentiation Formula (BDF)
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18. From the Properties menu select the Plot command.

19. Select the Plot Properties tab and change title to Iconic Diagram Electric.

20. Select the Y-axis tab and select the variable Capacitor\p.u for plotting.

21. Change the label to Capacitor Voltage.

22. Close the Plot Properties Editor by clicking the OK button.

23. From the Simulation menu select the Run command to start the simulation. The
result should look like the figure below.

The simulation results for the electric circuit.

As you  can  see,  creating  a  model  and  starting  a  simulation  is  easy  in  20-sim.  If  you
have  problems  creating  the  model,  load  the  model  Iconic  Diagram  Electric  from  the
Getting Started\Iconic Diagrams section of the library.

7.2 View Menu
In this topic we will give some more insight into the model of the electric circuit.

1. If you had problems creating this model, load the model Iconic Diagram Electric
from the Getting Started\Iconic Diagrams section of the library.

2. Go to the Editor.

Across and Through

In iconic diagrams, connections describe the flow of energy from one model to another.
This flow of energy can be characterized by two variables, of which the product is power.
These  variables  are  called  across  (a)  and  through  (t).  The  across  and  through
variables  make  up  a  combination  that  is  typical  for  a  physical  domain.  For  electrical
networks  these  variables  are  voltage  and  current.  In  20-sim  we  can  inspect  the
across and through variable of every connection.

3. Put your mouse pointer on top of a connection, until a little window pops up.
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It should look like the figure below (don't worry when the values are different, these are
just example values):

If you put your mouse pointer on top of a connection, the corresponding values are shown.

As  you  can  see,  the  connection  has  a  voltage  (across)  of  993  [mV]  and  a  current
(through) -39 [uA]. Across variables (voltages in this model) in the top level of a model,
are always defined with respect to a single  global reference of 0 V. This means that the
voltage is defined with respect to the ground.
 
Through variables, like the current in this model, are always defined with respect to the
models they are connected with. 20-sim  automatically  assigns  an  orientation  for  these
through variables. This orientation can be made visible  by selecting the Orientation Info
command of the View Menu.

4. From the View menu enable the option Show Terminals (click it until the option is
enabled).

5. From the View menu click the option Orientation Info (click it until the option is
enabled).

Your model should look like:

 

With the View menu you can show the orientation that 20-sim has chosen for positive currents.
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The arrows indicate the direction of the positive currents. Now you will understand why
open  and  closed  rectangles  are  used  to  indicate  the  terminals.  Open  rectangles  will
have  an  outward  oriented  positive  current  and  closed  rectangles  will  have  an  inward
oriented positive current. In the previous figure of this topic we saw a current value of i
= -39 [uA]. With the given orientation this means a current i = 39 [uA] flowing from the
resistor to the inductor.

Internal Description

6. From the View menu select Port Names Info.

7. Drag the Inductor model to the bottom, to have a better view of the port names.

Your model should have all ports (input signals, output signals or power ports) indicated
by their name:

With the View menu you can show the port names.

8. Select the model Inductor.

9. Click the F1 key or from the Help menu click Current Selection to open the help
file.

As the help file explains this model has one port p with two terminals  p_high and p_low.
These terminals  are the points where the connections with the other models are made.
Therefore p_high.u and p_low.u are the voltages on both sides of the inductor (the plus
sign in the model indicates the high voltage):
 

p.i = p_high.i = p_low.i;
p.u = p_high.u - p_low.u;

 
p.u  is  the  internal  voltage  difference  and  p.i  is  the  current  that  flows  through  the
inductor. The internal equation of the inductor is
 

p.i = (1/L)int(p.u);

10. From the Model menu click Go Down.

Now we see the internal model description. In 20-sim we can inspect the value of every
variable in an equation model.

11. Put your mouse pointer on top of a variable, until a little window pops-up.
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It should look like the figure below (don't worry  when this value is different, this is just
an example value):

Put your mouse pointer on any variable, to inspect its value.

As you can see the voltage p.u is 6.72 [mV] which means:
 

p.u = p_high.u - p_low.u = 6.72 [mV];

12. From the Model menu click Go Up.

13. From the Model menu select Show Variables.

14. In the Variable Chooser window, select the Inductor model.

Now you can see all the variables of the inductor model.

Variable values can also be inspected in the Variable Chooser.

Note that p_low.u = 993 [mV] (equal to the voltage we found at the start of this topic),
p_high.u = 1.0000 [V] and again p.u = 6.72 [mV].

Causality

15. Close the Variable Chooser.

16. From the View menu de-select all options and select Causality Info.
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Your model should look like:

The causal order of the model equations can be visualized with the Causality Info option.

The  arrows  at  the  connections  show  the  computational  direction  of  the  voltages  and
currents. This computational direction is called causality. The numbers show the order in
which the causality  is  computed  in  20-sim.  For  the  Inductor  model  this  means  that  at
both  sides  current  is  computed  as  function  of  the  voltages.  Combining  the  previous
findings, we can conclude that the following equations are derived:
 

p.u = p_high.u - p_low.u
p.i = (1/L)*int(p.u);
p_high.i = p.i;
p_low.i = p.i;

 
As you see with Causality  Info  command you can manually  inspect computational order
of your model equations. This  might  be  helpful  when  20-sim  has  problems  finding  the
correct computational order and you have to find the cause of these problems.
 
As  you  have  seen  the  View  menu  of  the  20-sim  Editor  is  an  important  aid  for
understanding  an  iconic  diagram.  We  advise  you  to  use  the  options  of  this  menu,  as
much as possible, when creating iconic  diagrams.  In  the  next  section  we  will  create  a
simple  mechanical  system.  We  will  apply  the  options  of  the  View  menu,  to  correctly
interpret the simulation results.
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7.3 Iconic Diagram (Mechanical)
In this topic you will learn how to enter a simple mechanical system  in  the  form  of  an
Iconic Diagram. We consider the mechanical system of the figure below.

Spring damper system.

 This system can easily be transferred into the iconic diagram model shown below.

The equivalent 20-sim model.

1. Open 20-sim and select File, New and Graphical Model and make sure that 20-
sim is in Debug Mode .

The right part of the Editor will now allow you to enter graphical models. That is why we
have named this part of the Editor the Graphical Editor.

2. Put the mouse pointer in the middle of the Graphical Editor.

3. From the right mouse menu or from the Insert menu select Insert, Knot and
Node.

This adds a an iconic diagram node.

4. Insert a second node.
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5. Drag the following library models to the Graphical Editor:

 model library model

 Library\Iconic Diagrams\Mechanical\Translation\Components
Library\Iconic Diagrams\Mechanical\Translation\Components
Library\Iconic Diagrams\Mechanical\Translation\Components
Library\Iconic Diagrams\Mechanical\Translation\Components
Library\Iconic Diagrams\Mechanical\Translation\Actuators

Damper
FixedWorld
Mass
Spring
Force

6. Select the Force model and rename it to Fg (select Settings menu and Submodel
command).

7. Do so with all the submodels and use the names given in the iconic diagram at the
top of this topic.

8. Select the FixedWorld submodel.

9. From the Drawing menu select the Rotate Left command.

10. Do the same for the Spring, Damper and Fg submodels.

11. Select the Fg submodel. From the right mouse menu select Show Name and
Right.

12. Do so with all the other submodels.

13. From the View menu select Show Terminals. Now your model should look like:

All the models have been dropped in the Graphical Editor.

14. In the taskbar, choose the second left button  (the mouse pointer with line).

This is the connection mode  button.

15. Select the model Fg and then the model Mass.

Now a connection will be created between the two submodels.



7. Iconic Diagrams

70Getting Started with 20-sim 5.0

16. Enter the other connections until your model looks like:

With the proper connections the model is ready for simulation.

The connections of an iconic diagram represent the power flow between the components.
The power flow in iconic diagrams is always characterized by two variables, across and
through (in this model velocity and force). The velocities are all defined with respect to a
general  reference  (fixed  world,  v  =  0).  The  forces  are  defined  with  respect  to  the
various components.

17. From the View menu select Orientation Info.

Your model should look like:

With the View menu you can show the orientation that 20-sim has chosen for positive forces.
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The orientation of the forces is  now  shown  in  the  Editor  by  the  little  arrows   and
.  When  the  arrows  point  inwards  ,  this  means  a  positive  force  will  pull  both

ends of the connection together.  When  the  arrows  point  outwards  ,  this  means  a
positive force will push both ends of the connection outwards.
 
The  connection  between  the  Fg  model  and  the  Mass  model  show  outward  pointing
arrows   .  This  means  that  a  positive  force  will  push  the  mass  upwards  and  a
negative  force  will  pull  the  mass  down.  To  generate  a  pulling  gravity  force  we  will
therefore use a negative force value in the next topic.

18. From the Model menu select the Check Complete Model command.

Now the complete model will be checked. If the model is correct at the bottom of the 

Editor the Process tab should show a message indicating 0 errors and 0 warnings. If any

errors are found, a message window pops up, showing the errors which 20-sim has

found.  You can click on the error in the Process tab to highlight the corresponding

equation or submodel.

19. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name IconicDiagramModelMechanical.emx.

If  you  have  problems  creating  the  model,  load  the  model  Iconic  Diagram  Mechanical
from the Getting Started\Iconic Diagrams section of the library.

Simulation

20. In the Editor toolbar from the Model menu select the Start Simulator command.

This opens the Simulator window. We will proceed with this window.

21. In the Simulator window, select from the Properties menu the Parameters
command and change the default parameter values to:

 Damper\d
Mass\m
Spring\k
Fg\F

1
1
2
-9.81

22. From the Properties menu select the Run command and change the default values
to:

 
 

Start
Finish
Method
Step Size

0
15
Euler
0.2

23. In the From the Properties menu select the Plot command.

24. Select the Plot Properties tab and change the title to Iconic Diagram
Mechanical.

25. Select the Y-axis tab and click Choose to open the Variable Chooser.

26. Select the variable Spring\x from the list and click OK.

27. Change the label to x.
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28. Set the following values:

 Tick Style Properties  

 Tick Style
Min. Distance (pixels)
Color

Diamond Closed
2
Red

 Scaling  

 Scaling
From
To

Manual
-10
10

 
29.Close the Plot Properties Editor by clicking the OK button.

30.From the Simulation menu select the Run command to start the simulation. The
result should look like the figure below.

The simulation results.

 

31. From the File menu click Save.

If  you  have  problems  creating  the  model,  load  the  model  Iconic  Diagram  Mechanical
from the Getting Started\Iconic Diagrams section of the library.
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8 Bond Graphs

8.1 Bond Graph Model
In  the  previous  sections  you  have  learned  how  to  enter  equation  models  and  block
diagram  models.  You  have  also  learned  how  to  enter  hierarchy  into  a  model.  In  this
lesson we will explain the basics of bond graph modeling in 20-sim. The lesson is meant
for  users  interested  in  bond  graph  modeling.  If  you  are  not  interested  in  bond  graph
modeling, we advise you to skip this section and continue with iconic diagrams.

Bond Graph Model

We consider the mechanical system of the figure below.

A mass with spring and damper.

This system can easily be transferred into the bond graph model shown below.

Bond graph model of the mass-spring-damper system

1. Open 20-sim and select File, New and Graphical Model and make sure that 20-

sim is in Debug Mode .

The right part of the Editor will now allow you to enter graphical models. That is why we
have named this part of the Editor the Graphical Editor.

2. Put the mouse pointer in the middle of the Graphical Editor.

3. From the right mouse menu or from the Insert menu select Insert, Knot and
OneJunction.

This adds a 1-junction.
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4. Right click on this 1-junction and select the Show Name menu and the None
command to hide the name of the 1-junction.

5. Go to the left of the Editor and click the Library tab.

6. Drag the following library models to the Graphical Editor:

 model library model

 Library\Bond Graph
Library\Bond Graph
Library\Bond Graph
Library\Bond Graph

C
I
R
Se

6. Select the Se model. From the Settings menu select the Submodel command.

This will open the Model Properties Editor.

7. Rename the model to Fg. Do so with all the submodels and use the names given in
the bond graph at the top of this topic.

8. Select the C model and from the right mouse select the Show Name menu and
the Right command.

This will put the element name to the right of the element.

9. Do so with the other elements (except for the Se element) until your model looks
like:

 

The bond graph elements in the Editor.

10. In the taskbar, choose the second left button  (the mouse pointer with line).

This is the connection mode  button.

11. Select the model Fg (left mouse click on top of the element) and then the 1-junction
(left mouse click on top of the element).
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This will create a connection between both elements:

The red color of the bond indicates a conflict. In this case more bonds need to be inserted.

The bond is drawn red, which means causality  could not be assigned. Don't worry! This
is  because  20-sim  has  an  on-line  causality  assignment  and  notices  there  is  only  one
bond connected to the 1-junction.

12. Create a bond between the 1-junction and the submodel spring.

Now your model should look like:

 

The orange stroke indicates a non-preferred causality.

The bond to the C model has an orange causal stroke. This means that the C model  in
this configuration has a non-preferred causality.
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13. Enter the other connections until your model looks like:

The complete bond graph model.

14. From the Model menu select the Check Complete Model command.

Now the complete model will be checked. If  the  model  is  correct  at  the  bottom  of  the
Editor the Process tab should show a message indicating 0 errors and 0 warnings. If any
errors  are  found,  a  message  window  pops  up,  showing  the  errors  which  20-sim  has
found.   You  can  click  on  the  error  in  the  Process  tab  to  highlight  the  corresponding
equation.

15. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name BondGraphModel.emx.

If you have problems creating the model, load  the  model  Bond  Graph  Model  from  the
Getting Started\Bond Graphs section of the library.

Simulation

16. In the Editor toolbar from the Model menu select the Start Simulator command.

This opens the Simulator window. We will proceed with this window.

17. In the Simulator window, select from the Properties menu the Parameters
command and change the default parameter values to:

 friction\r
Fg\effort
Mass\i
Spring\c

1
-9.81
1
0.5

18. From the Properties menu select the Run command and change the default values
to:

 
 

Start
Finish
Method

0
15
Euler
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Step Size 0.2

19. Select from the Properties menu the Plot command.

20. Select the Plot Properties tab and change the title to Bond Graph Mainmodel.

21. Select the Y-axis tab and click Choose to open the Variable Chooser.

22. Select the variable spring\state from the list and click OK.

23. Change the label to x.

24. Set the following values:

 Tick Style Properties  

 Tick Style
Min. Distance (pixels)
Color

Diamond Closed
2
Red

 Scaling  

 Scaling
From
To

Manual
-10
10

25. Close the Plot Properties Editor by clicking the OK button.

26. From the Simulation menu select the Run command to start the simulation. The
result should look like the figure below.

The simulation results.

27. From the File menu click Save.

If you have problems creating the model, load  the  model  Bond  Graph  Model  from  the
Getting Started\Bond Graphs section of the library.
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9 3D Mechanics Toolbox

9.1 3D Mechanics Toolbox
The 20-sim 3D Mechanics  Toolbox  provides  you  with  the  tool  that  makes  3D  dynamic
modeling easier, the 3D Mechanics Editor.

Bodies

You can create 3D models by dragging bodies in a 3D workspace. The representations of
each body can be changed to a sphere, block, cylinder etc. Furthermore, colors can be
changed and descriptions can be added. The size and shape  of  a  body  are  merely  for
representation, a body is fully characterized by its inertia coefficients and mass.

The 3D Mechanics Editor helps you to create 3D models easily.

Joints

Bodies are interconnected by the use of joints. Several joints are present in the library,
divided in two groups, rotational joints and translational joints. These joints can also be
drag  and  dropped  on  the  workspace.  Constraints  can  be  added  to  create  closed  loop
systems like four bar mechanisms or Stewart platforms.

Interface

The user interface has 4 different modes in which you can select, connect, translate  and
rotate  bodies  and  joints.  Much  effort  is  done  to  keep  the  graphical  user  interface  as
natural as possible. Multiple  views are supported. Besides the 3D environment, you can
see 2D intersections in the xy xz, and yz plane.

Models

The 3D Mechanics Editor can generate a 20-sim model from your 3D model. This 20-sim
model comprises all dynamics and kinematics of the model. Forces can be applied to the
joints or on to each body directly. You  can  also  couple  springs  and  dampers  from  the
mechanics  library  in  20-sim,  to  the  joints,  because  the  whole  model  is  port-based.
Gravity  can  be  set  as  an  external  force.  Eventually,  the  dynamic  response  of  the
complete model can be shown by the 3D Animation Editor.
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9.2 Double Pendulum

Introduction

In  this  section  we  will  use  the  3D Mechanics  Editor  to  create  the  model  of  a  double
pendulum. In this editor you can define the geometry  of the pendulum and  inspect  the
possible movements. From the 3D Mechanics Editor we will generate a 20-sim model that
incorporates  the  equations  of  motion  and  a  20-sim  scenery  for  the  animation  of  the
pendulum.
 
The pendulum model that we will create has actuated joints. This means we can apply  a
torque to the joints. In 20-sim, we will insert the pendulum model and connect  passive
actuation  through  dampers.  After  that  we  will  simulate  the  model  and  show  a  3D
Animation, to see how the damping affects the pendulum behavior.

Inserting Components

1. Open 20-sim and select File, New and Graphical Model.

2. In the Editor from the Tools menu select 3D Mechanics Toolbox and 3D
Mechanics Editor.

A 3D mechanics model will be inserted in the Editor  and the 3D Mechanics Editor will be
opened:

The 3D mechanics Editor.

Like the Editor, the 3D Mechanics Editor consists of several parts:

Model / Library  section: This is the part at the middle  left. The Model tab  opens  the
Model  Browser  which  shows  a  hierarchical  composition  (all  the  elements)  of  the
model that is created in the 3D Mechanics  Editor. The Library  tab  opens  the  Library
Browser which shows all the objects that can be used.

Object Properties: This is the part at  the  right  that  in  the  picture  above  shows  "No
Selection". As soon as an object is selected, it will show the name of that object and
allow you to change the object properties.
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Object Representation: This is the part at the right  that  in  the  picture  above  shows
"None". As soon as an  object  is  selected,  it  will  show  the  name  of  that  object  and
allow you to change its representation.

Graphical Editor: This is the space with the checker board at the right. In this editor
you can drag objects and create models.

Messages tab: This is the part at the right bottom, where all messages are shown.
 
The Editor has several modes of operation which are indicated by the buttons at the right
of the editor:

 butto
n

mode description

 Translation Mode Use this mode to translate selected objects

 Rotation Mode Use this mode to rotate selected objects

 Connection Mode Use this mode to connect objects

 Camera
Movement

Use this mode to change the camera view

You can choose to make objects transparent:

 butto
n

mode description

 Ghost Mode for
Bodies

Click this button to make all bodies transparent

 Ghost Mode for
Joints

Click this button to make all joints transparent

 Ghost Mode for
Sensors /
Actuators

Click this button to make all sensors and actuators
transparent

 
The Editor is in translation mode, which is suited for dragging and dropping components.
We are going to insert the necessary components to construct a double pendulum.

3. Click on the Library tab.

4. In the Library click on Bodies - Body and drag it to the Graphical Editor (the
checker board).

The first body that is inserted in the Graphical Editor will be fixed to the floor and will not
move during simulation. Our pendulum will be attached to this body.

5. Click on Edit Body button (at the left) to open the Body Properties.

6. Rename the body to Base.
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7. Select the Is Fixed World option.

Use the Body Properties dialog to change the name of a body, its position and mass parameters.

8. Click the Position button and change the position to (x = 4, y = -4, z = 0).

Set the position of the body.

9. Close the Body Properties.



9. 3D Mechanics Toolbox

82Getting Started with 20-sim 5.0

Your 3D Mechanics Editor should now look like:

The model tab shows that one body (Base) is fixed to the ground (indicated by the anchor).

10. In the Library tab click on Joints - Rotation - Actuated - X-rotation and drag it
to the Graphical Editor.

If  a  joint  is  selected,  lines  through  the  center  of  the  joint  indicate  the  possible
movements that you can make with the body. If you click the left mouse button you can
move  the  joint  over  the  surface.  If  you  press  the  Ctrl-button  while  keeping  the  left
mouse button pressed, the body goes up and down.

11. Select the joint and place it next to the body like:

In Translation Mode you can move objects easily with the mouse pointer.
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12. Click on the Edit joint button to open the Joint Properties.

13. Rename the joint to Base_Arm1.

 

Double clicking a joint will open the Joint Properties Dialog.

14. Close the Joint Properties.

15. Insert two more bodies and another actuated joint (X-rotation) and rename the
bodies to Arm1 and Arm2 and the joint to Arm1_Arm2.

Now the 3D Mechanics Editor should look like:

The model tab shows three bodies and two actuated joints.
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Creating Connections

16. Click on  to set the 3D Mechanics Editor in Connection Mode.

Now we can define the connections by clicking on the components.

17. Put the mouse pointer on top of the Base body and click the left mouse button.

Now a dotted line should  appear  between  the  body  and  the  mouse  pointer  to  indicate
that a connection is being defined between the body and a second component.

In Connection Mode you can create connections clicking the left mouse button.

18. Put the mouse on top of the Base_Arm1 joint and click again.

Now  the  connection  is  made  and  the  Create  Connection  dialog  is  opened.  In  this
dialog you can define the position offset of the Base_arm1 joint with respect to the Base
body. As shown in the Create Connection  dialog,  every  joint  has  two  connections.  We
will choose ConnectionPoint1 to start with.

19. Click on ConnectionPoint1.

20. Click on the position button and set the position to x = 0, y = 0, z = 0.
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Now the Create Connection dialog should look like:

After a connection is made the Create Connection dialog is opened.

21. Click OK to close the Create Connection dialog.

Because  we  have  set  the  offset  position  to  zero,  the  Base_Arm1  joint  has  the  same
position as the Base  body. To better see the joint we can turn on the Ghost Mode  for
Bodies, to make the bodies transparent.

22. Click on  to set the 3D Mechanics Editor in Ghost Mode for Bodies.

The 3D Mechanics Editor should now look like:

 

Use the ghost modes to make objects transparent.
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23. Make the connections 2, 3 and 4 according to the table below:

 Action First click Second click Position offset

 1 Base Base_Arm1 x = 0, y = 0, z = 0

 2 Base_Arm1 Arm1 x = 0, y = -2, z = 0

 3 Arm1 Arm1_Arm2 x = 0, y = 2, z = 0

 4 Arm1_Arm2 Arm2 x = 0, y = -2, z = 0

 
The 3D Mechanics Editor should look like:

All bodies are connected with joints.

24. Click on  to turn off the Ghost Mode for Bodies.

Checking Motion

To see if the model was defined properly we can check it and see how it can move.

25. Click on  to set the 3D Mechanics Editor in Translation Mode.

26. From the Actions menu, select Check Model.

The Message Dialog should  show  Analysis  Completed  Successfully.  We  will  inspect  the
possible motions of the mechanism.

27. Put the mouse pointer on top of the Arm1 body and click the left mouse button.

The Base_Arm1 joint will show an arrow that indicates positive rotation.

28. Keep the left mouse button pressed an move it up and down.

The body will now rotate around the joint.
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29. Repeat the movement with the Arm2 body to see its movement.

If the model is correctly assembled, you can inspect the motion by dragging the mouse pointer.

30. Select Check Model from the Actions menu to reset the movement.

During the checking all joint angles will be reset to their  initial value. Since we have not
changed the initial values (default = 0) the mechanism will return to its original set-up.

Updating to 20-sim

31. From the Actions menu select Generate 20-sim model.

A window will pop up asking you to store the model. 3D Mechanical models are stored in
a separate file with the extension 3dm. If you open a 3D Mechanics model from 20-sim,
this file will be read by the 3D Mechanics Editor.

32. Click Yes and store the model in a temporary directory (e.g. C:\temp) using the
name DoublePendulum.3dm.
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After the storage of the .3dm file the Code Generation dialog will be opened.

In the Code Generation dialog you can enter the settings for the generation of a 20-sim model.

A number of options can be set in this dialog:

Model Filename: The 3D Mechanics Editor will automatically generate the equations
that  describe  the  double  pendulum.  These  equations  are  stored  as  a  20-sim
submodel.

20-sim Scenery: In 20-sim we will show the pendulum motion in an animation. The
animation is generated by the 3D Mechanics Editor and stored on file.

Submodel  Name:  The  double  pendulum  will  be  loaded  in  20-sim  as  a  submodel,
with the name that can be entered here.

Icon: You can choose to make a snapshot of the model (automatic) or load an image
from file to be used for the model icon.

In most cases the default entries will be sufficient. We will not make any changes.

33. Click OK to export the model to 20-sim.

34. Close the 3D Mechanics Editor.

35. You will be asked to save the model. Choose Yes to save it.
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Editor

The 20-sim Editor will be updated with the double pendulum model. It should look like:

The 20-sim model of the double pendulum in the Graphical Editor.

Now it is a good time to store the model.

36. Save the model using the name DoublePendulumSimulation.emx.

37. Go to the Library tab and select the library Library\Iconic Diagrams
\Mechanical\Rotation\Components.

37. Insert the model Bearing twice.

38. Connect the two bearing models with the Base_Arm1 and Arm1_Arm2 ports of the
DoublePendulum submodel.

 

You can connect two bearing models to the double pendulum.
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40. From the File menu click Save.

Simulation

41. From the Model menu click Start Simulator.

This  will  open  the  Simulator  with  a  second  window  showing  a  3D  Animation  with  our
pendulum. You can now set the parameters values,  choose  an  integration  method,  set
the plot variables etc. We will use the default parameter values and run a 3D animation.

The 3D Animation window with the double pendulum scenery loaded.

42. Click the blue Run button to run a simulation

43. Click the green Run  button below the 3D Animation to replay the animation.

If you had problems creating the model, load the model DoublePendulumSimulation.emx
from the Getting Started\3D Mechanics Toolbox section of the library. You should see the
pendulum swinging during the simulation. Try  to change the bearing parameters to find

the changes in the pendulum movement. You can click  the Camera  button to change
camera views.
 
The pendulum model shows bodies as cubes with default sizes. A  more elegant  display
would result if we could define arbitrary  shapes.  Moreover,  we  used  default  mass  and
inertia parameters. Both can be changed in the 3D Mechanics editor as will be shown in
the next lesson.
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9.3 Scara Robot

Introduction

In this lesson you will learn how to create and simulate the dynamic model of a SCARA
robot.

A Selective Compliant Articulated Robot Arm (SCARA).

You  will  expand  the  knowledge  learned  from  the  previous  lesson,  by  introducing
mass and inertia parameters and making a more elegant display.
We will start by inspecting the robot, identify the links and mass and inertia

parameters. Then we will introduce the 20-sim model that will be used to simulate the

Scara robot. This model contains setpoint generators, controllers and drives that will

be connected to the robot.

We will proceed by entering the Scara robot in the 3D Mechanics Editor. From the 3D
Mechanics Editor we will generate a 20-sim submodel that incorporates the equations
of motion of the Scara robot. From the 3D Mechanics Editor you can also generate a
20-sim scenery that describes the animation of the Scara robot.

Finally the Scara robot model will be connected to the drives and simulated.
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Inspection

We start the modeling session by inspecting the Scara robot. The robot has a base with
arms that  can  move  in  the  horizontal  plane  and  a  load  that  can  move  vertically.  The
robot can thus be modeled using four bodies which are connected by joints. Between the
base and the first arm, a rotational joint is mounted, which can be actuated (indicated by
the  torque  T).  Between  the  first  and  the  second  arm  an  identical  joint  is  mounted.
Between  the  load  and  the  second  arm  a  translation  joint  is  mounted,  which  is  also
actuated (indicated by the force F).

Arms and joints of the Scara robot.

The robot model that we are going  to  create  in  the  3D Mechanics  Editor  will  therefore
have  to  three  power  ports.  Two  power  ports  for  the  rotation  joints  and  one  for  the
translation  joint.  To  simulate  the  robot  model,  we  have  to  connect  actuators  to  these
joints.

Geometrical parameters of the Scara robot.

The geometrical  parameters  and  the  masses  and  inertia's  can  be  found  in  the  design
drawings of the Scara robot. We will use the figure above.
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Components

The complete model that will be used to simulate the Scara robot is shown in the figure
below. The grey square with the local name robot  is  generated  with  the  3D  Mechanics
Editor.  It  represents  the  mechanical  structure  of  the  robot.  The  rotation  joints  are  by
driven  electrical  motors  (modeled  by  ideal  torque  sources)  with  gearboxes.  The
translation  joint  is  driven  by  an  electrical  motor  (also  modeled  by  an  ideal  torque
source) with a spindle. The motors are controlled by PD controllers, which compare the
desired motion (given by motion profile generators) with the actual position of the robot.

The 20-sim model of the drive system and the 3D robot model (grey).

1. Open 20-sim and load the model ScaraRobot from the Getting Started Manual\3D
Mechanics Toolbox section of the library.

2. Use File, Save As to Store the model in a temporary directory (e.g. C:\temp) using
the name ScaraRobot.emx.
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As you can see, this model contains the  drives  and  controllers  for  the  robot.  Only  the
mechanical part of the robot model is missing. We are going to create this part in the 3D
Mechanics Editor.

The 20-sim drive system model is already created: load ScaraRobot.emx.

3. In the 20-sim Editor from the Tools menu select 3D Mechanics Toolbox and 3D
Mechanics Editor.

This will insert a 3D Mechanics model in the 20-sim Editor and open the 3D mechanics

Editor. The dimensions of the Scara robot are rather small. Therefore we are going to

change the scaling of the 3D Mechanics Editor.

4. From the Tools menu in the 3D Mechanics Editor window select Model Settings.
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5. Change the Size of the Reference Frames to 0.1  and the Grid Size to 0.1 as
show below.

Changing the frame size.

6. Click OK to close the Model Settings dialog.

If the reference frame is too far away you can move the camera closer to the origin.

7. Change the Editor into Camera Mode (indicated by ), press the Ctrl-key and
drag the mouse until a good view has been obtained.

Use the Camera Mode to change the view.



9. 3D Mechanics Toolbox

96Getting Started with 20-sim 5.0

8. Return to Translation Mode (indicated by ).

We are going to insert the necessary components to construct the Scara robot.

9. Insert the following components into the Graphical Editor and rename them
according the table below.

 Action Component Name

 1 Bodies\Body base

 2 Bodies\Body arm1

 3 Bodies\Body arm2

 4 Bodies\Body load

 5 Joints\Rotation\Actuated\Z-rotation base_arm1

 6 Joints\Rotation\Actuated\Z-rotation arm1_arm2

 7 Joints\Translation\Actuated\Z-
translation

arm2_load

 Now the 3D Mechanics Editor will look like:

For the Scara robot we need four bodies and three joints.

Representation

To  make  the  mechanism  look  like  a  real  Scara  robot,  we  have  to  change  the
representation of the bodies. We will use the geometrical parameters of the robot.

10. Select the base body.

The Edit  button  of  the  Object  Representation  (at  the  left  of  the  3D  Mechanics  Editor)
should now be active.
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11. Click on the Edit button to open the 3D Representation dialog.

In the 3D Representation dialog you can change the looks of an object.

Using the 3D representation dialog, you can change the look of an object.

12. Change the representation of the base body according to the table below (action 1).

 Action Body Size Color Representation

 1 base x = 0.1, y = 0.1, z = 0.5 Green Block

 2 arm1 x = 0.1, y = 0.5, z = 0.1 Blue Block

 3 arm2 x = 0.1, y = 0.4, z = 0.1 Red Block

 4 load x = 0.04, y = 0.04, z = 0.5 Orange Cylinder

13. Do so with the other bodies according to the table (actions 2, 3 and 4).

14. Double click on the base body which opens the Body Properties dialog.

15. Make sure this body is Fixed to the World.

16. Set the Position to x = 0, y = 0 and z = 0.25 and close the Body Properties
dialog.
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If desired, you can drag and drop the other bodies to a more favorable location like:

You can give objects arbitrary shapes and colors.

Parameters

The  bodies  still  have  default  mass  and  inertia  parameters.  We  will  change  them
according to the specifications given previously.

17. Double click on the arm1 body which opens the Body Properties dialog.

18. Click the Edit button of the Inertia Properties and change the parameters of the
arm1 body according to the table below (action 1).

 Action Body Mass [kg] Ixx [kgm2] Iyy [kgm2] Izz [kgm2]

 1 arm1 8 0.1 0.02 0.1

 2 arm2 6 0.05 0.01 0.05

 3 load 0.5 0.01 0.01 0.0005

 
The base body is fixed to the ground, which make the inertia  parameters  irrelevant.  If
you want to insert then anyway, temporary remove the Is fixed world option.

19. Do the same with the other bodies according to the table (actions 2 and 3).

Connections
To assemble the Scara robot we will create connections between the various bodies and
joints.

20. Click on  to set the 3D Mechanics Editor in Connection Mode.

Now we can define the connections by clicking from joints to bodies. To make the joints
better visible, we will use the Ghost Mode for bodies.

21. Click on  to set the 3D Mechanics Editor in Ghost Mode for Bodies.
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22. Make the connections according to the table below:

 Action First click Second click Connection Point Position

 1 base_arm1 base ConnectionPoint1 x = 0, y = 0, z = 0.25

 2 base_arm1 arm1 ConnectionPoint2 x = 0, y = 0.2, z = -0.05

 3 arm1_arm2 arm1 ConnectionPoint1 x = 0, y = -0.2, z = -0.05

 4 arm1_arm2 arm2 ConnectionPoint2 x = 0, y = 0.15, z = 0.05

 5 arm2_load arm2 ConnectionPoint1 x = 0, y = -0.15, z = 0

 6 arm2_load load ConnectionPoint2 x = 0, y = 0, z = 0

 
When all bodies and joints are connected, 20-sim will start to assemble the robot. Your
3D Mechanics Editor should now look like:

20-sim will assemble all objects as soon as they are all connected.

Checking Motion

To see if the model was defined properly we can check it and see how it can move.

23. Click on   to set the 3D Mechanics Editor in Translation Mode.

24. Click on  to de-select the Ghost Mode.

25. From the Actions menu, select Check Model.

The Message Dialog should  show  Analysis  Completed  Successfully.  We  will  inspect  the
possible motions of the mechanism.

26. Put the mouse pointer on top of the arm1 body and click the left mouse button.

The base_arm1 joint will show an arrow that indicates positive rotation.

27. Keep the left mouse button pressed an move it up and down.
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The body will now rotate around the joint.

If the model is correctly assembled, you can inspect the motion by dragging the mouse pointer.

28. Repeat the movement with the arm2 and the load bodies to see their movements.

Updating to 20-sim

29. From the Actions menu select Generate 20-sim model.

A window will pop up asking you to store the model.

30. Store the model in the same temporary directory as the 20-sim model (e.g. C:
\temp) using the name Robot.3dm.
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After the storage of the .3dm file the Code Generation dialog will be opened.

In the Code Generation dialog you can enter the settings for the generation of a 20-sim model.

31. Click OK to export the model to 20-sim.

32. Close the 3D Mechanics Editor.

33. You will be asked to save the model. Choose Yes to save it.

Editor

The 20-sim Editor will be updated with the double pendulum model. It should look like:

The 20-sim model of the drive system and the robot model.

Now it is a good time to store the model.
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34. Save the model.

If you had problems creating the model, load the model ScaraRobotSimulation.emx  from
the Getting Started\3D Mechanics Toolbox section of the library. If you look at the Robot
model, you can see that it has three ports.  One  for  the  arm  base_arm1  joint,  one  for
the arm1_arm2 joint and one  for  the  arm2_load  joint.  We  are  going  to  connect  these
joints to the actuators.

35. Connect the actuators to the robot model (Gear1 to base_arm1, Gear2 to
arm1_arm2 and Spindle3 tot arm2_load), until the model looks like:

 

The robot model is connected to the drive trains.

Simulation

36. From the Model menu click Start Simulator.

This will open the Simulator. As you can see a predefined experiment is loaded, showing
a plot with setpoint and position variables. The 3D animation is filled automatically  with
the generated scenery file.

3D Animation of the Scara robot.
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37. Click the Run  button to start a simulation and show the corresponding animation.

38. You should see the robot move during the simulation. You can click the Camera 
button to change camera views.

You can also show the robot animation in the main Simulator window. Try  to insert a 3D
Animation plot. You must open the 3D mechanics model and  generate  a  20-sim  model
(see number 29) to make it effective.

9.4 Contact Modeling

Introduction

In the previous section, we have seen how to create a dynamic model of a robot with 3D
Mechanics Editor using Scara Robot. This section describes how to create a  model  with
some basic contact in it. 

In order to explain contact modeling, we use a model of a two wheel robot, that should
balance itself. It is a small “Segway” robot as shown below. The  contact  of  the  wheels
with the ground are modeled. At the end, the robot should  be  able  to  drive  in  straight
line while balancing itself.

Model of two wheel "segway" robot

Model of the Robot

Assumptions

The following assumptions are made during modeling.

The ground is a horizontal plane where where z==0.

The robot wheels will always stay level w.r.t. the ground.

Geometry

The robot will have the following geometry:

The main body will be modeled by a cube with mass=1{kg}

The size of the main body (cube) is 10 {cm} in all directions.

The wheels will have a radius of 4{cm}.
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The width of the wheels will be 2{cm}

The mass of each wheel is 0.5 {kg}

The geometry of the wheel is a cylinder.

Connection of wheels is made at 2.5 {cm} distance from the bottom of the cube

Step 1: Modeling main body

1. First start 20-sim.

2. In the 20-sim Editor from the Tools menu select 3D Mechanics Toolbox and 3D
Mechanics Editor.

This will insert a 3D Mechanics model in the 20-sim Editor and open the 3D mechanics

Editor.

3. From the Library tree in 3D Mechanics Editor, drag a Body to the workspace.

4. Select the body and click Edit Body, as shown below, and change the

name to 'carBody'. 
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Edit body dialog

5. Then press the Edit button and edit the Inertia and Mass properties for this object.

Our body has a mass (m) of 1{kg} and a width (w), height (h) and depth (d) of 10{cm}.

The inertia can therefore be calculated as:
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Inertia calculations

Substituting the m, w, h and d values, we get:

I
h
 = I

w
 = I

d
 = 1/12 * m * (h2  + w2) = 1/12 * 1 * (0.12  + 0.12) = 0.001667

In our case, I
h 

, I
w
 and I

d
 correspond to I

xx
, I

yy
 and I

zz
 respectively. 

Mass and inertia properties

6. Press OK on this dialog, and then OK on the Body Properties Dialog.

Now the shape of the cube must be set that it represents indeed a cube of 10{cm}.

7. To change the representation, press the Edit Button in the Representation section at
the left of the editor.

This opens a dialog shown below with which we can choose the color, shape and size of
a body. It is  important  to  know  that  this  is  indeed  only  a  representation.  Any  change
made  here  does  NOT  influence  the  dynamic  behavior  of  the  model,  but  only  the
appearance.
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Edit representation dialog

8. Press the Size button, and for every direction choose 0.1{m} and click OK.

Changing size 

The color of the body can also be changed with this dialog.

9. Choose a color you like and press OK to close.

If the body is not visible  anymore,  you  can  move  the  camera  closer  to  the  object  by
moving the mouse while pressing the Ctrl-key.
Now our worksheet will look like this:
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The grid is currently a square of 1 {m} which is a too big for our model.

10. To change the grid, choose from the Tools menu Model Settings. The dialog
shown below opens.

Here you can change the size of the reference frames, and the grid. Change both to 0.1
{m}. The scenery then looks like as shown below.
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Step 2: Inserting left wheel

Using similar steps followed, we insert a body for the left wheel. The size  of  the  newly
added  body  is  now  already  scaled  by  0.1.  This  is  because  of  the  settings  for  the
reference frame size we changed in the previous step.

11. Change the representation to be a cylinder with a radius of 4 {cm} and height of 2
{cm} as shown below.
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12. Press Ok to apply the settings. The scenery will now look like this:
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Cylinder representation with wrong scaling

Not exactly what we expected, but it can be explained: Because we changed the size of
the reference frames to be 0.1, all new bodies inserted will have a scaling of 0.1  in  all
directions. So by setting the exact dimension of the cylinder in the Cylinder  Properties,
all those are now scaled by 0.1. 

13. To adjust the setting, open the representation of the cylinder and change the scale
back to 1. It will now look like this:

Cylinder representation with correct scaling

We see that the orientation of the cylinder is such that it is lying down. 
Ultimately,  we  need  the  wheel  to  be  connected  to  the  left  side  of  the  body  with  y-
coordinate  -0.5  and  rotate  in  y-axis.  For  that  the  representation  should  be  adjusted
accordingly.

14. Open the cylinder representation again and change the orientation in x-axis to 90-
degrees.
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Orientation changed to 90-degrees in x-axis

You  see  that  it  has  rotated  to  the  left  (positive  angle)  and  that  the  origin  is  at  the
bottom. 

15. Change the color of the cylinder to purple (Red, Green, Blue = 153, 85, 187) to
indicate Left Wheel. 

We  now  have  the  correct  representation,  we  will  go  ahead  and  change  the  body
properties. 

On Wikipedia we can find the following for calculating the inertia of a cylinder.

We  are  rotating  over  the  y-axis,  so  take  that  into  account.  Also  in  the  picture  the
reference frame is at the center of the cylinder, but we have it at the bottom.

16. Open the Body Properties and change the name to LeftWheel.

Substituting for  mass  (m)  of  0.5  {kg},  height  (h)  of  0.02  {m}  and  radius  (r)  of  0.04
{m}, the inertia's we can be calculated as the following.
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In the Inertia Properties, we can also specify the location of the center Of Mass w.r.t. the
body reference. Since the center of mass is really  at the center, and we have our body
reference at the right side. The position offset is 1{cm} to the left. 

17. Fill in the calculated inertia values and position offset in the dialog as shown below.

Step 3: Connecting the left wheel 

We're going to attach the left wheel to the car body using a joint that rotates over the y-
axis. We want to be able to actuate this joint.

18. Choose the Actuated Y-Rotation Joint from the library and drag the joint to the
workspace.
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19. Now set the 3D Mechanics Editor in Connection Mode by pressing the Space Bar,
or by selecting the Connection Mode icon in the right button bar.

Now we want to connect the wheel to the body. The joint has two connection points. We
are going to connect the first connection point to the CarBody and the second connection
point to the LeftWheel.

20. Start connecting by dragging from the CarBody to the Joint.
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Once you release your mouse left button when you selected the joint the following dialog
will appear:

At the top, it shows that a connection is made from  CarBody  to  RotationJointY1.  We're
using ConnectionPoint1 to make the connection.
The position and orientation must be made w.r.t. the body coordinates.
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21. The orientation is the same as the body and is therefore set to zero. The position
offset is [x,y,z] = [0, -0.05, -0.025]

In the scenery still nothing happens, since the joint is not yet connected to the wheel.
So we will do the same action but now for the connection to the wheel.

22. Choose the position as [0, 0, 0] and the orientation also [0, 0, 0].

Now the model will look like this.

Step 4: Inserting right wheel

The easiest way to create the second wheel is by copying the first wheel.

23. Select the left wheel and press Ctrl-C and Ctrl-V. Or choose Copy and Paste from
the Edit menu.

A new wheel is inserted.

24. Change its name from LeftWheel2 to RightWheel and it's color to red.
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Step 5: Connecting the right wheel 

24. Connect a second Actuated Y-Rotation Joint this wheel just like with the first wheel.
Make sure the settings are set as shown below.
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Now it will look like this.

At  the  left  side  of  the  editor,  you  can  select  the  model  tree  by  pressing  the  tab  with
Model.  Here  you  can  see  that  the  joints  have  the  name  RotationJointY1  and
RotationJointY2.

25. With the right mouse button select Joint Properties. A dialog will open, here you
can change the names of the joints to LeftWheelJoint and RightWheelJoint.
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Step 6: Simulating the model

At this point we have enough information to make a simulation.

26. Press the 20-sim icon in the button bar (see figure below) in order to generate the
20-sim code.

First you will get the question:

27. Click Yes and choose a location and name. e.g. TwoWheelRobot3D.3dm for your
.3dm model. 

This name MUST be different from our 20-sim model name later on. Once you chose
your name, the Code Generation Dialog will open. It will show the following:
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28. Press Ok, and 20-sim will automatically update it's icon and pop to the front.

If we look at the interface of this model (right mouse click: select Edit  Interface)  we
see that there are two ports:
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Just close the dialog, since we don't have to make modifications to it.
We are now going to connect simple torques to the Joints.

29. Select Torque Actuator from the iconic Diagram library and drag two of them on
the worksheet.
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30. Change the names of the Torque Actuators to LeftWheelTorque and
RightWheelTorque.

Now  connect  the  actuators  to  the  TwoWheelRobot3D  sub-model.  Two  constant  source
sub-models are used as an input to the torque actuators.

31. Now press the start simulator button and the simulator window will open together
with the 3D animation window.
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32. Now press the run button. And then the replay animation.

You will see that the car will just drop through the floor. Therefore, it is now time to add
ground contact.

Step 5: Adding ground contact

To add ground contact, go back to the 3D Mechanics Editor.

Determining the lowest point of the wheel

33.From the library choose H-Matrix from the Sensor\Position&Orientation\Orientation.

This will return a 4x4 matrix giving the position and orientation of a specific point on the
car.
We're going to connect it to the center of each wheel. The idea is, if we know the center
of the wheel, we can subtract the radius of the wheel in z-direction to obtain the lowest
point of the wheel.
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34. Drag the H-Matrix and change the name into LeftWheelAbsH. Then connect it to
the left wheel just like you connected the joint. Since the body reference is at the
side of the cylinder we want to place it really in the center, by giving it an offset of
[0, -0.01, 0].

35. Repeat this action for the right wheel and change the name to RightWheelAbsH.

When we generate a 20-sim model again we now have two additional ports that give the
H-Matrices for the left wheel and right wheel. By subtracting the radius of the wheel in z-
direction we get the lowest point. This will be done in 20-sim.

The ground contact

The  ground  contact  is  modeled  by  applying  a  force  upwards  which  is  dependent  on
position. The force must be perpendicular to the floor.
We do this by applying a force Actuator also at the same location as the H-Matrix sensor.

36. From 3D mechanics Select the Torque & Force actuator from the library.

37. Drag it to the workspace and rename it to LeftWheelContact.

Note: Make sure that the Port Properties are set to World Coordinates.
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38. Connect the actuator to the LeftWheel at position [0, -0.01, 0]

39. Do the same for the RightWheel but connect it to position [0, 0.01, 0]

Now an external force can  be  applied  to  the  center  of  the  wheel,  but  always  with  the
orientation of the inertial frame.

39. Generate 20-sim model again.

In 20-sim the model will be updated and 4 additional ports will appear, 2 for each wheel.

40. In 20-sim Insert a new empty submodel. (with the right-mouse button) and name it 
LeftWheelContact.

Open the interface for this model and add the following ports:



9. 3D Mechanics Toolbox

126Getting Started with 20-sim 5.0

signal port: AbsH[4,4]

Iconic Diagram Port, mechanical: WheelContactForce[6,1]

41. Connect both ports it to the TwoWheelRobot3D model.

42. Now Double Click on the LeftWheelContact sub-model and choose a graph sub-
model. A graph sub-model will show with the two ports WheelContactForce and AbsH

43. At this level, insert yet another new sub-model with name Transformations.

44. Open the Interface editor for this sub-model and add the following ports:

signal port: AbsH[4,4]

Iconic  Diagram  Port,  mechanical,  Orientation  Output,  Causality:  Fixed  Force  Out:
WheelContactForce[6,1]

signal port, Orientation Output: zLowestPosition

Iconic  Diagram  Port,  mechanical,  Causality:  Fixed  Force  In  (Fixed  velocity  out):
ForceX

Iconic  Diagram  Port,  mechanical,  Causality:  Fixed  Force  In  (Fixed  velocity  out):
ForceY

Iconic  Diagram  Port,  mechanical,  Causality:  Fixed  Force  In  (Fixed  velocity  out):
ForceZ

45. Connect the AbsH port and the WheelContactForce.

46. Double Click on the Transformations submodel. Choose equation sub-model and
enter the following.

parameters

real global g_radius; //radius of the wheel

variables
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real LowestPointAbsH[4,4];

real AbsHinverse[4,4];

real invAdjointH[6,6];

real WheelWrench[1,6];

real WheelTwist[6];

equations

// copy all values from the AbsH matrix

// but by subtracting the g_radius from the z-coordinate

// the rotation part

// now unity, so no rotation w.r.t. inertial frame

LowestPointAbsH[1:3,1:3] = eye(3);

// the position part

LowestPointAbsH[1,4] = AbsH[1,4]; // x-position

LowestPointAbsH[2,4] = AbsH[2,4]; // y-position

LowestPointAbsH[3,4] = AbsH[3,4] - g_radius;        // z-position

// and the last row, which is [0, 0, 0, 1];

LowestPointAbsH[4,1:4] = AbsH[4,1:4];

// and set the output port

zLowestPosition = LowestPointAbsH[3,4];

// make an adjoint matrix, so we can transform a force

// acting on the lowest point, to the center of the body

AbsHinverse = inverseH (LowestPointAbsH);

invAdjointH = Adjoint (AbsHinverse);

// make a 1x6 vector holding the translational forces

WheelWrench = [0.0, 0.0, 0.0, ForceX.F, ForceY.F, ForceZ.F];

// transform the incoming WheelContactForce vector

WheelContactForce.F =  transpose (WheelWrench * invAdjointH);

// and do the same for the twist (velocity) vector

WheelTwist = invAdjointH * WheelContactForce.v;

// and pass the velocity

ForceX.v = WheelTwist[4];

ForceY.v = WheelTwist[5];

ForceZ.v = WheelTwist[6];

Describing the ground contact

At the three separate ports ForceX, ForceY  and  ForceZ,  we're  going  to  connect  the
ground contact and the friction in x and y-direction.
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47. From the Translation library, choose the FixedWorld, Damper, and
SpringDamper sub-models. 

48. Rename the Damper and SpringDamper to FrictionX, GroundContactZ. 

49. Now open the interface of the FrictionX model, and add a port name
zPositionLowestPoint.

50. Do the same with the GroundContactZ model. 

51. Now go down in the FrictionX model and change the line at the equations like this

equations

p.F = if zPositionLowestPoint < 0 then

d * p.v

else

0.0

end;

This means that the friction only is active if the lowest part of the wheel is lower that the
ground.

52. For the GroundContactZ model rewrite the equations to be like this

equations

p.F = if zPositionLowestPoint < 0 then

k * zPositionLowestPoint + d*p.v

else

0.0

end;

This  means  there  is  a  spring/damper  combination  active  only  when  the  wheel  goes
through the ground.
We will determine them later when we make a simulation.

Connecting the sub-models

It is now time to connect the sub-models. 

53. First copy FrictionX and paste it to the model FrictionY. They will be both the same.
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54. Now connect FrictionX, FrictionY and GroundContactZ to the Transformations sub-
model at the top. Some small nodes will be inserted, because of the port orientation.
Also connect the bottom of the models to the FixedWorld and the zLowestPosition to
all three models.

55. Now go up one level, so you see the TwoWheelRobot3D model again.

56. Copy the LeftWheelContact model, and paste this model, and rename it to
RightWheelContact.

57. Connect it to the TwoWheelRobot3D model, in the same way you connected the
LeftWheelContact model.

Note:  The  global  parameter  g_radius  is  defined  twice  since  we  copied  the
implementation  of  the  LeftWheelContact  to  the  RightWheelContact.  Therefore,  remove
the value of the parameter at one of the sub-models.

Simulating the model

Before simulating the model, the parameters should be set properly.
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58. Open the parameters editor and select the sub-model LeftWheelContact
\GroundContactZ and change the parameters to:

d = 1k {N.s/m}
k = 100k {N/m}

59. Do the same with the RightWheelContact\GroundContactZ.

60. Open the Parameters Editor again, and change the ConstantLeft and
ConstantRight models the values to C  = 0.01

61. Change the friction in X -and Y-direction of both left wheel as right wheel to d = 10
{k.N.s/m}

The  contact  model  should  now  be  working  as  expected.  However,  the  car  is  rotating.
This is because the wheels are  actuated  with  a  constant  torque.  The  torque  is  applied
between the wheels and the body, so they will rotate in opposite directions. 

Step 6: Balancing the mass

We want to be able to control two things:

The mass of the robot should remain upright.
The mass of the robot should be under a certain angle such that it moves with a constant
velocity.

Because we rotate over the y-axis a positive rotation will tilt the mass in the forward x-
direction. In order to do this, we must move the robot forward to balance this mass. So
by controlling the angle, we control the velocity of the vehicle.

Measuring the angle of the robot

62. Go to the 3D Mechanics model and from Sensors in the library choose
RotationMatrix(3x3)
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63. Rename it to Rbody and connect it to the CarBody at the location of the axis: [0, 0,
-0.025]. 

Generate  20-sim  code  again.  An  additional  port  is  now  available  holding  the  Rotation
matrix of the CarBody.

From this rotation matrix we can extract the tilting-angle.

64. In 20-sim create a new sub-model with the name CarAngle. At the interface define
two ports:

input: signal R[3,3]

output signal angle

For the implementation fill in the following:

variables

real angles[3];

equations

angles = dll('EulerAngles.dll', 'EulZYXrFromRotationMatrix', R);

angle = angles[2];

What this does is, it gives the three angle rotations that are applied next to each other in
the order: Z-axis rotation, Y-axis rotation and X-axis rotation.

If we're moving in the x-direction, the rotation of the x-axis and z-axis are zero, so this
will only have value for the y-axis.
If we drive in a circle, we first have to rotate over the z-axis, and then the y-axis. The x-
axis will remain zero in that case as well.

Now connect the complete model in the following way:
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What we see here is that  the  angle  of  the  car  is  compared  to  a  reference  angle.  The
difference is fed into a PID controller. The output of the controller is given to both wheel
motors.
There is an additional multiplication of -1, because a positive torque on the wheels, will
make  the  wheel  move  backward  (positive  angle  is  counter-clockwise).  We  want  it  to
move forward with a positive measured angle.

The  OffsetAngle  can  be  created  by  a  simple  MotionProfile  submodel.  Choose  the
amplitude not larger than 0.5 {rad}. You can give any type of movement you want. The
PID works fine with the default parameters. Simulating the model should drive the car in
a straight line.
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10 Animation Toolbox

10.1 Animation Toolbox
Animation is a powerful method to inspect and verify  your simulation results, especially
when working in  three  dimensions.  The  20-sim  Animation  Toolbox  offers  you  an  easy
way to create 3D Animations and view graph animations.

3D Animation

Simulation results in 20-sim can be shown  as  animations  using  a  3D Animation  Editor.
Animations  are  composed  of  predefined  objects  like  cubes,  spheres,  lines,  squares,
cameras  and  lights.  Complex  objects  can  be  imported  from  CAD  packages  using
common exchange formats.

Objects

Any variable of a 20-sim model can be connected to an object. Various attributes of the
object can be controlled this way: position, orientation, size, etc. Thermal graphs can be
created by controlling the color of the objects.

 

In the 3D Animation Editor you can connect every object property to a variable in the model.

Reference  frame  objects  can  be  used  to  group  animation  objects  and  inherit  object
attributes. Objects can be duplicated, resulting in complex animation with a  few  mouse
clicks.

Connected to Simulation

Animations  are  fully  linked  to  the  20-sim  Simulator.  While  a  plot  is  being  drawn,
simultaneously  the  animation  will  be  shown!  This  link  is  kept  after  a  simulation  has
finished.  While  inspecting  the  numerical  values,  you  will  notice  that  the  3D  Animation
changes simultaneously!

Movies

Every animation can be exported to movies in various  formats  (mpg,  wmv,  avi.  flash)
for the use in presentations and external programs.
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Graph Animation

With  20-sim  Graph  Animation  you  can  display  the  results  of  a  simulation  in  your
graphical model.  During  simulation,  the  thickness  and  color  of  the  bonds,  connections
and signals will correspond with the values they carry.

10.2 3D Animation Basics
This lesson demonstrates how to build a simple 3D-animation. It helps you to understand
the  basics  of  reference  frames,  define  objects  and  couple  them  to  variables  in  your
model.

Model

1. Open 20-sim and load the model 3DAnimation from the Getting Started\Animation
Toolbox section of the library.

This  model  consists  of  three  signal  generators.  We  will  use  the  outputs  of  these
generators to show moving objects in a 3D Animation window.

2. Open the Simulator. 

3. In the tree at the left select Window1. From the right mouse menu select Add
Plot - 3D Animation.

This will open a 3D Animation plot next to the standard plot:

The 3D Animation window at start-up.

The first time the 3D Animation window is opened, the top reference  frame  is  shown
(red = x, green = y, blue = z) in a semi transparent grid (the checkerboard) that covers
the xy-plane. All objects you want to show in the 3D Animation window, must be defined
with respect to this frame.

4. In the tree at the left select 3D Animation. From the right mouse menu select
Plot Properties.
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This opens the 3D Animation Properties window:

The 3D Animation Properties window at start-up.

At the left of the 3D Animation Properties window an object tree  is  shown  with  several
reference frames and objects:

Reference Frame:  This  is  the  top  reference  frame.  All  other  reference  frames  and
objects are defined with respect to this frame.

Default  Lights  and  Cameras:  This  reference  frame  contains  the  default  lights  and
cameras.

Scenery: In this reference frame you can add your own objects.

5. Close the 3D Animation Properties and re-open it by double clicking in the 3D
Animation plot.

Cameras

The 3D Animation window comes with five default cameras. All cameras are defined with
respect to the Default Lights and Cameras frame, which has the same orientation as the
top reference frame.

Front Cameras

There are three cameras which are positioned on top of the principal axes of the Default
Lights and Cameras frame. The front cameras do not show in perspective.

6. In the 3D Properties window, from the objects tree select the Front(XY)-
Camera.
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As you will  notice  the  view  in  the  3D  Animation  window  changes.  It  shows  the  x-axis
(red) and y-axis (green) of the top reference frame:

The view with the Front (XY) Camera selected.

7. Try out the other cameras.

Camera Looking at Origin

The Camera Looking at Origin can be positioned at every  desired place but  will  always
look at the origin of the Default Lights and Cameras frame.

8. In the 3D Animation Properties window, from the objects tree select the Camera
Looking At Origin and inspect the position tab on the right of the window.

9. Change the Y-position of the Camera Looking At Origin and inspect the results in
the 3D Animation window.

As you will see the position of the camera can be changed, but its orientation will always
be  chosen  to  make  the  camera  look  at  the  origin  of  the  Default  Lights  and  Cameras
frame.

Position and orientation of the Camera Looking at Origin.

Adding Objects

With the camera in a  good  position,  it  is  easy  to  add  objects.  We  will  remove  the  3D
Animation window and open it again to get a fresh set of cameras.
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10. Close the 3D Properties and the 3D Animation window.

11. In the tree at the left select 3D Animation. From the right mouse menu select
Delete Plot.

12. In the tree at the left select Window1. From the right mouse menu select Add
Plot - 3D Animation.

13. Open the 3D Properties window.

12. In the 3D Properties window, from the objects tree select the Scenery frame.

13. From the right mouse menu select Edit, Insert Object and Sphere.

Now a sphere is added to the objects tree.  A  dialog  is  popped-up  showing  the  Object
Properties of the Sphere.

14. Change the properties of the Sphere into:

 Color Scaling Values

 Red, Value = 1.0 Scale X, Value =  = 0.5

 Green, Value= 0.0 Scale Y, Value =  = 0.5

 Blue, Value = 0.0 Scale Z, Value =  = 0.5

15. Close the Object Properties dialog and set the position and orientation of the sphere
equal to:

 Position Orientation (Bryant)

 X-position,  Variable  =  Sine
\output

X, Value = 0.0

 Y-position, Value = 0.0 Y, Value = 0.0

 Z-position, Value = 0.0 Z, Value = 0.0

16. For the X-position you have to choose the correct variable using the Choose
Variable button.

Your 3D Properties window should now look like:

The X-position of the sphere is coupled to a variable of the 20-sim model.



10. Animation Toolbox

138Getting Started with 20-sim 5.0

17. Close the 3D Properties window and return to the 20-sim Simulator.

18. From the Simulation menu select Run to calculate the plot (or click the blue Run

Simulation button ).

19. From the Simulation menu select Replay and 3D Animation (or click the green
Run 3D Animation button ) and you will see the Sphere move.

The sphere moving along the X-axis.

If you have problems producing a good animation, close all windows. Open 20-sim and
load the model 3DAnimation1 from the Getting Started\Animation Toolbox section of the
library. This model will show the proper animation of the moving sphere.

Zooming

The object is quite far away. We will use the camera zoom to get a close look.

20. Open the 3D Properties window and from the objects tree select the Default
Lights and Cameras and Camera Looking at Origin.

21. Select the Object Properties (tab at the right) and click the Set Object
Properties button.
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22. Pull the Zooming slider until you have a closer look at the object and close the
Properties window.

Use the Camera properties to change the zooming level.

Other Objects

23. In the tree at the left of the 3D Properties window select the Scenery frame.

24. From the menu select Edit, Insert Object and Cube.

25. Open the 3D Properties window and from the objects tree select the Scenery
frame.

26. From the menu select Edit, Insert Object and Cube.

We would like to see the Cube rotate.

27. Select the Cube from the objects tree and change the Object Properties to:

 Color Scaling Values Position Orientation (Bryant)

 Red = 0.0 X = 0.5 X-position = 0.0 X = 0.0

 Green = 1.0 Y = 0.5 Y-position = 2.0 Y = 0.0

 Blue = 0.0 Z = 0.5 Z-position = -0.25 Z = Triangle\output

28. Like the Cube now add a Line object.

We want the line to rotate along the Y-axis.

29. Select the Object Properties of the Line and change the properties to:

 Color Start Position End Position

 Red = 1.0 X-position = 0.0 X = Sine\output

 Green = 1.0 Y-position = 1.0 Y = 1.0

 Blue = 1.0 Z-position = 0.0 Z = Cosine\output

30. Close the 3D Properties window and return to the 20-sim Simulator.
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31. From the Simulation menu select Run to calculate the plot (or click the blue Run

Simulation button ).

32. From the Simulation menu select Replay and 3D Animation (or click the green
Run 3D Animation button ).

You will see the sphere move, the cube  rotate  and  the  line  rotate  along  the  Y-axis.  It
should look like the figure below:

Three moving objects.

If you have problems producing a good animation, close all windows. Open 20-sim and
load the model 3DAnimation2 from the Getting Started\Animation Toolbox section of the
library. This model will show the proper animation of the moving objects.

10.3 Planetary System
All objects in a 3D Animation can be defined with respect to the top reference  frame.
If you have multiple  objects that move relative to the top  reference  frame  but  have  a
fixed  position  and  orientation  to  with  respect  to  each  other,  it  is  useful  to  introduce
additional reference frames. We will demonstrate this by creating  a  3D  Animation  of  a
planetary system.

Remove Default Elements

1. Open 20-sim and load the model Planetary System from the Getting Started
\Animation Toolbox section of the library.

2. Open the Simulator.

3. In the tree at the left select Window1.

4. From the right mouse menu select Add Plot - 3D Animation.

5. In the tree at the left select 3D Animation. From the right mouse menu select Plot
Properties.

Change background and remove the grid

We will remove the grid and change the background.
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6. From the Properties Menu select General Properties.

7. Select the Choose Color button and change the background color to black.

8. De-select the Apply Image check box and the Show Grid check box.

In the General Properties window you can select the background color and the grid.

9. Close the General 3D Properties window.

Sun

10. Select the Scenery Reference Frame and rename it (Edit menu) to: Sun
Reference Frame.

11. Select the Sun Reference Frame.

12. Insert a Spot Light.

13. Rename it to Sun Light and change the properties to:

 Ambient Color Diffuse Color Specular Color Position

 Off On On  

 Red = 0.0 Red = 1.0 Red = 1.0 X-position = 0.0

 Green = 0.0 Green = 1.0 Green = 1.0 Y-position = 0.0

 Blue = 0.0 Blue = 1.0 Blue = 1.0 Z-position = 0.0

14. Select the Sun Reference Frame and insert an Ambient Light. Change its
properties to:

 Ambient Color Diffuse Color Specular Color Position

 On Off Off  

 Red = 0.5 Red = 0 Red = 0 X-position = 0.0

 Green = 0.5 Green = 0 Green = 0 Y-position = 0.0

 Blue = 0.5 Blue = 0 Blue = 0 Z-position = 0.0

15. Select the Sun Reference Frame and insert a Camera. Change the zooming
until you have a good view.
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Now your 3D Animation should look like:

With an additional camera you will have a new view.

16. Select the Sun Reference Frame and insert a Sphere.

17. Rename it to Sun and change the properties to:

 Color Scaling Values Position Orientation
(Bryant)

 Red = 1.0 X = 1.0 X-position = 0.0 X = 0.0

 Green = 1.0 Y = 1.0 Y-position = 0.0 Y = 0.0

 Blue = 0.0 Z = 1.0 Z-position = 0.0 Z = 0.0

18. Select the Sun Reference Frame and insert a Circle.

19. Rename it to Hot Spot and change the properties to:

 Color Scaling Values Position Orientation
(Bryant)

 Red = 0.0 X = 0.2 X-position = 0.5 X = 0.0

 Green = 0.0 Y = 0.2 Y-position = 0.0 Y = 1.57

 Blue = 0.0 Z = 0.2 Z-position = 0.0 Z = 0.0

Earth

As you might have guessed we are creating the sun. For the earth motion we will use a
second reference frame.

20. Select the Sun Reference Frame and from the Edit menu select Copy and
Paste.

As you can see a second reference frame is added including objects.

21. From the second reference frame delete the Sun Light and Camera objects.

22. Click on the Camera of the Sun Reference Frame to get a correct view again.
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23. Rename the second reference frame to Earth Reference Frame and change the
properties to:

 Scaling Values Position Orientation (Bryant)

 X = 0.3 X-position = Sine\output X = 0.0

 Y = 0.3 Y-position = Cosine\output Y = 0.0

 Z = 0.3 Z-position = 0.0 Z = Sine\arg

24. From the Earth Reference Frame select the Hot Spot object and change the name
to Launch Site.

25. Select the Sun object and change its name to Earth.

26. Change its color to red = 0, green = 0.5 and blue = 1.

27. Select the Camera from the Sun Reference Frame.

We have added  objects  and  variables  which  haven't  been  simulated  before.  To  see  a
good animation, we first have to run a simulation.

28. Close the 3D Animation Properties window and return to the 20-sim Simulator.

29. From the Simulation menu select Run to calculate the plot (or click the blue Run

Simulation button ).

30. From the Simulation menu select Replay and 3D Animation (or click the green
Run 3D Animation button ).

Now you will see the earth orbiting the sun. It should look like the figure below:

The earth orbiting the sun.

If your objects seem far away, change the zooming of the camera.

Moon

The same trick as we did with the earth will now be repeated to create a moon.

31. Open the 3D Properties window.
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32. Select the Earth Reference Frame and from the Edit menu select Copy and
Paste.

33. Rename the objects to Moon Reference Frame, Moon and Lunar Landing Site.

34. Select the Moon Reference Frame and change the properties to:

 Scaling Values Position Orientation
(Bryant)

 X = 0.5 X-position  =  Cosine
\output

X = 0.0

 Y = 0.5 Y-position  =  Sine
\output

Y = 0.0

 Z = 0.5 Z-position = 0.0 Z = Sine\arg

35. Select the Moon and change its color to red = 1, green = 1 and blue = 0.5.

36. Select every reference frame and de-select the option Show Frame.

You can also press the Ctrl-key and de-select the Show Frame  option of the top frame.
This will make that all underlying frames will have the Show Frame option de-selected.

37. Select the Camera from the Sun Reference Frame.

Viewing the Animation

38. Close the 3D Properties window and return to the 20-sim Simulator.

39. From the Simulation menu select Replay and 3D Animation (or click the green
Run 3D Animation button ).

Now you should see the earth orbiting the sun:

The earth orbiting the sun and the moon orbiting the earth.

40. In the Simulator, from the View menu select Numerical Values.
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With the Numerical Values window you can inspect the values of the simulation plot. At
the same time you will see the corresponding view in the 3D Animation window. If  you
use the slider  of  the  Numerical  Values  window  you  can  seen  the  earth  and  the  moon
move.

41. Use the slider of the Numerical Values window to move the earth and the moon.

Switching Cameras

42. In the 3D Properties window select the Earth Reference Frame and insert a
Camera object. Change the zooming until you have a good view.

43. Change the name of the Camera into Earth Camera.

44. In the 3D Animation window click the Play  button to see the sun and moon
moving around the earth.

45. Switch between cameras by clicking the Camera  button.

46. If you have problems producing a good animation, close all windows. Open 20-sim
and load the model Planetary System1 from the Getting Started\Animation Toolbox
section of the library. This model will show the proper animation of the planetary
system.
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11 Control Toolbox

11.1 Control Toolbox
The  Control  Toolbox  of  20-sim  contains  several  tools  that  can  aid  you  in  developing
controllers for your modeled machines, the Controller Design Editor, the Filter Editor  and
the Neural Network Editors.

Controller Design Editor

1. In the Editor from the Tools menu select Control Toolbox - Controller Design
Editor.

The  Controller  Design  Editor  is  a  specialized  tool  for  the  design  of  feedback  control
systems. A feedback structure of subsystems is presented with a linear plant, controller,
measurement  and  pre-filter.  Also  the  open-loop  and  closed-loop  gains  and  the
sensitivities are available.

The Controller Design Editor.

You can edit your controller as an ABCD State Space system, a Transfer Function or in a
Zero Pole  Gain form. Changes in one of the  subsystems  directly  update  all  open  plots
and dialogs. For instance,  adapting  the  controller  gain  immediately  changes  poles  and
zeros of the closed-loop system and the overall step response. The integration within 20-
sim  and  linear  system  exchange  with  MATLAB  makes  this  editor  a  powerful  tool  for
designing feedback control systems!

Filter Editor

2. In the Editor from the Tools menu select Control Toolbox - Filter Editor.
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With  the  Filter  Editor  you  can  create  your  own  linear  filters  according  to  your
specifications. Available filters are Bessel, Butterworth and ChebyChev filters where you
can specify  the order and  characteristic  frequencies.  A  choice  can  also  be  made  from
PID, lead/lag, or notch filters.

The Filter Editor.

Neural Network Editors

3. In the Editor from the Tools menu select Control Toolbox - B-Spline Network
Editor.

The  20-sim  Control  toolbox  supports  two  well-known  networks:  Adaptive  B-Spline
Networks and Multi-Layer Perceptron Networks.

The B-Spline Editor.

These  neural  networks  must  be  trained  by  repeatedly  presenting  examples  to  the
network.  Each  example  includes  both  inputs  and  desired  outputs.  Based  on  the  error
between  desired  outputs  and  the  real  network  output,  the  neural  network  adapts  the
weight  of  each  neuron  according  to  a  user-defined  learning  rate.  If  the  response  is
accurate enough, you can save the weights of the neurons, to use the neural network in
your controller. An unlimited number of neurons may be used.
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12 Frequency Domain Toolbox

12.1 Frequency Domain Toolbox
The  20-sim  Frequency  Domain  Toolbox  consists  of  the  Linear  System  Editor,  FFT
Analysis, Model Linearization and Dynamic Error Budgeting functionality.

Linear System Editor

The  Linear  System  Editor  is  a  specialized  tool  for  the  design  and  analysis  of  linear
systems.  The  editor  supports  continuous-time  and  discrete-time  SISO  systems  using
various representations.
 
The graphical interface allows you  to  edit  a  linear  system  in  any  desired  form:  ABCD
state  space,  Transfer  Function  or  Zero  Pole  Gain.  Analyzing  the  Step  response,  Bode
plot, Nyquist diagram, Nichols chart and Pole-Zero plots allows you  to  quickly  evaluate
system behavior. Phase, gain and modulus margins are calculated, as well as rise  time,
overshoot and steady state value.
 
Input can originate from a 20-sim linear  system  model,  20-sim  filter  or  control  editor,
MATLAB workspace, or user input. You are able to generate output for all 20-sim editors,
the clipboard and the MATLAB workspace.

Fast Fourier Transform

Fast Fourier Transforms (FFT) can be applied to any time-domain plot in  20-sim.  Either
simulation results or measurement  data  will  do.  When  the  data  is  not  equally  spaced,
linear  interpolation  is  first  applied  after  which  the  Fast  Fourier  Transform  is  used  to
calculate the frequency  contents.  Three  representations  are  supported:  Amplitude  and
Phase plot, Frequency plot and Power Spectral Density plot.

Model Linearization

Any 20-sim model can be linearized to state space form. If possible, linearization will be
performed symbolically. Otherwise linearization will be performed numerically.
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The resulting state space model is shown in the 20-sim Linear System Editor. The Linear
System Editor  is  a  specialized  tool  for  the  design  and  analysis  of  linear  systems.  The
editor  supports  continuous-time  and  discrete-time  SISO  systems  using  various
representations. Standardized plots enable you to quickly evaluate system behavior.

 

In the Linear System Editor you can generate bode plots.

Features

Editing  as  ABCD  state  space,  Transfer  Function  or  Zero  Pole  Gain  with  automatic
transformation between these forms.

Transfer between continuous-time and discrete-time representation.

View characteristic properties like eigenfrequencies and damping.

Handles numeric and symbolic models.

Various plot options: Step Response, Bode Plot, Nyquist Diagram, Nichols Chart and
Pole-Zero Plot.

Dynamic Error Budgeting

The performance of  precision  machines  is  mostly  limited  by  the  disturbances  that  are
injected in these machines. These disturbances are often stochastic in nature. Dynamic
Error  Budgeting  is  a  method  whereby  the  effect  of  these  disturbances  on  the  final
performance  can  be  calculated.  The  advantage  of  this  method  is  that  it  enables  the
designer to enter the contributions of the individual disturbances and view and optimize
the overall machine performance.
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The Dynamic Error Budgeting toolbox shows the total error as a result of injected disturbances.

Running the Toolbox

You can open the Dynamic Error Budgeting tool in the Simulator: 

1. Open 20-sim and load the model Dynamic Error Budgeting from the Getting Started
\Frequency Domain Toolbox section of the library.

2. In the Simulator from the Tools menu select Frequency Domain Toolbox and
Dynamic Error Budgeting.

The Dynamic Error Budgeting tool.

The tool allows you to enter disturbances (as power spectral density) in the Input Noises
section.
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3. For each disturbance you have to select a corresponding variable by clicking the 
Add input noise button.

Each disturbance is effectively a summation to the chosen variable, just like  closed loop
linearization. You can inspect each disturbance in the graph on the top right. 

Next  you  have  to  select  an  output  variable,  where  the  result  of  the  disturbances  is
calculated.

4.Select the output by clicking the Add Output button.

In the graph on the bottom right you can see the resulting error at the selected output
as a result of the disturbances. The error is given in the form of a power spectral density
(PSD) and cumulative power spectral density (CPS). The square root of the final value of
the CPS is equal to the standard deviation of the output error.
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13 Mechatronics Toolbox

13.1 Mechatronics Toolbox
The Mechatronics Toolbox includes the following items:

1. CAM Wizard

2. Motion Profile Wizard

3. Servo Motor Editor

13.2 Cam Wizard

How to use the Cam Wizard

Introduction

Cams and mechanisms are all based on the same principle. The motion of an input axis
is transformed to an output axis or translation. The  transformation  is  a  function  of  the
input angle. This function is called the cam motion profile.

The 20-sim cam wizard helps you to generate cam and mechanism models. You can use
various types of motion profiles which are continuous in velocity, acceleration or even in
jerk!  An  example  of  a  mechanism  that  can  be  generated  by  the  Cam  wizard  is  the
crank-rod mechanism, where a rotary input motion is transformed to a translating output
motion.

The  models  that  are  generated  by  the  20-sim  Cam  wizard  are  fully  dynamic!  This
means:

The models describe the output velocity  as function of the input velocity  but also the
input torque as function of the output load.

The speed of the input axis does not have to be constant nor does the output load.
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No  inertia,  stiffness  or  other  dynamic  behavior  is  included,  but  this  can  be  easily
incorporated by coupling elements from the 20-sim library  (inertias, springs etc.)  to
the input or output of the model.

Example

To generate a cam or mechanism model in 20-sim, follow the next steps.

1. Open the 20-sim model library an go to the section Iconic Diagram\Mechanical
\Rotation\Gears and drag the model Cam-Wizard.emx to the editor. You can also
select in the Editor: Tools - Mechatronics Toolbox - Cam Wizard.

2. Select the Cam-Wizard model and click Go Down. Now the wizard will be opened.

3. Choose the desired motion profile, the profile parameters and type of output
(translation/rotation):

5. Select the type of cam motion profile:
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6. Enter the parameters values (Stroke, Start Angle Stop Angle). If you have chosen a
continuous pulse as output, you must also enter the values for the Return Angle and
End Angle:

7. In the last page, the resulting values are shown:



13. Mechatronics Toolbox

155Getting Started with 20-sim 5.0

8. Click Finish and the cam model will be defined. All you have to do is to connect the
input axis (p_in, rotation) and the output axis (p_out, rotation or translation) of the
cam model.

Note

1. If you have changed the settings of this wizard, you have to process the model first
(from the Model menu, choose Check Complete Model) before the changes become
effective.

2. You can change parameter values during simulation (from the Properties menu
select Parameters).

3. This is a masked model that uses the dll-file MotionProfile.dll to open the wizard.
This dll-function must be stored in the bin directory of 20-sim. To see the SIDOPS
code of a masked model press the shift-key, while clicking the Go Down command.

Cam Motion Profiles

Motion Types

Two types of motion profiles can be generated by the Cam wizard: intermittent steps
and  continuous  pulses.  The  intermittent  step  motion  does  not  return  to  its  starting
position,  but  gradually  moves  further  away  .  It  is  characterized  by  the  parameters
stroke, start_angle and stop_angle.
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The continuous pulse  motion output  returns  at  the  end  of  each  cycle  returns  to  the
starting position. It is characterized by the parameters stroke,  start_angle,  stop_angle,
return_angle and end_angle.

Motion Profiles

In  mechanical  engineering  an  important  part  of  design  is  the  reduction  of  vibrations.
Every  time  a  construction  is  in  motion,  vibrations  are  induced.  When  cams  or
mechanisms are used, the amount of vibrations,  depend  on  the  kind  of  motion  that  is
induced. E.g. a sudden step change will induce violent vibrations in comparison with with
a fluent motion. An important parameter to characterize motions, is the order:

1. Zero Order: Motions that are discontinuous in the position (e.g. a step).

2. First Order: Motions that are continuous in the position but discontinuous in the
velocity (e.g. a ramp).

3. Second Order: Motions that are continuous in the position and velocity but
discontinuous in the acceleration.

4. Third Order: Motions that are continuous in the position, velocity and acceleration.

5. Fourth Order: Motions that are continuous in the position, velocity, acceleration and
jerk.

The specific shape of a motion profile  can  have  a  significant  influence  on  the  dynamic
behavior.  Some  profiles  minimize  the  maximum  velocity,  some  profile  minimize
acceleration, while other profiles tend to make a tradeoff between the maximum velocity
and acceleration. If we take a standard motion with stroke 1 and motion time 1 sec., the
following table can be generated:
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profile order vmax amax y(0) y(1/2)

Ramp 1 1 infinite infinite 0

Crank-Rod2 2 > 1.57 > 4.93 infinite < -15.5

Trapezoidal 2 2 4 infinite -infinite

Partial Trapezoidal1 2 1.67 4.17 infinite 0

Geneva Mechanism 2 2.41 8.49 infinite -118.5

Sine 2 1.57 4.93 infinite -15.5

Cubic 3 2 4 32 -32

Partial Cubic3 3 1.67 5.55 55.6 0

Cycloidal 3 2 6.28 39.5 -39.5

Modified Sine 3 1.76 5.53 69.4 -23.2

Modified Trapezoidal 3 2 4.88 61.4 -61.4

MSC50 3 1.26 9.20 173.6 0

MSC%4 3 1.37 7.20 113.1 0

3-4-5 Polynomial 3 1.88 5.77 60 -30

1-3-5-7-9

Polynomial5

3/4 2.05 10.25 BB BM

1: Parameter CV = 20%

2: For lw >> lc the Crank Rod profile equals the sine profile, for lw > lc performance
deteriorates.

3: Parameter CV = 20%, CA = 20%

4: Parameter n = 30%, alpha = 10%

5: Parameter BB = 30%, BM = 10%

Here  y(0)  is  the  initial  jerk  (derivative  of  acceleration)  and  y(1/2)  the  crossover
(halftime) jerk.

Ramp

The ramp profile is a first order profile. It has a constant velocity and acceleration peaks
at the start and end of the motion.
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Crank Rod Mechanism

A Crank Rod mechanism converts a rotary motion into a repeating translation and

If the rod is much longer than the crank, the resulting motion profile  will  approach  the
sine  profile.  Below  the  motion  profile  is  shown  for  half  a  rotation  of  the  crank  (angle
from 0 to 180 degrees in 1 sec.).

If the rod gets smaller, the maximum velocity and acceleration increase.
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Note: A real crank-rod mechanism will not suddenly stop at half a rotation and therefore
not show a discontinuous acceleration.

Trapezoidal

The trapezoidal profile  is  a  second  order  profile.  It  has  a  constant  acceleration  at  the
start of the motion and a constant deceleration at the end of the motion.

This profile  is most widely  used in early  servo systems. Because of the discontinuity  in
the  acceleration  this  motion  profile  can  still  induce  a  lot  of  vibrations.  Therefore  in
modern servo systems third order profiles are preferred.

Partial Trapezoidal

The partial trapezoidal profile is a second order profile. It has is equal to the trapezoidal
motion, but has a constant velocity part, during a fraction CV (%) of the motion.
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Geneva Mechanism

A  Geneva  mechanism  is  an  old  motion  profile  generation  mechanism.  A  continuously
rotating crankshaft (a) generates an intermittent motion of a second shaft (b). The result
is a second order profile.

The  motion  profile  generator  yields  the  motion  of  the  second  shaft  (b).  It  is  shown
below:

Sine

The sine profile is a second order profile of which the displacement can be described as:
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x = 0.5 - cos (p * t) / 2.

Cubic

The cubic profile is a third order profile of which the acceleration is constantly  increasing
and decreasing.

Partial Cubic

The partial cubic profile  (3rd order) is a modified  cubic  profile  with  a  constant  velocity
during a fraction CV (%) of the motion and a constant acceleration during a fraction CA
(%) of the motion.

Cycloidal

The cycloidal profile is a third order profile, of which the velocity can be described as:
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v = stroke*(1-cos(t*a))

Modified Sine

The modified sine profile is also a third order profile. It is a modification of the cycloidal
profile to get a lower maximum velocity and a lower maximum acceleration.

Modified Trapezoidal

The modified trapezoidal profile is a modification of the trapezoidal profile  (to make it a
third order profile). This profile yields a very low maximum acceleration.

Modified Sine with Constant Velocity (MSC50)

The  modified  sine  with  constant  velocity  profile  (3rd  order)  is  a  modification  of  the
modified sine profile. It has a constant velocity during 50% of the motion.
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General Modified Sine with Constant Velocity (MSC%)

The  modified  sine  with  constant  velocity  profile  (3rd  order)  is  a  modification  of  the
modified sine profile. It has a constant velocity during a user definable  part of the of the
motion.  The  non-zero  acceleration  part  is  defined  by  two  parameters  which  are  both
defined as a fraction of the motion. The first parameters alpha  (%) defines the start of
the acceleration and the second parameters n (%) defines the end of the acceleration.

3-4-5 Polynomial

The is a third profile described by a 5th order polynomial.
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1-3-5-7-9 Polynomial

The  is  a  third/fourth  order  profile  described  by  a  9th  order  polynomial.  The  profile  is
characterized  by  two  parameters  that  denote  the  initial  jerk,  BB,  and  the  crossover
jerk, BM. If BB is chosen zero, this a a fourth order profile.  If  BB  is  chosen  non-zero,
this is a third order profile.

13.3 Motion Profile Wizard

Motion Profile Wizard

The 20-sim Motion Profile Wizard helps you to define motion profiles. To generate such a
profile, follow the next steps.

1. Open the 20-sim model library an go to the section Signal\Sources and drag and
drop the model MotionProfileWizard.emx to the editor. You can also select in the
Editor: Tools - Mechatronics Toolbox - Motion Profile Wizard.

2. Select the model and click Go Down.

This is a masked model. Clicking Go Down will open the Motion Profile Wizard.

4. Select the inputs and outputs:
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A number of inputs and outputs are available:

External Input: Normally  the time will be used for the x-axis of the profile.  You  can
however use an external input as x-axis variable.

On/Off: Use this input signal to start (onoff =  TRUE) and  stop  (onoff  =  FALSE)  the
profile.

Reset: When the reset signal gets high (reset = TRUE) the profile will be started.

Reference: The motion profile reference signal, e.g. position.

First  Derivative:  The  first  derivative  of  the  motion  profile  reference  signal,  e.g.
velocity.

Second Derivative: The second derivative of the motion profile  reference signal, e.g.
velocity.

Profile Counter: Gives the number of profiles that have been generated.

Ready Signal: Gets high (ready = TRUE) when the profile is completely generated.

5. Click Next to enter the desired profile.

6. You can enter as many profiles as needed to design the complete motion. You can
choose out of a number of predefined profiles.
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7. Choose the number of times the motion should be repeated.

8. Click Next to go to the last page.

In the last page, you can choose to generate  Time  Events  and  what  to  show  the  next
time (the  wizard  or  the  generated  code).  Use  the  default  settings  if  you  are  not  sure
what to use.
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9. Click Next to go to close the Wizard.

10. In the Editor from the Model menu Check Complete Model to make the changes
effective.
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Motion Profiles

You  can  choose  out  of  a  number  of  predefined  motion  profiles  in  the  Motion  Profile
Wizard.

Flat

Ramp

Trapezoidal

Partial Trapezoidal

Geneva Mechanism

Sine

Cubic

Partial Cubic

Cycloidal

Standard Modified Sine

Modified Trapezoidal

Modified Sine with Constant Velocity (MSC50)

General Modified Sine with Constant Velocity (MSC%)

3-4-5 Polynomial

1-3-5-7-9 Polynomial

Flat

The  flat  profile  is  a  zero  order  profile.  It  has  a  constant  position,  zero  velocity  and
acceleration.

Ramp

The ramp profile is a first order profile. It has a constant velocity and acceleration peaks
at the start and end of the motion.

The ramp profile.

Trapezoidal

The trapezoidal profile  is  a  second  order  profile.  It  has  a  constant  acceleration  at  the
start of the motion and a constant deceleration at the end of the motion.
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The trapezoidal profile.

This profile  is most widely  used in early  servo systems. Because of the discontinuity  in
the  acceleration  this  motion  profile  can  still  induce  a  lot  of  vibrations.  Therefore  in
modern servo systems third order profiles are preferred.

Partial Trapezoidal

The partial trapezoidal profile is a second order profile. It has is equal to the trapezoidal
motion, but has a constant velocity part, during a fraction CV (%) of the motion.

The partial trapezoidal profile.

Geneva Mechanism

A  Geneva  mechanism  is  an  old  motion  profile  generation  mechanism.  A  continuously
rotating crankshaft (a) generates an intermittent motion of a second shaft (b). The result
is a second order profile.
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A Geneva mechanism.

The  motion  profile  generator  yields  the  motion  of  the  second  shaft  (b).  It  is  shown
below:

The Geneva mechanism profile.

Sine

The sine profile is a second order profile of which the displacement can be described as:

x = 0.5 - cos (p * t) / 2.

The sine profile.
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Cubic

The cubic profile is a third order profile of which the acceleration is constantly  increasing
and decreasing.

The cubic profile.

Partial Cubic

The partial cubic profile  (3rd order) is a modified  cubic  profile  with  a  constant  velocity
during a fraction CV (%) of the motion and a constant acceleration during a fraction CA
(%) of the motion.

The partial cubic profile.

Cycloidal

The cycloidal profile is a third order profile, of which the velocity can be described as:
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v = stroke*(1-cos(t*a))

The cycloidal profile.

Modified Sine

The modified sine profile is also a third order profile. It is a modification of the cycloidal
profile to get a lower maximum velocity and a lower maximum acceleration.

The modified sine profile.

Modified Trapezoidal

The modified trapezoidal profile is a modification of the trapezoidal profile  (to make it a
third order profile). This profile yields a very low maximum acceleration.
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The modified trapezoidal profile.

Modified Sine with Constant Velocity (MSC50)

The  modified  sine  with  constant  velocity  profile  (3rd  order)  is  a  modification  of  the
modified sine profile. It has a constant velocity during 50% of the motion.

The modified sine with constant velocity profile.

General Modified Sine with Constant Velocity (MSC%)
The  modified  sine  with  constant  velocity  profile  (3rd  order)  is  a  modification  of  the
modified sine profile. It has a constant velocity during a user definable  part of the of the
motion.  The  non-zero  acceleration  part  is  defined  by  two  parameters  which  are  both
defined as a fraction of the motion. The first parameters alpha  (%) defines the start of
the acceleration and the second parameters n (%) defines the end of the acceleration.
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The general modified sine with constant velocity profile.

3-4-5 Polynomial

The is a third profile described by a 5th order polynomial.

The 1-3-5 polynomial profile.

1-3-5-7-9 Polynomial

The  is  a  third/fourth  order  profile  described  by  a  9th  order  polynomial.  The  profile  is
characterized  by  two  parameters  that  denote  the  initial  jerk,  BB,  and  the  crossover
jerk, BM. If BB is chosen zero, this a a fourth order profile.  If  BB  is  chosen  non-zero,
this is a third order profile.

The 1-3-5-7-9 polynomial profile.

To  keep  the  polynomial  consistent,  i.e.  the  polynomial  does  not  change  when  the
amplitude is changed, the initial jerk (BB) and the crossover jerk  (BM) are defined for a
standard motion with:

stroke = 1

start_time = 0

stop_time = 1
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Comparison of Profiles

The specific shape of a motion profile  can  have  a  significant  influence  on  the  dynamic
behavior.  Some  profiles  minimize  the  maximum  velocity,  some  profile  minimize
acceleration, while other profiles tend to make a tradeoff between the maximum velocity
and acceleration. If we take a standard motion with stroke 1 and motion time 1 sec., the
following table can be generated:

profile order vmax amax j(0) j(1/2)

Flat 0 0 0 0 0

Ramp 1 1 infinite infinite 0

Trapezoidal 2 2 4 infinite -infinite

Partial Trapezoidal1 2 1.67 4.17 infinite 0

Geneva Mechanism 2 2.41 8.49 infinite -118.5

Sine 2 1.57 4.93 infinite -15.5

Cubic 3 2 4 32 -32

Partial Cubic3 3 1.67 5.55 55.6 0

Cycloidal 3 2 6.28 39.5 -39.5

Modified Sine 3 1.76 5.53 69.4 -23.2

Modified Trapezoidal 3 2 4.88 61.4 -61.4

MSC50 3 1.26 9.20 173.6 0

MSC%4 3 1.37 7.20 113.1 0

3-4-5 Polynomial 3 1.88 5.77 60 -30

1-3-5-7-9

Polynomial5

3/4 2.05 10.25 BB BM

1: Parameter CV = 20%

2: For lw >> lc the Crank Rod profile equals the sine profile, for lw > lc performance
deteriorates.

3: Parameter CV = 20%, CA = 20%

4: Parameter n = 30%, alpha = 10%

5: Parameter BB = 30%, BM = 10%

Here  j(0)  is  the  initial  jerk  yerk  (derivative  of  acceleration)  and  j(1/2)  the  crossover
(halftime) jerk.
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13.4 Servo Motor Editor

Servo Motor Editor

The 20-sim Servo Motor Editor is a program that helps engineers to choose the  proper
servo motor for any electromechanical system:

Brush DC (Iron Armature Motor, Hollow Rotor Motor, Disc Armature Motor)

Brushless DC

AC synchronous

AC synchronous linear

In cooperation with motor manufacturers, motor data tables have been created for  the
Servo Motor Editor. The performance of every motor can be shown by the torque speed
curve. The Servo Motor Editor can generate dynamic models for the simulation program
20-sim.  In  this  program  you  can  simulate  the  thermal  and  dynamic  behaviour  of  the
servo motor in combination with control loops and dynamic loads.
 
Any engineer involved in the design of electromechanical machines can benefit from the
Servo Motor Editor. Precious time and money can be saved by finding the optimal servo
motor in a few minutes, without risking overheating or under-powering.

The 20-sim Servo Motor Editor.

Features

Support of predefined motor data tables.

Add your own motors to the data table.

Quick search by multiple parameters.

Torque-Speed  curves  with:  line  of  maximum  current,  maximum  torque,  maximum
voltage,  maximum  speed,  maximum  power,  maximum  efficiency  and  maximum
power output.

Safe Operating Area, Desired Operating Area.
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Generate dynamic models for the simulation program 20-sim. These models include
thermal  effects  of  the  coils  and  housing,  electrical  losses  through  dissipation,
magnetic losses through hysteresis, eddy currents and cogging.

Show torque speed curve with dynamic load curve.

Template models, covering most commercial control schemes and many mechanical
loads.

Application Areas

Control Design

Industrial Equipment and Machinery

Precision Engineering

Simulation

Utilities and Energy

Vibration Analysis and Control

How to use the Servo Motor Editor

This section demonstrates how to use the Servo Motor Editor to select the correct motor
for a drive train. The Servo Motor Editor  is  part  of  the  Mechatronics  Toolbox.  You  can
use  the  Servo  Motor  Editor  to  create  models  that  include  permanent  magnet  servo
motors. In the figure below you see a PID  controlled  AC  synchronous  motor  driving  a
load through a gearbox and beltdrive. In this example we will show how  to  create  and
use such a model.

PD controlled servo motor with gearbox and belt.

Model

1. Open 20-sim and select File, New and Graphical Model.

2. From the Tools menu select Mechatronics Toolbox and  Servo Motor Editor.
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A servo motor model will be inserted:

A servo motor inserted.

3. The Servo Motor Editor will be opened automatically. If this does not happen,
force the editor to open by clicking the Go Down button.

The editor will show the default motor list and the parameters of the selected motor.

You can choose from a list of existing servo motors in the Servo Motor Editor.

4. From the File menu choose Open Database.

5. Load the file ServoMotor.csv. You can find this file in the folder C:\Program Files\20-

sim 5.0\Tools\Servo Motor Dynamics

Use C:\Program Files (x86)\20-sim 5.0\Tools\Servo Motor Dynamics on 64-bit versions
of Windows

Now the Servo Motor Editor will show a list of motors.
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6. From the list choose the Maxon EC 60 motor with keyname 167131 s (almost at the
end of the list).

Display the characteristic parameters of a selected motor.

7. Click the Plot tab to inspect the torque speed curve.

Show a torque speed plot of the selected motor.

8. Click the OK button to close the editor and generate the dynamic model.
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The 20-sim editor will now look like:

The selected motor is now inserted in 20-sim.

9. Add the following models and connect them until your model looks like the figure
below. Try to give the same submodel names as indicated in the figure.

 model library model

 Iconic Diagrams\Mechanical\Translation\Sensors
Iconic Diagrams\Mechanical\Translation\Components
Iconic Diagrams\Mechanical\Translation\Transmission
Iconic Diagrams\Mechanical\Rotation\Gears
Signal\Block Diagram
Signal\Sources
Signal\Control\PID Control\Continuous

PositionSensor-Absolute
Mass (Default)
BeltPulley
Transmission (Ideal)
PlusMinus
SignalGenerator-Cycloid
PID

The complete model of the belt driven load.
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10. From the File menu click Save as. Store the model in a temporary directory (e.g.
C:\temp) using the name ServoMotor.emx.

If you have problems creating the model, load the model ServoMotor1  from the Getting
Started\Mechatonic Toolbox section of the library.

Simulation

11. In the Editor toolbar from the Model menu select the Start Simulator command.

12. In the Simulator, click the Parameters command from the Properties menu.

13. As you will see the parameter values for the AC motor have been filled in
automatically by the Servo Motor Editor. Enter the other parameters as:

 Parameter Value

 Load\m
PID\kp
PID\tauD
PID\beta
PID\tauI
BeltPulley\radius
Gear\i
SP\start_time
SP\amplitude
SP\stop_time

20
5000
0.05
0.1
20
0.1
20
1
1
2

14. From the Properties menu select the Run command and change the default values
to:

 
 

Start
Finish
Method

0
4
Vode Adams

15. In the tree, select the plot (model). From the right mouse menu, select Rename
and rename it to position.

16. From the right mouse menu, select Plot Properties.

17. From the Properties menu select the Plot command. Add the following plot
variables to the Y-tab.

 Variable Label

 SP\output
Pos\x

SP
x

18. Click on the Shared Axis option to select it.
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19. Close the Plot Properties Editor and run a Simulation. It should look like the next
figure.

Simulation of the drive system.

As you can see the motor is able  to drive a load of 20 kg. Now we are going to inspect
the thermal behaviour of the motor.

19. In the tree at the left click on Window 1 to select it.

20. From the right mouse menu select Add Plot - Plot.

Now a second plot will be visible.

20. Rename the plot to temperature.

21. Open the Plot Properties Editor (Properties - Plot). Add the following plot
variables to the Y-tab.

 Variable Label

 ServoMotor\Temp_coil
ServoMotor\Temp_housing

coil
housing

22. Click on the Shared Axis option to select it.
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23. Run a new simulation.  The Simulator will look like the next figure.

In the Simulator you can open additional plots.

The coils heat up  immediately  and  the  housing  heats  up  gradually.  We  have  to  run  a
simulation for a longer time, to see if the motor will overheat. We can also  inspect  the
torque speed curve to inspect the thermal behaviour.

24. From the View menu choose New Plot Window. This will open a new plot.

25. Open the Plot Properties Editor (Properties - Plot). Add the following plot
variables.

 x-axis Variable Label

  ServoMotor\omega_range speed

 

 y-axis Variable Label

  ServoMotor\T_100
ServoMotor\T_25
ServoMotor\Torquemax
ServoMotor\T_abs

T_100
T_25
max torque
load torque

 
For the variable ServoMotor\T_abs we will choose a separate x-axis.

26. Select the tab with Load Torque and then select the Separate X-Axis option at
the bottom of the Plot Properties Editor.

27. Click the Choose button next to the Separate X-Axis option and select the variable
ServoMotor\omega_abs.
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Your Plot Properties Editor should now look like:

You can choose a separate x-axis for every plotted variable.

28. Run a new simulation. The extra plot will look like the next figure.

Torque speed plot with the duty cycle lines and the load torque.

The  load  torque,  i.e.  the  torque  that  is  applied  by  the  motor  to  drive  the  load,  is
completely  under the 25% duty  cycle  curve. This means the motor will never  overheat
when once every 4 sec there is a step change of 1 s. The motor curve is even under the
100% duty cycle. This means it wouldn't overheat if we would apply 4 steps in 4 s. If we
stick to the 25% duty cycle, we might choose a lighter motor.

29. Go to the Editor. Select the ServoMotor model and click Go Down.

30. In the Servo Motor Editor choose the motor with keyname 252463 s.

This is a motor with less power (156 W vs. 312W), a smaller maximum torque (5.14 Nm
vs. 6.59 Nm) and a higher maximum speed (10000 rpm vs. 7000 rpm)
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31. Click OK to close the Servo Motor Editor.

32. In the Editor from the Model menu click the Check Complete Model command.
This will ensure that the new motor will be used in the simulation.

33. In the Simulator from the Simulation menu choose Clear - All Runs.

34. Now run a new simulation. The torque speed plot will now look like:

The motor torque crosses the 25% duty cycle line. This means the motor will overheat.

The load curve now crosses the 25% duty  cycle  line. This means the motor will heat up
higher  than  the  allowed  maximum.  To  prevent  this  from  happening  we  will  use  the
higher maximum speed of the motor. This can be done by changing the gearbox ratio.

35. In the Simulator, from the Properties menu click the Parameters command.
Change the gearbox ratio Gear\i to 40.
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36. Clear the previous simulation and run a new simulation. The torque speed plot will
now look like:

Changing the gearbox ratio will keep the motor torque under the 25% duty cycle line.

Now the load curve does not cross the 25% duty  cycle  line anymore. You can also load
the  model  ServoMotor2  from  the  Getting  Started\Mechatonic  Toolbox  section  of  the
library to show the final result.
 
You can load the model ServoMotor3.emx   from the Getting Started\Mechatonic Toolbox
section of the library, to see a long simulation of the motor temperature. In this model
the setpoint generation is performed by a motion profile block which outputs a repeating
signal  with  a  duty  cycle  of  25%.  As  you  can  see  from  the  plot  the  coil  temperature
increases to 43 °C which is far below the maximum temperature of 125 °C.

A simulation of the motor temperature.
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14 Real Time Toolbox

14.1 Real Time Toolbox
The Real Time Toolbox  provides you with C-code generation tools and templates for all
kinds of different targets and platforms.
 
With 20-sim you are able to generate C-code as well as MATLAB code for every  20-sim
model that you have created, whether it is a continuous or discrete-time model. The C-
code  can  be  created  for  several  targets,  like  MATLAB  Simulink,  but  also  for  Rapid
Prototyping (RP) systems and Hardware-In-the-Loop (HIL) simulations.

Matlab Simulink

Generating C-code for use in MATLAB Simulink also includes a submodel block with input
and output terminals. 20-sim uses the MEX-compiler, to compile this code directly into an
S-function. These S-functions can also be used in the  Real  Time  Workshop  in  order  to
generate code for a specific platform, for instance xPC Target.

C-code

20-sim can generate standalone C-code for use in C and C++ programs. The generated
C-code is supplied with several fixed step simulation algorithms to assure that it will run
in real-time. The Euler and RungeKutta 4 method are supported by default.
 
All C-code templates are open and can be adapted by the user to assign compilers, run
ftp-sessions and automate almost everything between the  20-sim  code  generation  and
the actual running of the code on a (remote) machine. During C-code generation support
code  is  generated  for  20-sim  operators  like  matrix  calculations  and  trigonometric
functions.

20-sim 4C

With  the  Real-Time  Toolbox  you  can  generate  code  for  20-sim  4C.  20-sim  4C  is  a
program that is sold separate from 20-sim. 20-sim 4C  is a prototyping environment that
enables you to connect 20-sim models to physical systems. The models can be executed
as  real-time  C-code  on  hardware  like  PC's  or  ARM-9  based  processor  boards.  This
enables you to perform various tasks:

Measurement and Calibration: From 20-sim 4C  you  can  export  C-code  that  will
operate and read sensors.

Machine Control: With 20-sim 4C you can export code to external targets to control
the operation of machines. In 20-sim 4C  you  can  start  and  stop  the  controller  and
change parameters during run-time.
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Rapid Prototyping: 20-sim models can be exported to 20-sim 4C with the click  of a
button  and  executed  on  a  target  with  a  second  click.  This  makes  20-sim  4C  a
valuable tool for rapid prototyping.

20-sim 4C allows you to run C-code, generated in 20-sim, on real machines.

More information on 20-sim 4C can be found on the 20-sim website www.20sim.com.

 

http://www.20sim.com
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15 Time Domain Toolbox

15.1 Time Domain Toolbox
During  simulation,  the  time  domain  behavior  of  a  model  is  calculated.  Based  on  this
time-domain behavior, the model can be analyzed. A set of powerful methods  for  time
domain analysis is available in 20-sim.

Parameter Sweep

Parameter sweeps are multiple  simulations with a variation of parameter values. It is a
quick method to see how your model behavior depends on the parameter values.

Optimization

Using  Optimization,  you  can  maximize  the  performance  of  your  model  by  varying
specified model parameters. Predefined or user defined cost functions can be used as a
measure of model performance. A number of well known optimization  methods  can  be
used to minimize or maximize these cost functions.

Using optimization to find controller parameters with optimal disturbance rejection.

Curve Fitting
With  Curve  Fitting  you  can  fit  model  performance  to  a  given  result  by  variation  of
parameters.  It  is  a  very  useful  method  to  optimize  model  parameters  when
measurement data is available.

Sensitivity Analysis

Sensitivity  Analysis  is  used  to  investigate  the  effect  of  parameter  variation  on  model
performance. The change in performance divided by the parameter change is plotted in
a  table.  Sensitivity  Analysis  is  a  well-known  method  in  production  engineering  to  find
critical systems tolerances in early stages of the design
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Monte Carlo Analysis

With Monte Carlo Analysis, you can perform a predefined number of simulation runs with
statistical  variation  of  parameter  values.  Results  can  be  shown  as  histograms  or
inspected numerically. Monte Carlo Analysis is a powerful method to find out worst case
model behavior.

Variation Analysis

With Variation Analysis you can find the statistical range of parameter values that yield a
model with a certain performance level. Variation Analysis is a powerful method to find a
measure for system tolerances in the early stage of the design.

15.2 Parameter Sweep

Introduction

Using  the  Parameter  Sweep  option  of  the  Time  Domain  Toolbox,  you  can  perform  a
predefined number of simulation runs with variation of parameters / initial values.

Example

1. From the Getting Started Manual\Time Domain Toolbox library open the model
ParameterSweep.

2. Open the Simulator.

3. In the Simulator, from the Tools menu select the Time Domain Toolbox and
then Parameter Sweep.

A window will open, asking you which parameters values should be changed during the
multiple  simulations.  Here  the  parameters  Lever\L\r  and  Bellows\K\k  are  already
entered.
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4. Click the Next button.

Result

A  window  opens  asking  you  which  result  (optional)  should  be  shown  after  the
simulations:
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Here  the  integral  of  the  pipe  air  flow  (e.g.  the  total  air  volume)  is  chosen.  For  a
parameter sweep, you do not have to fill in a  value,  but  it  is  nice  to  see  which  set  of
parameters will give a maximum air flow.

5. Click the Next button.

Run options

A window will open, asking some simulation run options:
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You can select the following items:

Steps: Number of simulations runs.

Copy from States: Use the result of the previous simulation runs as the starting value

numerical output of the parameter sweep.

Join Parameter Variation: Change all parameters simultaneously.

Clear After Every Run: C lear the simulation plot when a new simulation run starts.

Redraw After Every Run: Update the scaling after every run.

Here the two parameters will be varied  5  times  independently,  requiring  25  simulation
runs. 

6. Click the Next button.

A window will open with a summary of the chosen options. If your are not satisfied you
can use the Back button to go to a previous window and change settings.

7. Click the Finish button to close the Multiple Run Wizard.

8. From the Simulation menu click the Multiple Run command to perform the
Parameter Sweep.

Now the Simulator will perform the 25 runs and show the results in the plots. If you click
View - Numerical values, you can inspect the runs and see that run number 10 will give
the largest air flow.
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Parameter Sweep Results

After simulation has been  done,  a  Multiple  Run  Results  window  will  open,  showing  the
minimum and maximum value of the result and chosen parameters.

Here the maximum and minimum air flow volume is shown. You can select the following
items:

Values: Choose this button to  open  the  list  that  shows  the  numerical  output  of  the
parameter sweep.
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Matlab: Export the results to Matlab.

OK: C lose the Multiple Run Results Window.

You can always re-open the Multiple Run Results window, by selecting the Multiple  Run
Results command of the View Menu.

9. By choosing the Values button, a new window is opened, showing the numerical
results of the parameter sweep.

In the Results  list of this window the subsequent runs are shown and (if available) the
value of the chosen result:

Here the 25 runs are shown with the parameter values and resulting air  flow volume. As
you can see, run number 10 gives the maximum air  flow. You  can  select  the  following
items:

Step: Click on Step or the other column headers to sort the runs.

Set Values: Choose the values of the selected run, as new parameter values of your
model.

Create Datafile: Use this button to store the values of the selected variables on file.
Use the control-key and shift-key to make multiple selections.
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15.3 Optimization
Using  the  Optimization  option  of  the  Time  Domain  Toolbox,  you  can  optimize  a  given
result using variation of parameters / initial values.

Optimization Method

1. From the Getting Started Manual\Time Domain Toolbox library open the model
Optimization.

2. Open the Simulator.

3. In the Simulator, from the Tools menu select the Time Domain Toolbox and
then Optimization.

A window opens asking you which optimization method should used:

Here the optimization method is already chosen. 

4. Click the Next button.

Parameters / Initial Values

A  window  will  open,  asking  you  which  parameters  values  should  be  use  for  the
optimization. Here the parameters Lever\L\r and Bellows\K\k are already entered.
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5. Click the Next button.

Result

A window opens asking you which result should optimized:
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Here the integral of the pipe air flow (e.g. the total air volume) is chosen.

6. Click the Next button.

Run options

A window opens asking some simulation run options:

7. Click the Next button.

A window opens with a summary of the chosen options. If your are not satisfied you can
use the Back button to go to a previous window and change settings.

9. Click the Finish button to close the Multiple Run Wizard.

10. From the Simulation menu click the Multiple Run command to perform the
Optimization.

You will see the Simulator perform  many  simulation  runs.  After  a  maximum  has  been
found on the starting run and the runs with the maximum air flow is shown.
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Optimization Results

After simulation has been done, an Optimization Results window will open,  showing  the
optimum value of the result and corresponding parameters:

Here the maximum air flow volume is shown. You can select the following items:

Values: Choose this button to  open  the  list  that  shows  the  numerical  output  of  the
optimization runs.

Matlab: Export the results to Matlab.

OK: C lose the Optimization Results Window.
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You can always re-open the Multiple Run Results window, by selecting the Multiple  Run
Results command of the View Menu.

11. By choosing the Values button, a new window is opened, showing the numerical
results of the parameter sweep.

In the Results list of this window the subsequent runs are shown and (if available) the
value of the chosen result:

As you can see Here the 81 runs are performed  and shown with the parameter values
and resulting air  flow volume. As you can see, run number  81  gives  the  maximum  air
flow. You can select the following items:

Set Values: Choose the values of the selected run, as new parameter values of your
model.

Create Datafile: Use this button to store the values of the selected variables on file.
Use the control-key and shift-key to make multiple selections.

15.4 Sensitivity Analysis
Using the Sensitivity  Analysis option of the Time Domain Toolbox, you can detect which
variations in parameter values will give the  largest  deviation  of  a  given  metric.  If,  for
example,  the  metric  is  the  accuracy  of  a  machine,  with  sensitivity  analysis  you  can
detect  how  sensitive  the  machine  is  for  parameter  changes,  with  respect  to  that
accuracy.
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Sensitivity analysis starts with a simulation run with nominal parameter values. After the
run a given result is monitored (r). Then, one by one, each  parameter  (pi)  is  changed
with  a  given  percentage  (to  pi  +  dpi)  and  a  simulation  run  is  performed.  After  the
simulation run the changed result is monitored (r + dri).  After  all  the  runs,  the  results
are displayed as sensitivities, where sensitivity is defined as the change in result divided
by the change in parameter:
 

Si = dri / dpi
 
A large sensitivity means that the result is highly dependent of the parameter value. This
can be used for optimization (change the parameter value) or design (change the design
to make it less dependant of the parameter).

Parameters / Initial Values

1. From the Getting Started Manual\Time Domain Toolbox library open the model
SensitivityAnalysis.

2. Open the Simulator.

3. From the Tools menu select the Time Domain Toolbox and then Sensitivity
Analysis.

A window opens asking you which parameters / initial values should be changed for the
sensitivity analysis:

As you can see the parameters have already been entered.

4. Click the Next button.
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Result

A window opens asking you which result should be monitored for the sensitivity:

The integral absolute value of the position error is chosen here.

5. Click the Next button.

Run options

A window opens asking some simulation run options:
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6. Click the Next button.

A window opens with a summary of the chosen options. If your are not satisfied you can
use the Back button to go to a previous window and change settings.

7. Click the Finish button to close the Multiple Run Wizard.

8. From the Simulation menu click the Multiple Run command to perform the
Sensitivity Analysis.

Now the Simulator will perform a number of simulation runs and show the results.

Sensitivity Analysis Results

After simulation has been done, a Sensitivity Analysis Results window will open, showing
the sensitivities:
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As you can see, a change in pulley2 radius will by  far give the largest change in error.
I.e. the system  is  very  sensitive  to  changes  in  the  pulley2  radius.  You  can  select  the
following items:

Multiple Run Values: Choose this button to open the list that shows the output of the
various runs performed during the sensitivity analysis.

Close: Close the Sensitivity Analysis Results Window.

You can always re-open the  Multiple  Run Results  window, by selecting  the  Multiple  Run
Results command of the View Menu.

15.5 Curve Fitting
Using the Parameter Sweep option of the Time Domain Toolbox, you can fit your model
to a given result using variation of parameters / initial values.

Optimization Method

1. From the Getting Started Manual\Time Domain Toolbox library open the model
CurveFitting.

2. Open the Simulator.

3. From the Tools menu select the Time Domain Toolbox and then Curve Fittting.

A window opens asking you which optimization method should used for curve fitting:
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Here the optimization method is already chosen. 

4. Click the Next button.

Parameters / Initial Values

A window will open, asking  you  which  parameters  values  should  be  use  for  the  curve
fitting. Here the parameters Model\omega and Model\zeta are already entered.
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5. Click the Next button.

Result

A window opens asking you which result should minimized to fit your model (variable  1)
to a given result (variable 2):
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6. Click the Next button.

Run options

A window opens asking some simulation run options:
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7. Select the desired run options and click the Next button.

A window opens with a summary of the chosen options. If your are not satisfied you can
use the Back button to go to a previous window and change settings.

8. Click the Finish button to close the Multiple Run Wizard.

9. From the Simulation menu click the Multiple Run command to perform the Curve
Fitting.

You  will  see  the  Simulator  perform  many  simulation  runs.  After  a  good  fit  has  been
found on the starting run and the runs with the best fit is shown.
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Optimization Results

After the curve fit has been  done,  the  Optimization  Results  window  will  open,  showing
the minimum value of the result and corresponding parameters:

You can select the following items:

Values: Choose this button to  open  the  list  that  shows  the  numerical  output  of  the
curve fitting runs.

Matlab: Export the results to Matlab.

OK: Close the Optimization Results Window.
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You can always re-open the  Multiple  Run  Results  window,  by  selecting  the  Multiple
Run Results command of the View Menu.

11. By choosing the Values button, a new window is opened, showing the numerical
results of the parameter sweep.

In the Results  list of this window the subsequent runs are shown and the value of the
chosen result:

You can select the following items:

Set Values: Choose the values of the selected run, as new parameter values of your
model.

Create Datafile: Use this button to store the values of the selected variables on file.
Use the control-key and shift-key to make multiple selections.
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15.6 Monte Carlo Analysis
Using the Monte Carlo analysis option of the Time Domain Toolbox, you can  perform  a
predefined number of simulation runs with variation of parameter values according to a
predefined distribution function.

Parameters / Initial Values

1. From the Getting Started Manual\Time Domain Toolbox library open the model
ParameterSweep.

2. Open the Simulator.

3. From the Tools menu select the Time Domain Toolbox and then Monte Carlo
Analysis.

A  window opens asking you which parameters /  initial  values  should  be  varied  for  the
Monte Carlo analysis:

Two parameters have already been entered.

4. Click the Next button.

Result

A window opens  asking  you  which  result  should  be  monitored  during  the  Monte  Carlo
Analysis:
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Here the integrated absolute error of the machine is chosen.

5. Click the Next button.

Run options

A window opens asking some simulation run options:
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Because this is a statistical method, we have to do many simulations runs. We therefore
choose not to display  the results in a plot to speed up simulation and prevent using too
much computer memory.

6. Click the Next button.

A window opens with a summary of the chosen options. If your are not satisfied you can
use the Back button to go to a previous window and change settings.

7. Click the Finish button to close the Multiple Run Wizard.

8. From the Simulation menu click the Multiple Run command to perform the Monte
Carlo Analysis.

Monte Carlo Analysis Results

After the simulations have been done, a Monte Carlo Analysis Results window will open,
showing the results:
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You can select the following items:

Values: Choose this button to open the list that shows the output of the various runs
performed during the Monte Carlo analysis.

Histogram: Choose this button to open a histogram of the selected item.

Matlab: Export the results to Matlab.

OK: C lose the Multiple Run Results Window.

You can always re-open the Multiple  Run  Results  window,  by  selecting  the  Multiple
Run Results command of the View Menu.

9. By choosing the Values button, a new window is opened, showing output of the
various runs performed during the Monte Carlo analysis.
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You can select the following items:

Set Values: Choose the values of the selected run, as new parameter values of your
model.

Create Datafile: Use this button to store the values of the selected variables on file.
Use the control-key and shift-key to make multiple selections.

By choosing the Histogram button, a new window is opened, showing distribution of the
integrated absolute error:
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15.7 Variation Analysis
Using the Monte Carlo analysis option of the Time Domain Toolbox, you can  perform  a
predefined number of simulation runs with variation of parameter values according to a
predefined distribution function. We will then 
restrict  the  parameter  variation  until  the  error  is  within  certain  bounds.  This  is  called
Variation analysis.

Parameters / Initial Values

1. From the Getting Started Manual\Time Domain Toolbox library open the model
ParameterSweep.

2. Open the Simulator.

3. From the Tools menu select the Time Domain Toolbox and then Variation
Analysis.

A  window opens asking you which parameters /  initial  values  should  be  varied  for  the
Variation analysis:
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Here the integrated absolute error of the machine is chosen.

5. Click the Next button.

Result

A  window  opens  asking  you  which  result  should  be  monitored  during  the  Variation
Analysis:
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Two parameters have already been entered.

6. Click the Next button.

Run options

A window opens asking some simulation run options:
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Because this is a statistical method, we have to do many simulations runs. We therefore
choose not to display  the results in a plot to speed up simulation and prevent using too
much computer memory.

6. click the Next button.

A window opens with a summary of the chosen options. If your are not satisfied you can
use the Back button to go to a previous window and change settings.

7. Click the Finish button to close the Multiple Run Wizard.

8. From the Simulation menu click the Multiple Run command to perform the

Variation Analysis.

Variation Analysis Results

After simulation has been done, a Variation Analysis Results window will open, showing
the results. A histogram shows the distribution of the result. Using the slider bar you can
see  how  restraining  the  distribution  of  the  parameters  effects  the  distribution  of  the
result.
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The histogram shows the value of the  integrated  absolute  error  on  the  x-axis  and  the
number of runs on the y-axis.

You can select the following items:

Slider Bar: Select a parameter and restrict its distribution with the slider bar. You will
see the results distribution change.

Multiple Run Values: Choose this button to open the list that shows the output of the
various runs performed during the Variation Analysis.

OK: C lose the Multiple Run Results Window.

You can always re-open the Multiple Run Results window, by selecting the Multiple  Run
Results command of the View Menu.

9. Change the slider bar for the two parameters and inspect the results.

You can see the following:

An increase of the end effector mass will not reduce the maximum error.

A decrease of the stiffness will not reduce the maximum error.

We can slide the maximum mass to the middle and minimum stiffness to the middle to
decrease the error:
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16 Scripting Toolbox

16.1 Introduction
20-sim  scripting  allows  you  to  run  tasks  in  20-sim  automatically  using  specialized
scripting functions. With these functions you can open models,  run  simulations,  change
parameters, store results and  much  more.  Scripting  support  was  introduced  in  20-sim
4.4. 

20-sim session automated by a script in Octave, Matlab or Python.

These scripting functions are not very useful stand-alone, but you can use them to write
scripts to automate various tasks in 20-sim.
20-sim provides  a  set  of  script  functions  for  numerical  computation  environments  like
Octave and Matlab and for the Python programming language (since 20-sim 4.6).
The 20-sim scripting functions are based on XML-RPC  calls, so any  other  programming
language with support for XML-RPC can be used to automate various 20-sim steps.

In this chapter you will learn how to run basic scripts and make scripts on your own.

The next sections explain:

Installation for scripting:

o 20-sim: enabling the XML-RPC scripting interface in 20-sim

o Octave: installing Octave as scripting environment

o Matlab: installing Matlab as scripting environment

o Python: installing Python as scripting environment

Prepare  Scripting  Folder:  extract  the  20-sim  scripting  functions  and
documentation to your work directory.

Basic  Script:  run  your  first  script  and  see  how  a  basic  script  is  made  in  Octave/
Matlab or Python.

Advanced  Scripts:  see  how  you  can  expand  the  basic  script  to  perform  more
advanced tasks in Octave/Matlab.

Writing  your  own  Scripts:  How  to  write  your  own  scripts  in  Octave/Matlab  or
Python.

Note:  Scripting  is  not  supported  in  the  20-sim  Viewer/Demonstration  Version.  If  you
would like to try the scripting functionality, you will need licensed 20-sim version or a
trial license.
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16.2 Installation for Scripting: 20-sim
20-sim  uses  XML-RPC  as  a  protocol  to  communicate  scripting  functions  with  external
packages. By default the XML-RPC  interface is  turned  on  only  for  your  local  computer
(listening on the TCP ports 5580 and 5520).

To enable/disable and configure the 20-sim scripting support:

1. Open 20-sim.

2. Go to Tools - Options and select the Scripting Server tab.

Scripting Interface settings tab.

3. To enable the 20-sim scripting support, make sure that the HTTP and TCP
checkboxes under XMLRPC Interface are enabled.

By  default,  20-sim  will  only  accept  scripting  connections  from  your  local  computer
(Localhost only option is enabled).

Your  firewall  may  generate  a  warning  message  and  ask  you  to  allow  network
communication for 20-sim.

4. Set the firewall to allow communication.

16.3 Scripting Menu
If you  store  the  scripts  in  a  folder  "Scripting"  next  to  your  20-sim  model,  a  Scripting
menu will appear in the 20-sim Editor.

The Examples\Scripting folder contains models with scripting. If you open one  of  these
models, the  Scripting  menu  will  be  visible  showing  several  scripts.  You  can  run  these
scripts directly from the menu.
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16.4 Scripting in Octave/Matlab

Installation for Scripting: Octave

What is Octave?

GNU Octave is a high-level language, primarily intended for numerical computations. The
package is open source and  can  be  freely  distributed.  GNU  Octave  offers  functionality
similar  to  Matlab  users.  If  you  have  experience  with  Matlab,  using  Octave  will  be
familiar. Users with no experience with Octave nor Matlab are advised to read a proper
introduction to GNU Octave first. You will find lot of pages and videos on the Internet.

Installation

The  Windows  versions  of  Octave  7.2.0,  7.1.0,  6.x,  5.x,  4.x,  3.8.x,  3.6.x  have  been
tested with 20-sim scripting at the time of this release.
Note  that  for  older  versions  of  Octave  only  the  32-bit  Octave  is  supported.  64-bit
versions of Octave are supported since Octave 4.2.1.

First choose the Octave version you wish to install and go to the corresponding  section
below:

Octave 7.x / 6.x / 5.x / 4.x

1. Go to: https://www.gnu.org/software/octave/

2. Go to the download page and download the Windows installer (direct link: https://
ftp.gnu.org/gnu/octave/windows/octave-7.2.0-w64-installer.exe)

3. Run the installer and follow the wizard. The steps below assume default installation
settings.

4. Octave 4.0.x only: Unfortunately Octave 4.0.x has a Windows specific bug in its
internal run() function. This bug is resolved in Octave 4.2 and above.
For Octave 4.0.x you will need to manually replace the default run() implementation
with a corrected version. Copy the file:

C:\Program Files (x86)\20-sim 5.0\Scripting\Octave-patch\4.0.0

\run.m

or on 32-bit versions of Windows:

C:\Program Files\20-sim 5.0\Scripting\Octave-patch\4.0.0\run.m

to:

C:\Octave\Octave-4.0.0\share\octave\4.0.0\m\miscellaneous\run.m

5. Launch Octave from the Start menu or using the script: C:\Octave\Octave-x.y.z

\octave.bat

6. Execute the following commands to make sure that the io, control and signal are
installed.
pkg install -forge io

pkg install -forge control

pkg install -forge signal

https://www.gnu.org/software/octave/
https://ftp.gnu.org/gnu/octave/windows/octave-7.2.0-w64-installer.exe
https://ftp.gnu.org/gnu/octave/windows/octave-7.2.0-w64-installer.exe
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The Octave GUI.

Your Octave installation is now ready to use.

Octave 3.8.x

1. Go to: http://www.20sim.com/downloads/files/ThirdParty/octave-3.8.2-2-
installer.exe

2. Run the installer and follow the wizard.

3. Launch Octave using the script: C:\Octave\Octave-3.8.2\octave.bat

4. Execute the following commands to install packages io, control and signal:
pkg install -forge io

pkg install -forge control

pkg install -forge signal

Your Octave installation is now ready to use.

Octave 3.6.x

1. Go to the Octave download site (http://sourceforge.net/projects/octave/.). 

2. Click on the Files tab and click on Octave Windows Binaries.

3. Select the Octave 3.6.4 for Windows MinGW installer.

http://www.20sim.com/downloads/files/ThirdParty/octave-3.8.2-2-installer.exe
http://www.20sim.com/downloads/files/ThirdParty/octave-3.8.2-2-installer.exe
http://sourceforge.net/projects/octave/
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4. Now you can download the files Octave3.6.4_gcc4.6.2_yyyyxxxx.7z

(Octave Installation) and Octave3.6.4_gcc4.6.2_pkgs_yyyyxxxx.7z
(Octaveforge Packages).

5. Create an installation directory which doesn't have space chars (i.e. C:\Octave).

6. Unzip the file Octave3.6.4_gcc4.6.2_yyyyxxxx.7z and copy it to the

installation directory.

7. Copy the shortcut link C:\Octave\Octave3.6.4_gcc4.6.2.lnk to your desktop.

This is a shortcut to start Octave.exe.

Note: Unzipping can be done with programs like 7-zip (http://www.7-zip.org/)
Note: There is a bug with Windows 8 and running Octave. In order to use Octave  start
Octave with octave.exe -i --line-editing. See the Octave wiki webpage for  more

information.

8. Unzip the file Octave3.6.4_gcc4.6.2_pkgs_yyyyxxxx.7z and copy it to the

installation directory.

9. Launch Octave (e.g. the link to Octave.exe).

10. Execute the following five rebuild commands from the Octave console (e.g. re-type
every line followed by ENTER):

pkg rebuild -auto

pkg rebuild -noauto ad

pkg rebuild -noauto nan % shadows many statistics functions

pkg rebuild -noauto gsl % shadows some core functions

pkg rebuild -auto java

The Octave command window.

11. Close and restart Octave.

Setting the Octave Location

1.In the 20-sim Editor choose  Tools - Options - Scripting Client - Octave Folder  to enter
the location where Octave is installed on your computer.

http://www.7-zip.org/
http://wiki.octave.org/Octave_for_Windows#Octave-3.6.4-mingw_.2B_octaveforge_pkgs
http://wiki.octave.org/Octave_for_Windows#Octave-3.6.4-mingw_.2B_octaveforge_pkgs
http://wiki.octave.org/Octave_for_Windows#Octave-3.6.4-mingw_.2B_octaveforge_pkgs
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Installation for Scripting: Matlab

What is Matlab?

Matlab  is  a  high-level  language,  primarily  intended  for  numerical  computations.  The
package is commercially  distributed by the Mathworks. If you don't have the resources
to purchase Matlab, you can run use Octave, which offers similar functionality.

Versions

Matlab R2011, R2012, R2013, R2014, R2015, R2016  and  R2017  have  been  tested  with
20-sim scripting but older and newer versions may also work fine.

Installation

See the Matlab documentation from the Mathworks for information on  installing  Matlab.
No special (additional) installation is needed to use 20-sim scripting from Matlab.

Note: Scripting in Matlab is similar to Octave. You can type exactly the same commands
as given for Octave in the next sections.

Prepare Scripting Folder

20-sim  comes  with  a  Scripting  Folder  that  contains  documentation  of  all  scripting
functions, the function library  and example scripts. You have to install this folder to use
scripting.

Installation

1. Open the Install Scripting program from the Windows Start menu (located under
20-sim 5.0)
- or -
Go to the folder where 20-sim is installed (e.g. C:\Program Files\20-sim 5.0
\Scripting or C:\Program Files (x86)\20-sim 5.0\Scripting)  and open 
20simScripting.exe 

2. This will open a dialog where you can choose where to extract the 20-sim scripting
files. Change the path to a local working folder of your choice (for example: C:
\Users\yourusername\Documents\20simscripting)

20-sim Scripts extraction

Note: To write/modify  scripts, the scripting folder should be  accessible  and  writable  by
the  user.  Do  not  install  the  scripting  folder  on  C:\Program  Files  (x86)  or  C:\Program
Files.

Scripting Working Folder

For the remainder of this chapter,  we  use  the  name  scripting  working  folder  when  we
refer to the folder where you just extracted the 20-sim scripting files.

http://www.mathworks.nl/
http://www.mathworks.nl/
http://www.mathworks.nl/
http://www.mathworks.nl/
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Contents

Your newly created scripting working folder contains a number of subfolders:

1. Models: This folder contains the 20-sim models and data files that are used for the
example and tutorial scripts .

2. Octave: This folder contains all Octave/Matlab scripting functionality and
documentation

a. documentation: This folder contains the scripting API documentation: a list of
supported functions and their syntax. It is a copy of the help file that you can
open in the 20-sim Editor by selecting Help - Octave Scripting API. 

Note: the API documentation is also accessible from the Windows Start menu
under 20-sim 5.0\Scripting API documentation

b. library: This folder contains the core scripting functions.

c. tutorials: This folder contains basis scripts with a step by step explanation. You
can use these scripts as a base for your own scripts.

d. examples: This folder contains some more advanced scripts.

3. Octave-patch: This folder contains modified Octave scripts for certain Octave
versions to fix bugs in the core Octave scripts that are not yet fixed in the latest
release (currently 4.0.0)

4. Python: This folder contains all Python scripting functionality and documentation
(see the Scripting in Python section for more information).

Basic Script

When the scripting files are properly  installed  in  your  scripting  working  folder,  we  can
run some tutorial scripts. Tutorial scripts are a step by step demonstrations of usage of
the scripting functionality in 20-sim. These scripts are found in the tutorials  subfolder of
the scripting working folder. We will start with a basic script that opens and runs  a  20-
sim model.

1. Open 20-sim.

2. Open Octave (or Matlab). 

3. In Octave/Matlab, change the local working directory to the tutorial folder inside
your scripting working folder . E.g . type:

cd 'C:\Users\yourusername\Documents\20simscripting\Octave\tutorials'

Note: 20-sim should be open before running the script!

4. In Octave/Matlab, execute the following command (e.g. type the following case
sensitive command followed by ENTER):

runSimulation

Note: Octave may give a cryptic "undefined near line x  column 1" message, if you type
the command as runsimulation instead of runSimulation!
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5. Now Octave / Matlab will give a message and ask you to press ENTER to continue.

The model ControlledSystem.emx is loaded into 20-sim and simulated. 

6. Again Octave/Matlab will give a message and ask you to press ENTER to continue.

Now the simulation and model will be unloaded.

Inspecting the script

To see how the script is made, you can inspect it with a text editor.

1. Open a file browser and go to the tutorials folder (e.g. C:\Users\yourusername
\Documents\20simscripting\Octave\tutorials)

2. Open the file runSimulation.m with a text editor like Notepad.

Core Functions

The core functions of the runSimulation script are:

addpath:  The  script  starts  with  the  command  addpath('../library/xxsim');  This  will
enable  Octave / Matlab to use  the  20-sim  scripting  functions  that  are  stored  in  the
library subfolder of your scripting working folder.

xxsimConnect: This command opens a connection to 20-sim.

xxSimOpenModel: This command opens a model in 20-sim by giving the  filename
including the full path.

xxsimProcessModel: This command will process the model.

xxsimRun: This command will run a simulation.

xxsimCloseModel: This command will remove the simulation model from 20-sim.

These functions are the basis of scripting in 20-sim and will be present  in  this  order  in
most scripts. Therefore you  can  use  the  script  runSimulation.m  as  a  template  for  any
new script that you create.
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Advanced Scripts

Now that we have seen the core functions of a script we will run and check some more
advanced scripts.

1. Open 20-sim.

2. Open Octave (or Matlab). 

3. In Octave/Matlab, change the local working directory to the tutorial folder inside
your scripting working folder. E.g . type:

cd 'C:\Users\yourusername\Documents\20simscripting\Octave\tutorials'

Set Parameter Values

4. In Octave/Matlab, execute the following script (e.g. type the command followed by
ENTER):

SetParameterAndRun

This  script  will  open  the  model  ControlledSystem.emx  and  run  a  simulation.  Then  a
model parameter is changed and a second simulation run is performed. As explained in
the previous topic, you can inspect the script in a text editor.

Compared to the basic script you will find a new function:

xxsimSetParameters: This function is used to set the parameter in the model with
the new value.

Multiple Runs

5. In Octave/Matlab, execute the following script (e.g. type the command followed by
ENTER):

multipleRun

This  script  will  open  the  model  ControlledSystem.emx  and  run  a  simulation  multiple
times while  changing a parameter. Then  a  model  parameter  is  changed  and  a  second
simulation run is performed.

Read Parameter Values

6. In Octave/Matlab, execute the following script (e.g. type the command followed by
ENTER):

readAndSetParameters

This  script  will  open  the  model  ControlledSystem.emx  and  run  a  simulation.  Then  a
model parameter is read from file  and changed accordingly  in the model, followed by a
second simulation run. 

You will find these new functions:

addpath:  An  additional  path  is  given  (../library/xxlib)  to  allow  addtional  (user
defined) functions. 
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xxlibReadCsv: This function is used to  read  a  parameter  name  and  value  from  a
spreadsheet file.

Store Simulation Results

7. In Octave/Matlab, execute the following script (e.g. type the command followed by
ENTER):

modelVerification

This script will open the model ControlledSystem.emx and run a simulation. After the run
the simulation results are stored and plotted in  Octave/Matlab.  You  will  find  these  new
functions:

xxsimSetLogVariables: Define which variables are going to  be  logged  during  the
simulation run. 

xxsimGetLogVariables:  Export  the  logged  variables  after  the  simulation  run  to
Octave/Matlab.

Examples

8. In Octave/Matlab, change the local working directory to the tutorial folder. E.g. type:

cd 'C:\Users\yourusername\Documents\20simscripting\examples'

here you can find more example scripts.

Writing your own Scripts

Example

We will show you how to write your own scripts using a simple example. We assume that
you have installed a scripting folder and its location is:

'C:\Users\yourusername\Documents\20simscripting'

of course you can use own location. We will copy a 20-sim model to the scripting folder
and write a script that will open this model in 20-sim and run a simulation.

1. Copy the example model FastManipulator.emx to the Octave\tutorials folder. E.g
copy:

'C:\Program Files (x86)\20-sim 5.0\Models\Examples\Drivetrains

\FastManipulator.emx'

to

'C:\Users\yourusername\Documents\20simscripting\Octave\tutorials

\FastManipulator.emx'
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2. Open a text editor (e.g. notepad) and enter the following lines:

run('../library/xxsim/xxsimAddToPath.m');

xxsimConnect();

xxsimOpenModel( 'FastManipulator.emx' );

xxsimProcessModel();

xxsimRun(); 

xxsimDisconnect();

3. Save the text file as:

'C:\Users\yourusername\Documents\20simscripting\Octave\tutorials

\MyScript.m'

4. Open 20-sim.

5. Open Octave (or Matlab). 

6. In Octave/Matlab, change the local working directory. Type in the command line:

cd 'C:\Users\yourusername\Documents\20simscripting\Octave\tutorials'

7. In Octave/Matlab, run your own script. Type in the command line:

MyScript

Now you will see the model being loaded in 20-sim and a simulation being run.

Writing your own scripts 

In the tutorial folder there are more scripts. Use these as a template for writing you own
scripts and follow the guidelines below:

Location

Create  your  own  subfolder  inside  your  scripting  working  folder.  This  allows  you  to
update the 20-sim scripting files when new versions of 20-sim are released. 

Functions

You can find help on scripting functions in the 20-sim Editor by selecting Help  - Octave
Scripting API.
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16.5 Scripting in Python

Installation for Scripting: Python

What is Python

Python is a general-purpose high-level programming language with an emphasis on code
readability  and  writing  algorithms  in  fewer  lines  of  code  than  other  programming
languages. Python is open-source and managed by the Python  Software  Foundation.  It
has  an  extensive  standard  library  and  can  be  extended  with  many  external  libraries
including  a  rapidly  growing  set  of  scientific  and  mathematical  libraries  such  as  SciPy,
NumPy  and  Sympy  and  an  extensive  plotting  library  Matplotlib.  20-sim  scripting  has
been tested with the following versions of Python: Python 2.7.x, Python 3.4.x-3.7.x  (32-
bit and 64-bit).

Installation

During  installation  of  20-sim,  you  are  asked  to  install  the  (optional)  Python  3.7
package. We advise to keep the default setting (Yes) which will install the Python  3.7
installation that  includes  20-sim  scripting  support  and  the  following  packages:  NumPy,
Matplotlib, Sympy, Pandas and IPython. This installation provides just enough support to
get started with 20-sim scripting. However, it does not provide a development IDE or an
extensive set of scientific and mathematical libraries.

Prepare Scripting Folder

20-sim  comes  with  a  Scripting  Folder  that  contains  documentation  of  all  scripting
functions, the function library  and example scripts. You have to install this folder to use
scripting.

Installation

1. Open the Install Scripting program from the Windows Start menu (located under
20-sim 5.0)
- or -
Go to the folder where 20-sim is installed (e.g. C:\Program Files (x86)\20-sim
5.0\Scripting or C:\Program Files (x86)\20-sim 5.0\Scripting)  and open 
20simScripting.exe 

2. This will open a dialog where you can choose where to extract the 20-sim scripting
files. Change the path to a local working folder of your choice (for example: C:
\Users\yourusername\Documents\20simscripting)

20-sim Scripts extraction

https://www.python.org/
http://www.scipy.org/
http://www.numpy.org/
http://www.sympy.org
http://matplotlib.org/
http://www.numpy.org/
https://matplotlib.org/
https://www.sympy.org
https://pandas.pydata.org/
http://ipython.org/
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Note: To write/modify  scripts, the scripting folder should be  accessible  and  writable  by
the  user.  Do  not  install  the  scripting  folder  on  C:\Program  Files  (x86)  or  C:\Program
Files. For the remainder of this chapter, we use the name scripting working folder  when
we refer to the folder where you just extracted the 20-sim scripting files.

Contents

Your newly created scripting working folder contains a number of subfolders:

1. Models: This folder contains the 20-sim models and data files that are used for the
example and tutorial scripts .

2. Octave and Octave-patch: These folders contain Octave/Matlab scripting
functionality and documentation (see the Scripting in Octave/Matlab section for more
information)

3. Python: This folder contains all Python scripting functionality and documentation:

a. controllab: Folder containing the Python classes that allow communication with
20-sim.

b. documentation: This folder contains the scripting API documentation: a list of
supported functions and their syntax. It is a copy of the help file that you can
open in the 20-sim Editor by selecting Help - Python Scripting API. 

c. examples: This folder contains some more advanced scripts.

d. tutorials: This folder contains basis scripts with a step by step explanation. You
can use these scripts as a base for your own scripts.

Basic Script

When the scripting files are properly  installed  in  your  scripting  working  folder,  we  can
run some tutorial scripts. Tutorial scripts are step by step demonstrations of usage of the
scripting functionality  in 20-sim. These scripts can be found in the tutorials  subfolder of
the scripting working folder. We will start with a basic script that opens and runs  a  20-
sim model.

1. Open 20-sim.

2. Open IPython (Interactive Python shell) from the Start menu (under 20-sim 5.0). 

3. In IPython, change the local working directory to the tutorial folder inside your
scripting working folder . E.g . type:

cd C:\Users\yourusername\Documents\20simscripting\Python
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4. In IPython, execute the following command (e.g. type the following case
sensitive command followed by ENTER):

run main_menu

Note that the run  command is specific for IPython. For a standard Python session,  you

can start this script on the command line using: python.exe menu.py. This command

will show a menu with several options including T for Tutorials.

IPython session for the tutorials

5. Select option T and press ENTER to show to enter the tutorials:

Welcome to the 20-sim scripting tutorials for Python.

These tutorials assume that the user has some experience with

scripting and Python.

If this is not the case, consider reading: https://www.python.org/

about/gettingstarted/

or use Octave for scripting if you are more familiar with it.

6. Press ENTER to continue:

 - Tutorial menu -

Select a tutorial:

1 - Run a simulation.

2 - Set a parameter in 20-sim, then run a simulation.

3 - Execute multiple runs with a changing parameter.

4 - Basic simulation result analysis.

5 - Read a parameter from a CSV file and set it in 20-sim.

6 - Retrieve 20-sim model variables and their properties.

Or choose a menu option:

  Q - Quit

  I - Show the introduction text again.

Your choice > 

7. Press 1 followed by ENTER.1
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In this tutorial the scripting interface will:

 - Open a 20-sim model (starting 20-sim if necessary)

 - Process and run the model

 - Close the 20-sim model

8. Press ENTER

The Python scripting interface will now connect to 20-sim.

If 20-sim is not running it will be started automatically.

9. Press ENTER

Connecting, please wait...

The scripting interface has successfully connected to 20-sim.

The tutorial model will be opened.

If you still have an open model. SAVE YOUR MODEL, unsaved changes

will be overwritten.

10. Press ENTER

The model ControlledSystem.emx has been opened in 20-sim.

The model will be processed and simulated.

The 20-sim plot window will open.

11. Press ENTER to load the model ControlledSystem.emx in 20-sim and to simulate it.

The tutorial will now close the 20-sim model and exit.

12. Press ENTER to close the simulation and this 20-sim model

Inspecting the script

Tutorial completed!

Do you want to see the source code? [y/N]

To see how the script is made, you can inspect it by choosing y. This will print the
relevant script lines on the Python console. You can also open the real script in a text
editor like Notepad by opening the file: C:\Users\yourusername\Documents

\20simscripting\Python\tutorials\run_simulation.py.

Important Functions

The important functions / lines of the runSimulation script are:

import  controllab:  Tell  Python  to  load  the  Controllab  package  with  the  20-sim
scripting functions in the XXSim() class.

my20sim = controllab.XXSim(): create a 20-sim scripting object

my20sim.connect(): This command opens a connection to 20-sim.

my20sim.set_scriptmode(): Tell 20-sim that we are  in  scripting  mode  (does  not
show confirmation dialogs)
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my20sim.open_model(): This command opens a model in 20-sim by giving the file
name including the full path.

my20sim.process_model(): This command will process the model.

my20sim.run(): This command will run a simulation.

my20sim.close_model():  This  command  will  remove  the  simulation  model  from
20-sim.

These functions are the basis of scripting in 20-sim and will be present  in  this  order  in
most scripts.

Writing your own Scripts

Example

We will show you how to write your own scripts using a simple example. We assume that
you have installed a scripting folder and its location is:

'C:\Users\yourusername\Documents\20simscripting'

Of course you can use own location. We will copy a 20-sim model to the scripting folder
and write a script that will open this model in 20-sim and run a simulation.

1. Copy the example model FastManipulator.emx to the Python\tutorials folder.

E.g copy:

'C:\Program Files (x86)\20-sim 5.0\Models\Examples\Drivetrains

\FastManipulator.emx'

to

'C:\Users\yourusername\Documents\20simscripting\Python\tutorials

\FastManipulator.emx'

2. Open a text editor (e.g. notepad) and enter the following lines:

import controllab

xxsim = controllab.XXSim()

xxsim.connect()

xxsim.open_model('FastManipulator.emx')

xxsim.process_model()

xxsim.run()

xxsim.disconnect()

3. Save the text file as:

'C:\Users\yourusername\Documents\20simscripting\Python\tutorials

\myscript.py'
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4. Open 20-sim.

5. Open IPython. 

6. In IPython, change the local working directory. Type in the command line:

cd 'C:\Users\yourusername\Documents\20simscripting\Python\tutorials'

7. In IPython, run your own script. Type in the command line:

run myscript

Now you will see the model being loaded in 20-sim and a simulation being run.

Writing your own scripts 

In the tutorial folder there are  more  scripts.  Use  these  as  a  template  for  writing  your
own scripts and follow the guidelines below:

Location

Create  your  own  subfolder  inside  your  scripting  working  folder.  This  allows  you  to
update the 20-sim scripting files when new versions of 20-sim are released. 

Functions

You can find help on scripting functions in the 20-sim Editor by selecting Help  - Python
Scripting API.

Advanced Functionality

Python Distributions

When you need more functionality  or prefer to use an IDE with syntax highlighting and
debugging support, it is strongly  advised to install one of the  following  external  Python
distributions or IDEs:

Anaconda: The World's Most Popular Python/R Data Science Platform.

Spyder: the Scientific PYthon Development EnviRonment with a powerful IDE for the
Python  language  with  advanced  editing,  interactive  testing,  debugging  and
introspection  features  and  a  a  numerical  computing  environment  based  on  SciPy,
NumPy, Matplotlib and IPython.

Python, extended with the Visual Studio IDE and Python Tools for Visual Studio.

Running 20-sim scripts in Python distributions

To add the 20-sim scripting support to your Python distribution, you can use the Python
pip command (installed by default since Python 2.7.10 and 3.4.x) to install the Controllab
package.

1. Open a Windows command prompt (cmd.exe) and type:

cd YOUR_PYTHON_INSTALLATION_DIR\

python -m pip install --no-cache-dir --upgrade "C:\Program Files (x86)\20-sim 5.0\Scripting\Python\whl\controllab-1.3.3-py2.py3-none-any.whl"

Note: use C:\Program Files\20-sim 5.0\ on 32-bit Windows systems.

https://www.anaconda.com
http://pythonhosted.org/spyder/
http://www.scipy.org/
http://www.numpy.org/
http://matplotlib.org/
http://ipython.org/
https://www.python.org/
http://microsoft.github.io/PTVS/
http://microsoft.github.io/PTVS/
http://microsoft.github.io/PTVS/
http://microsoft.github.io/PTVS/
http://microsoft.github.io/PTVS/
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Manual installation of the Controllab package in Python
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17 Unity Toolbox

17.1 Introduction
Unity  is a game engine developed by Unity  Technologies that allows you to create high
visual fidelity, 3D real-time interactive user experiences. The Unity  Toolbox  allows  you
to couple animations created in Unity with a 20-sim simulation model. When you run the
20-sim  simulation,  the  Unity  application  is  shown  and  moves/changes  with  the
simulation.

Features

The Unity  Toolbox will allow you to couple  variables from a 20-sim model to  objects  in
Unity. You can for example couple  the position of an object with the simulated position.
Every  time you start a 20-sim simulation, a Unity  window will be shown   and  changes/
moves while the 20-sim simulation advances.

The Unity  Toolbox does exactly  the same as the 20-sim 3D Animation, but  is  far  more
advanced.  In  Unity  far  more  objects  are  available,  the  quality  of  rendering  (shadow,
light  ,  etc.)  is  far  better  and  there  are  more  display  options  (single  screen,  multiple
scree, VR/AR headsets etc.).

License

The  Unity  Toolbox  does  not  come  standard  with  20-sim.  It  has  to  be  purchased
separately. If you have purchased the Unity  Toolbox you will receive a license key that
will enable the toolbox in 20-sim. 

Example

To see a Unity Animation in action (if you have a valid license) open the example model
Examples\2D Mechanics\ScaraRobot_UnityAnimation.emx.

Getting Started

To get started and learn to work with the Unity  Toolbox, please have a look at  the  the
Reference Manual.

License Required

The Unity  Toolbox is not part of the  set  of  standard  toolboxes  of  20-sim.  It  has  to  be
purchased separately. When you have purchased the Unity  Toolbox, you  will  receive  a
license  code  for  20-sim  that  will  enable  the  plug-in  to  establish  a  run-time
communication between 20-sim and Unity.

17.2 License Unity Toolbx

Purchase

The  Unity  Toolbox  does  not  come  standard  with  20-sim.  It  has  to  be  purchased
separately. If you have purchased the Unity  Toolbox you will receive a license key that
will enable the toolbox in 20-sim. 

No License

Without a valid license, the Unity IntroductionToolbox plug-in will stop the simulation and
present an error message in the 20-sim Editor:

Message: Could not find Unity toolbox license.

https://unity.com
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Error Message when you do not have a license for the Unity Toolbox.

17.3 How does the Unity Toolbox work?

Plug-in

The  Unity  Toolbox  comes  with  a  plug-in  that  has  to  be  installed  in  Unity.  The  plug-in
connects objects created in Unity with variables from a 20-sim model:

1. You can connect objects manually with 20-sim variables.

2. You can import a 20-sim 3D Scenery into Unity.

Coupling with 20-sim

When the Unity 3D Animation is completed and all objects have been connected with the
proper variables from the 20-sim model, you can generate an .fmu (Functional Mockup
Interface) file. You can drag and drop the .fmu file into the 20-sim model.

Simulation

The .fmu file will connect the 20-sim variables with the Unity  application. When you start
the simulation, the Unity application will start up. The Unity  application will show moves/
changes  during  simulation.  Set  the  20-sim  simulation  to  run  in  real-time  to  show  the
Unity application at the right speed.

Export

If you want to use the model with Unity  Application on another location, make sure that
you copy both the 20-sim model (.emx file) and the Unity application (.fmu file).
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17.4 Installing
To get the Unity Toolbox running, you need a working version of Unity and install a  plug-
in for the Unity project that you are working on.

Unity

Unity is a commercial package by Unity Technologies. You can purchase the commercial
Pro version or the free Personal version. There are various videos available  on Youtube
that show you how to install Unity. Note that the Unity Toolbox has been verified to work
with Unity  2018.4, 2019.2, 2020.3.x  (LTS), 2021.2.9f1. It is possible  that it  will  work  in
intermediate and newer versions of Unity.

Plug-In

The Unity  Toolbox comes with a plug-in that has to be installed in Unity.  The  plug-in  is
located in the 20-sim installation folder, usually at:

C:\Program Files (x86)\20-sim 5.0\addons\unity\20-sim-unity-toolbox-x.y.z.unitypackage

Here x,y,z are the version number of the plug-in.  For  every  new  project  in  Unity,  you
have to install the plug-in in your version of Unity:

1. Open Unity and open/start a new (3D) project

2. From the Assets menu select Import Package and Custom Package.

The 20-sim Unity Toolbox ready for use.
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3. Select the plug-in that is located in the 20-sim installaton folder:
C:\Program Files (x86)\20-sim 5.0\addons\unity\20-sim-unity-toolbox-

x.y.z.unitypackage.

4. Click Import.

5. From the GameObject menu select 20-sim and 20-sim Unity Toolbox.

Now the plug-in is installed and ready for use.

The 20-sim Unity Toolbox ready for use.

In the Hierarchy you will see the 20-sim Unity Toolbox listed. You can start to build your
Unity application now.

17.5 Example: Cube

GameObjects

When you have installed the 20-sim Unity  Toolbox correctly, it should be visible  in Unity
in the Hierarchy at the left. You can insert all kinds of Game Objects and connect them
with variables coming from the 20-sim model. Let's start with a Cube.

1. From the GameObject menu select 3D Object - Cube.

Now Cube object is visibe in the Hierachy. 
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Creating a Cube.

2. In the Hierachy select the Cube object.

3. In the Inspector at the bottom right click Add Component - 20-sim Unity
Toolbox - 20-sim coordinates.

Now you will see a 20-sim Variable component in the Inspector. Here you can connect
the  properties  of  the  Cube  with  variables  in  your  20-sim  model.  If  our  20-sim  model
contains a Submodel named Cube with three variables x, y  and z, we can connect these
with the position of the cube.

4. In the 20-sim Variable component keep the Input/Output button on Input.

5. Add the variable names to the x-, y- and z-axis as shown in the next figure.
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Connecting the position of the Cube with 20-sim variables.

In a similar manner you can create many more  Game  Objects  and  connect  them  with
20-sim variables.

Building a Unity Animation

When  all  objects  have  been  defined  we  can  generate  a  Unity  Animation.  Unity
Animations are stored in an .fmu file.

6. In the Hierarchy at the left select 20-sim Unity Toolbox.

7. In the Inspector at the right go to 20-sim Unity Toolbox and Build Unity
Animation.

8. Enter the Export Location (a folder where you have read and write access) and
Animation Name (e.g. Cube) and click Build Unity Animation.
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Building a Unity Animation.

Now the file Cube.fmu will be created in the export location that you have chosen.

Importing the Unity Animation in 20-sim

We will drag and drop the Cube.fmu file into 20-sim and connect the x,y and z input with
signal generators.

9. Open 20-sim

10. From the export location, drag and drop the file Cube.fmu to the Editor.

11. From the Signal/Sources library drag and drop the following submodels in the
Editor:

WaveGenerator-Sine

WaveGenerator-Cosine

WaveGenerator-Saw

12. Connect the sine model with the Cube model (x), the cosine model with Cube (y)
and the saw model with Cube (z).  
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Connecting the FMU.

Running the Unity Animation

When you simulate the 20-sim  model,  a  Unity  Animation  will  pop  up  and  run  with  the
simulation. Generally  the simulation will be much too fast to follow. Therefore  we  must
force the simulation to run in real-time.

13. In the Editor, from the Model menu select Start Simulator.

14. In the Simulator from the Properties Menu select Run.

Forcing a real-time simulation.

15. In the Run Properties dialog click the More button and select Attempting Realtime
Simulation On.
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16. Click Ok to close the Run Properties dialog.

17. From the Simulation menu select Run.

Now you will see a Unity Animation window appear showing the cube moving.

The unity Animation with the cube.

18. In case Unity Animation Window is displayed in windowed mode, Click Alt-Enter to
change the full screen mode.

17.6 Example: Scara Robot

Scenery

The easiest way to start building a Unity  Animation is by importing a 3D Animation from
20-sim. First you build the 3D Animation in 20-sim with simple objects and make sure it
is running correctly. Then you import the 3D Animation  to  Unity  and  use  the  power  of
Unity to create the Animation. Here we will show how this is done with the Scara Robot
example model.

1. Open 20-sim.

2. From the Examples\2D Mechanics library drag and drop the ScaraRobot model.

3. Open the Simulator and run a simulation.

4. Put you mouse pointer on top of the 3D Animation and from the right mouse menu
select Plot Properties.
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Opening the 3D Properties.

5. In the 3D Properties from the File menu select Save Scene. 

6. Click Yes to save the whole scenery.

7. Save the scenery in a location where you have read and write access using the
name ScaraRobot.scn.

Now the 3D Animation is stored in a scenery file.

Opening the 3D Properties.
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Import in Unity

The next job is to import the scenery file into Unity and create a Unity Animation.

8. Open Unity.

9. From the GameObject menu select 20-sim and 20-sim Unity Toolbox.

10. In the Hierarchy at the left select 20-sim Unity Toolbox.

11. In the Inspector at the right go to 20-sim Unity Toolbox and Import 20-sim
Scenery File.

12. Click the Browse button to find the scenery file ScaraRobot.scn.

13. Click the Import 20-sim Scenery button to import the scenery file.

The Scara Robot should now be visible in the scene at the center.

Importing a scenery file in Unity.

Building the Unity Animation

Now we could work on the scene and enrich it by  adding  all  kind  of  GameObjects.  We
will leave this up to your own imagination. The final part of the job is to create a Unity
Animation, generate an .fmu file and import this into 20-sim.

14. In the Hierarchy at the left select 20-sim Unity Toolbox.

15. In the Inspector at the right go to 20-sim Unity Toolbox and Build Unity
Animation.
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16. Enter the Export Location (a folder where you have read and write access) and
Animation Name (e.g. ScaraRobot) and click Build Unity Animation.

Importing the Unity Animation into 20-sim 

17. Open 20-sim with the Scara Robot model.

18. Drag and drop the file ScaraRbot.fmu to the Editor. 

Connecting the FMU.

The Unity  Animation does not have any inputs.  It  uses  global  variables  to  connect  the
simulation to the animation. Therefore we do not have to make connections.

Running the Unity Animation

When you simulate the 20-sim  model,  a  Unity  Animation  will  pop  up  and  run  with  the
simulation. Generally  the simulation will be much too fast to follow. Therefore  we  must
force the simulation to run in real-time.

19. In the Editor, from the Model menu select Start Simulator.

20. In the Simulator from the Properties Menu select Run.

21. In the Run Properties dialog click the More button and select Attempting Realtime
Simulation On.

22. Click Ok to close the Run Properties dialog.

23. From the Simulation menu select Run.

Now you will see a Unity Animation window appear showing the Scara Robot moving.
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24. Click Alt-Enter to change the Unity Animation from full screen to a window.

17.7 20-sim Inspector Properties
If  the  20-sim  Unity  Toolbox  is  installed,  any  GameObject  can  be  connected  to  the
variables coming from a 20-sim simulation. The following object properties can specified.

Input / Output

In most cases the variables that are calculated in 20-sim and epxorted to Unity. You
can keep the Input/Output button to its default setting: Input.

In some cases, however, a variable coming from Unity and exported to 20-sim. Then
you have to set the Input/Output button to Output.

20-sim Coordinates / Unity Coordinates 

When you add the 20-sim Toolbox to a GameObject, you can use 20-sim coordinates or
Unity Coordinates: 

20-sim  uses  a  right-handed  coordinate  system  for  the  position  and  rotation  of
objects. 

Unity uses a left-handed coordinate system frame.

Position / Rotation / Scale

You can couple 20-sim variables with the position, orientation and scale of objects, which
works just like the position, orientation and scale of a 20-sim 3D Animation.

Scripting

In  Unity  you  can  create  script  in  C#  to  tailor  make  GameObjects.  If  you  choose  the
Scripting option in the 20-sim  Variable  section,  you  can  connect  20-sim  variables  with
the public member variables of your C# script.

17.8 Importing 3D Scenery
3D animations created in 20-sim can be exported to Unity. You first have to create a 20-
sim  model,  simulate  it  and  create  a  3D  Animation.  From  the  3D  Animation,  you  can
create a scenery file that can be imported in Unity: 

1. In 20-sim go to the Simulator and put you mouse pointer on top of the 3D
animation.

2. From the right mouse menu, select Plot Properties.

3. In the Plot Properties window, select File - Save Scene.

Now you can open a Unity 3D project and install the 20-sim Unity  Toolbox plug-in. When
this is done properly, the Inspector at the left will show a 20-sim Unity Toolbox.
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You can now import the 20-sim 3D animation into your Unity project:

4. In the Inspector at the right go to the 20-sim Unity Toolbox and Import 20-sim
Scenery File.

8. Click the Browse button to find the scenery file ScaraRobot.scn.

9. Click the Import 20-sim Scenery button to import the scenery file.

17.9 Generating the Unity Animation
In Unity when you select the 20-sim Unity Toolbox from the Hierachy at the left, a  menu
named 20sim unity Toolbox (scripting) is visible in the Inspector at the right. You can
use this menu to create a Unity Animation.
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The 20-sim Unity Toolbox can create a standalone Unity application.

1. In the Export Location, choose the folder where you want to store the .fmu file with
the Unity application.

2. In the Animation Name section enter the file name for the .fmu file.

3. Click on the Build Unity Animation button.

Now an .fmu file will be generated. You can drag and drop this file into your 20-sim
model to run the animation.

17.10Drag and Drop to 20-sim
Once you have created the .fmu file with the Unity  application, you can drag and drop it
to your 20-sim model.

1. Open your 20-sim model.

2. Drag and drop the .fmu file from a File Explorer into the 20-sim Editor.

Scenery File

If the .fmu file  was generated from an 20-sim 3D Animation using a scenery file, it will
only run properly when dropped into the original 20-sim model.
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Inputs

If  the  .fmu  was  created  from  scratch  assigning  variables  to  GameObjects,  these
variables will be inputs in the .fmu in 20-sim. You have to connect these inputs with the
proper generators to get the animation working.

17.11Running the Unity Animation
When you have inserted the .fmu file with the Unity application into 20-sim, you can start
a simulation and the Unity  Animation will appear. Generally  the simulation will be much
to fast. You have to force the simulation to run in real-time, to see a good result.

1. In the 20-sim Editor, from the Model menu select Start Simulator.

2. In the 20-sim Simulator, from the Properties menu select Run.

3. In the Run Properties window click the More button.

4. Set the Attempting Realtime Simulation button to On and click OK.

Make sure the simulation is set to realtime. 
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5. In the 20-sim Simulator, from the Simulation menu select Run.

Now Unity application will open and the simulation will start.

6. Click Alt-Enter to change the Unity Animation from full screen to a window.
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18 Scenario Manager

18.1 Introduction

Introduction

Scripting  is  very  useful to  run  tasks  automatically  but  they  are  not  very
user  friendly  and  intuitive  for  users  with  little  knowledge  of  scripting
languages.  The  Scenario  Manager  fills  this  gap.  You  can  use  it  to  add
actions (basic scripting functions) into a scenario (a set  of actions) and run
that automatically, without any knowledge of scripting languages. 

The Scenario Manager can be used to run all kinds of tasks automatically:

Change all kinds of model settings and run simulations (experiments)
Check simulation outputs against pre-defined results (test automation)
Run simulations and store the results on file (data storage)
Generate C-code of submodels (code generation)

How does the Scenario Manager Work?

When you have a model ready for testing, you can open the Scenario Manager.

1. From the Tools menu select Scenario Manager.

2. Click on Scenario1.

Now you will see an empty Scenario Manager with Scenario1 selected:
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The Pre-simulation bar, Simulation bar and Post-simulation bar allow you to add Actions.
Actions  in  the  Pre-Simulation  bar  will  be  carried  out  before  the  model  is  simulated.
Actions in the Simulation bar will be carried out during a simulation. Actions in the Post-
Simulation bar will be carried out after the model is simulated.

3. Click on the Pre-simulation bar, the Simulation bar or the Post-simulation
bar to add Actions.
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Under the bar a list of Actions is presented. If you click on an Action, it will be added to
the bar.

4. Click on the Action to see its Properties at the right
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You can set the Properties for the selected Action at the left. If you click  on the Recycle
Bin button at the top left, the Action will be removed from the bar.

Scenario

A set of Actions is called a Scenario. You may change the name of the Scenario in  the
tree at the left. If you select a Scenario in the tree, you can run it by  clicking the Play
button (white circle with black triangle) at the top middle.
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Category

A Category may contain a set of Scenarios. You may change the name of the Category
in the tree at the left. If  you  select  a  Category  in  the  tree,  and  click  the  Play  button
(white circle with black triangle) at the top middle, all Scenarios in the Category will be
run.
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As  you  can  see,  the  Pre-simulation  bar,  Simulation  bar  and  Post-simulation  bar  have
different  color  when  a  Category  is  selected.  If  you  add  an  Action,  this  action  will  be
present for all Scenarios under the Category. This is very useful if you have Actions that
have to repeat for every Scenario.

Learn More

To learn more about the Scenario Manager:

1. Run the example model to see how it all works.

2. See which Actions can be used.

3. Inspect the results of an Action, using the logs.

4. Reset the changes made during a Scenario.

5. See where the Scenarios are stored on file.

Tips

You can use the Scenario Manager for a number of tasks. Here are some examples:

1. Run a simulation a number of seconds: You can run a simulation for a certain time
by executing the Modules: Start Simulation - Wait for seconds - Stop
Simulation. 

2. Compare a simulation output with a previously recorded output: You can log a
variable during a simulation with the module Log Variables, store it in a .csv-file
with the Module Generate CSV and then use the Module Compare CSV to compare
this value with a previously recorded value.
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3. Unit Testing: Insert a model from a library with the Update Submodel Module and
then run a test.

4. Parameter Sweep: Set a parameter value and compare the simulation output with a
previous run.

5. Test Automation: Defined the desired output of a simulation run and compare this
with the real simulation output using an Assert model.

Change all kinds of model settings and run simulations (experiments)
Check simulation outputs against pre-defined results (test automation)
Run simulations and store the results on file (data storage)
Generate C-code of submodels (code generation)

18.2 Example

Introduction

You  can  see  the  toolbox  in  action  with  the  example  model  Lifting  System  -  Test
Automation.  We  will  run  this  model  tow  show  you  how  the  Scenario  Manager  can  be
used.

Editor

1. In the 20-sim Editor go to the Library tab

2. In the Library tab select Examples - Signal Processing - Lifting System - Test
Automation.

3. Drag and drop the model to the right to open the model.

Now the Editor will look like:
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As you can see, in the model two AssertSignal blocks have been added. 

AssertSignal1 (Continuous): compares the actual position with the setpoint position.
If both deviate more that 5 cm, the output testResult goes from true to false.

AssertSignal2 (Boolean): The minimum value of the presssures in both chambers is
compared with a constant signal of 5 bar. If any one of the pressures is lower, the
output of the AssertSignal2 block testResult goes from true to false.

We will use the two AssertSignal blocks to veryfy the outcomes of several Scenarios in
the Scenario Manager.

Scenario Manager

Now we will open the Scenario Manager and run some scenarios:

1. From the Tools menu select Scenario Manager.

2. Select Proportional Gains.

The Scenario Manager will look like:
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Category

At the left in the Scenario Manager you will see a  tree  with  Categories  and  Scenarios.
Categories are listed directly  under  Home.  In  the  picture  above  you  see  the  category
Proportional Gains, the Category Valve Settings and the Catergory  Failing Tests.  Under
the Categories, the Scenarios are listed (kp = 4 etc, kp  =  5,  kp  =  6,  Gleak  =   1e-14
etc.). 

In the middle of the Scenario Manager, you can see the various Actions that have been
selected. Each Action will  perform  a  certain  task.  Actions  are  carried  out  sequentially,
from  the  left  to  the  right,  and  from  the  top  to  the  bottom.  In  the  picture  above,  the
category  Proportional  Gains  is  selected.  The  Actions  that  apply  for  this  Category  are
indicated in purple:

Pre-simulation:  The  Actions  that  are  shown  here,  are  carried  out  before  the
simulation. In the picture above no Actions have been selected.

Simulation: The Actions that are shown here, are carried out during the simulation. In
the picture above the Actions Run Simulation and OK to Continue are shown.

Post-simulation: The Actions that are shown here, are carried after  a  simulation.  In
the picture above the two Actions AssertTest are shown.

Scenario

3. Select kp = 4.

Now the Scenario Manager will look like:
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As you can see, the Pre-simulation bar shows one Action extra, Set Parameter. The color
of the Actions is blue.

Actions from a Category are shown in purple.
Actions from a Scenario are shown in blue.
When running a scenario, all Actions will be executed.

In the Scenario of the picture above a parameter value will be set, the a simulation will
be  run  followed  by  asking  the  user  to  press  OK  and  then  check  the  output  of  the
AssertSignal modules.

Running a Category

4. Open the 20-sim Simulator: In the 20-sim Editor click Model - Start Simulator.

5. Move the Simulator window on aside from the Scenario Manager window, so you
can see both.

6. In the Scenario Manager choose the Category Proportional Gains

7. Click on the  Play button .

Now the first scenario of this Category will be run. In the Simulator window you can see
the simulation run:
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8. Press OK after each run.

After the three runs have been performed, the Scenario Manager will look like:

Left  of  the  Scenarios,  you  will  see  V-signs  indicating  that  the  Scenarios  were  run
succesfully: the AssertSignal blocks have given a true output at the end of each run.

9. In the Scenario Manager choose the Category Valve Settings.

10. Click on the Run category button.
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Now three Scenarios will be run without asking  you  to  click  OK.  Left  of  the  Scenarios,
you will see V-signs indicating that the tests were successful.

11. In the Scenario Manager choose the Category Failing Tests

12. Click on the Run category button.

Left  of  the  Scenarios,  you  will  see  red  crosses,  indicating  that  the  tests  were  not
successful: the AssertSignal blocks have given a false output at the end of each run.

Running a Scenario

You can also run a Scenario individually.

13. In the Scenario Manager choose the Scenario Amax = 1e-8

14. Click on the Play button.

Now the Scenario will run. After the Scenario has been run, one of the Actions has a red
edge. If you click  on the Action, you will see the corresponding log. It will  show  that  a
time = 0.16 s the simulation output was deviating too much from the desired value. 

Inspecting a Module

You can inspect a module by clicking on it.

15. In the Scenario Manager click on the Module Set Parameter.

Now the Scenario Manager will look like:
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At the right of the Scenario manager, you can see the settings of this Action. It will set
the parameter of the 20-sim model to a certain value. By clicking on the pencil buttons,
you can change the settings.
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18.3 Actions
The following Actions are available in the Scenario Manager.

Pre-simulation

Add Plot Window: Create a new plot in 20-sim and show variables.

Generate Code: Create C-code from a 20-sim model. 

Implementation: Change the implementation of a submodel.

Log Variables: Log a variable in memory during a simulation run.

OK to Continue: Ask the user to click OK to continue. 

Set Parameter: Change the value of a parameter.

Simulator Setting: Change the settings of the Simulator: Fast mode, Endless mode,
Start time, Finish Time, Event Delta, Output after each, Integration method.

Update Submodel: Exchange a submodel in your model with a submodel from file.

Simulation

Generate Code: Create C-code from a 20-sim model. 

Generate CSV: Store the variables that have been logged on a .csv-file. 

Log Variables: Log a variable in memory during a simulation run.

OK to Continue: Ask the user to click OK to continue. 

Run Simulation: Run a simulation from start time to finish time. If the finish time is
passed, the simulation will  stop,  even  if  endless  simulation  has  been  chosen.  After
passing the finish time the next Module will be executed.

Set Parameter: Change the value of a parameter.

Simulator Setting: Change the settings of the Simulator: Fast mode, Endless mode,
Start time, Finish Time, Event Delta, Output after each, Integration method.

Start  Simulation:  Start  a  simulation  run  and  execute  the  next  module.  The
simulation  will  stop  when  all  Modules  have  been  executed  or  the  Stop  Simulation
Module is executed.

Stop Simulation: Stop a running Simulation.

Update Submodel: Exchange a submodel in your model with a submodel from file.

Wait for Seconds: Wait a number of second before executing the next Module.

Post-simulation

Assert Test: This Module  will ask  you to select a submodel.  It  will  look  inside  this
submodel for a boolean output signal testResult. If this signal is true at the end of the
simulation run, the test was successful and a V-sign is  placed  next  to  the  scenario,
otherwise a red cross will be placed.

Compare CSV: Compare the values in two .csv-files.

Generate Code: Create C-code from a 20-sim model. 

Generate CSV: Store the variables that have been logged on a .csv-file. 

Implementation: Change the implementation of a submodel.

OK to Continue: Ask the user to click OK to continue. 

Set Parameter: Change the value of a parameter.
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18.4 Action Logs
With the Logging Active button displayed:

logging will be active during the running of  the  Scenario.  After  a  run  is  complete,  you
can inspect the log, by clicking on an Action. Now the log of that Action will be displayed
below the Action.

Inspecting the log is useful to see if an action was carried out properly. If an Action fails
(e.g. file  cannot be found, no writing  permission,..),  the  cause  will  be  displayed  in  the
log. 

18.5 Reset Model
With the Reset Model button displayed:

all changes made to a model, during a scenario, will be reset after the scenario has been
run.  This  very  useful  if  you  do  not  want  to  mess  up  you  model,  but  sometimes
unwanted. Uncheck this button, if you want to keep the changes made to the model. 
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18.6 File Storage

File Locations

All settings  for  the  Scenario  Manager  are  stored  in  a  folder  named  Scenario  Manager
with the same folder as the 20-sim model. Suppose you have stored a 20-sim model as:

C:\temp\models\my 20sim model.emx

Then the Scenario Manager files are stored in the folder:

C:\temp\models\ScenarioManager\my20simmodel\

Inside this folder you will find a log file

C:\temp\models\ScenarioManager\my20simmodel\build_server_log.txt

Inside the log file you can see the outcomes of the Scenarios that have been run.

Copies

If  you  want  to  copy  the  Scenario  Manager  with  a  20-sim  model,  make  sure  that  you
copy the folder

ScenarioManager\my20simmodel\

with the 20-sim model.



Index

Getting Started with 20-sim 5.0 273

Index

- . -

.fmu     241

- 1 -

1-3-5-7-9 Polynomial     155, 168

1-junction     73

- 2 -

20sim     4

20-sim     1, 4, 222, 233, 234, 237

20-sim Coordinates     243

20-sim Inspector     252

20-sim scenery file     252

- 3 -

3-4-5 Polynomial     155, 168

3D Animation Editor     133

3D Animation Properties     134

3D Animation Properties window     134

3D Animation window     134

3D Mechanics     78

3D Mechanics Editor     78

3D Mechanics Toolbox     78

- A -

acceleration     164

across     60, 63

Actions     257

Add Plot Window     270

Add Port     36

Advanced Scripts     230

Animation     133

Animation Control     140

Animation Toolbox     133

Assert Test     270

Attributes     47

- B -

Basic Script     228

Block Diagram     47

Block Diagrams     14

Bond Graph     73

Bond Graph Model Demo     73

Bond Graphs     16

Browser     47

B-Spline Networks     146

- C -

Cam Motion Profiles     155

Cam Wizard     152, 155

Camera Movement     79

Cams     152

Category     263

Causal Relation     63

Causality Info     63

C-code     187

C-code templates     187

Change the name     53

Check     47

Check Complete Model     26, 36, 47, 53

Check Model     79

Check Submodel     36

Choose     26

Clear After Every Run     190

closed rectangles     63

Compare CSV     270

connection     79

Connection Mode     36, 47, 79

Connections     47, 60, 68

Contact Modeling     103

continuous pulse     155, 168

Control Toolbox     146

Controller Design Editor     146

Copy from States     190

Create Bond Graph Model     73

Create Connection dialog     79

Create Datafile     190

Create Iconic Diagram Model     60

crossover yerk     155, 168

Cube     243

Cubic     155, 168

current     63

curve fitting     189, 204



Index

Getting Started with 20-sim 5.0 274

Custom Libraries     13

cyclic     155, 168

Cyclic Motions     155, 168

Cycloidal     155, 168

- D -

Deactivate License     8

Deactivation     8

Debug Mode     18, 21, 26

demonstration     4

Description     63

Diagram     60

Discrete-time models     21

Documentation     231

Drag and Drop .fmu     254

dragging and dropping     60

- E -

Edit Icon     53

Editor     10, 18, 47

Empty Submodel     36

End Angle     152

End Time     164

end_time     155, 168

energy     60

Equation Editor     10, 36

equation mainmodel     24

Equation Model Demo     26

Equation Models     26

equation submodel     24

equations     63

Events     21

Export 3D Animation to Unity     248

- F -

F1     26

F1 key     63

Fast Fourier Transform     148

Fast Mode     18, 21

FFT     148

File     47

Filter Editor     146

Find tab     10

floating license     4

free     4

Frequency     148

Frequency Domain Toolbox     148

- G -

General Modified Sine with Constant Velocity    
155, 168

Generate Code     270

Generate CSV     270

Generating Unity Animation     253

Geneva Mechanism     155, 168

Getting Started     1

Ghost Mode for Bodies     79

Ghost Mode for Joints     79

Ghost Mode for Sensors / Actuators     79

global reference     63

Go Down     36

Go Down command     53

Go Up     36, 63

graph submodel     53

Graphical Editor     10, 79

Graphical Model     47

grid     134

- H -

Help file     63

Hierarchy     47, 53

high     63

Histogram     211

- I -

Icon     47, 53

Icon Editor     10, 36

Icon tab     10, 36

Iconic Diagram Model Demo     68

Iconic Diagram Models     60

Iconic Diagrams     15

Implementation     36, 47, 270

implementations     60

Implode     53

Import 20-sim Scenery file     248



Index

Getting Started with 20-sim 5.0 275

included toolboxes     4

Initial Values     20

initial yerk     155, 168

Input     53

Input/Output     243

Insert     68, 79

Insert menu     47, 53

Inserting Junctions     73

inspect     63

installation     224, 233

Installing Unity Toolbox     242

Interface     36

Interface Editor     10, 36

Interface tab     10, 36

intermediate points     47

Intermittent     155, 168

Internal Description     63

introduction     222

inward oriented     63

ipython     233

- J -

jerk     152

Join Parameter Variation     190

- K -

Knot     47, 68

- L -

library     10, 13, 47

Library Browser     10, 13

Library tab     10, 24, 79

License     5

License Unity Toolbox     240

limitations     4

Linear System Editor     148

Linearization     148

Log Variables     270

Logging     271

look at position     140

low     63

- M -

Main Model     26

mainmodel     24

matlab     190, 222, 227

matplotlib     233

mechanical system     68

mechanisms     152

Mechatronics Toolbox     176

Menu Scripting     223

Messages tab:     79

Minimize/Maximize     196

Minimum / Maximum     190, 196

minus     47

Model Browser     10

model library     13, 47

Model menu     53, 63

Model tab     10, 24, 79

Modified Sine     155, 168

Modified Sine with Constant Velocity     155, 168

modified sine with contstant velocity     155, 168

Modified Trapezoidal     155, 168

Module     263

Monte Carlo analysis     211

Monte-Carlo Analysis     189

motion     152, 168

motion profile     152

Motion profile parameters     168

Motion Profile Wizard     164

movements     79

MSC%     155, 168

MSC50     155, 168

Multi-Layer Perceptron Networks     146

Multiple Run results     190

- N -

Neural Network Editors     146

New     47

New Simulation Plot     177

Node     68

Notation     3

Numerical Output     190



Index

Getting Started with 20-sim 5.0 276

Numerical Values     140

numpy     233

- O -

Object Properties     79, 134

Object Representation     79

octave     222, 224

octaveforge     224

OK     190

OK to Continue     270

OneJunction     73

Open rectangles     63

Optimization     196

Optimization Method     196

Optimization Results     196

order     155, 168

Orientation     63, 68

Orientation Info     63

oscillating     155, 168

oscillating signal generators     155, 168

Output     53

Output tab     10

outward oriented     63

- P -

Parameter Optimization     189

parameter sweep     190

Parameter Sweeps     189, 190

Parameters     20, 26

Partial Cubic     155, 168

Partial Trapezoidal     155, 168

Play button     257

Plot     26

Plot Properties     26

Plot Windows     21

Plots     21

plug-in     241, 242

plus     47

PlusMinus     47

Polynomial     155, 168

Port     53

Position     164, 243

Prepare Scripting Folder     227

Process tab     10

professional     4

profile     155, 164, 168

Profiles     155, 168

Properties     26

pulse     155, 168

python     222, 233, 234, 237

- R -

Ramp     155, 168

Real Time Toolbox     187

rectangles     63

Reference     63

Registration/Update License     5

Rename     36, 47

Replay Animation     140

Request License     5

Requirements     5

Reset Model     271

Return Angle     152

Return Time     164

return_time     155, 168

Rotate Left     68

Rotation     243

Rotation Mode     79

Run     26

Run Simulation     270

run tasks     222

running in real-time     255

running the Unity Animation     255

- S -

Save     26, 47

Save as     26, 47

Save Submodel     53

Scale     243

Scara Robot     91

Scenario     257, 263

Scenario Manager     257, 263

Scenario Manager - File Storage     272

Scenario Manager Reset Model     271



Index

Getting Started with 20-sim 5.0 277

Scenario Mmanager Logging     271

scipy     233

Scripting     222, 223, 227, 233, 234, 237, 243

scripting configuration     223

Scripting Examples     223

Scripting Menu     223

scrypting working folder     227

selection mode     36, 47

sensitivity     200

Sensitivity analysis     189, 200

Separate X-Axis     177

Servo Motor Editor     176

Set Parameter     270

Set Values     190

shape     155, 168

Show Name     68

Show Terminals     60, 68

Show Variables     63

signal additions     47

Simulation     26

Simulation Algorithms     21

Simulator     10, 21

Simulator Setting     270

Sine     155, 168

single     4

Single License     5

Splitters     47

standard     4

Start Angle     152

Start Simulation     270

Start Simulator     26

Start Time     164

start_time     155, 168

Steps     190

Stop Angle     152

Stop Simulation     270

Stop Time     164

stop_time     155, 168

Stroke     152, 155, 164, 168

Submodels     24, 47

Sweep     190

sympy     233

- T -

terminals     53, 60, 63

text mode     53

through     60, 63

Time Domain Toolbox     189

Title     26

Tolerance     196

toolbox     4

Toolboxes     22

top reference frame     134

Translation Mode     79

Trapezoidal     155, 168

Type     47

type of motion     164

- U -

Uninstalling     8

Unity     240

Unity Animation     253

Unity Application     241

Unity Cube     243

Unity Import Scenery     252

Unity Simulation     241

Unity Toolbox     240

UnityCoordinates     243

Update Submodel     270

Use as Result     190

- V -

Values     63, 190

Variables     20

Variation Analysis     189, 216

velocity     164

version     4

View menu     63

viewer     4

voltage     63

- W -

Welcome     1



Index

Getting Started with 20-sim 5.0 278

What is 20-sim     9

Writing your own Scripts     231

- X -

XML-RPC     223

- Y -

Y-axis     26

yerk     155, 164, 168




	Welcome
	Notation
	Installation
	Versions
	Requirements
	Installing 20-sim
	Uninstalling
	Deactivation

	Introduction
	What is 20-sim
	20-sim: a quick tour
	Library
	Block Diagrams
	Iconic Diagrams
	Bond Graphs
	Editor
	Variables, Parameters and Initial Values
	Simulator
	Toolboxes

	Equation Models
	Introduction
	Equation Mainmodel
	Equation Submodel

	Block Diagrams
	Block Diagram Mainmodel
	Block Diagram Submodel

	Iconic Diagrams
	Iconic Diagram (Electric)
	View Menu
	Iconic Diagram (Mechanical)

	Bond Graphs
	Bond Graph Model

	3D Mechanics Toolbox
	3D Mechanics Toolbox
	Double Pendulum
	Scara Robot
	Contact Modeling

	Animation Toolbox
	Animation Toolbox
	3D Animation Basics
	Planetary System

	Control Toolbox
	Control Toolbox

	Frequency Domain Toolbox
	Frequency Domain Toolbox

	Mechatronics Toolbox
	Mechatronics Toolbox
	Cam Wizard
	How to use the Cam Wizard
	Cam Motion Profiles

	Motion Profile Wizard
	Motion Profile Wizard
	Motion Profiles

	Servo Motor Editor
	Servo Motor Editor
	How to use the Servo Motor Editor


	Real Time Toolbox
	Real Time Toolbox

	Time Domain Toolbox
	Time Domain Toolbox
	Parameter Sweep
	Optimization
	Sensitivity Analysis
	Curve Fitting
	Monte Carlo Analysis
	Variation Analysis

	Scripting Toolbox
	Introduction
	Installation for Scripting: 20-sim
	Scripting Menu
	Scripting in Octave/Matlab
	Installation for Scripting: Octave
	Installation for Scripting: Matlab
	Prepare Scripting Folder
	Basic Script
	Advanced Scripts
	Writing your own Scripts

	Scripting in Python
	Installation for Scripting: Python
	Prepare Scripting Folder
	Basic Script
	Writing your own Scripts
	Advanced Functionality


	Unity Toolbox
	Introduction
	License Unity Toolbx
	How does the Unity Toolbox work?
	Installing
	Example: Cube
	Example: Scara Robot
	20-sim Inspector Properties
	Importing 3D Scenery
	Generating the Unity Animation
	Drag and Drop to 20-sim
	Running the Unity Animation

	Scenario Manager
	Introduction
	Example
	Actions
	Action Logs
	Reset Model
	File Storage


